1. sammymeken's Avatar
    my wifi used to work perfectly before updating but now it sees the network and connect to it but when i use the browser it loads and loads and then tell me the it couldn't find the requested server any ideas please
    08-15-10 01:58 PM
  2. vinmontRD's Avatar
    my wifi used to work perfectly before updating but now it sees the network and connect to it but when i use the browser it loads and loads and then tell me the it couldn't find the requested server any ideas please
    I personally like 822 better...but 681 should work with your connection.

    Check your APN settings: Options / Advanced Options / TCP/IP

    Make sure the top box "APN Settings Enabled" is checked.

    Make sure the APN specified on the next line is appropriate for your carrier. In my case, I'm on t-mobile, so my APN is "epc.tmobile.com". Every carrier has their own APN. This is the "Access Point Name". If your APN doesn't appear to be related to your carrier, you should find out the appropriate name and make sure it's save in that option.
    08-15-10 02:12 PM
  3. sammymeken's Avatar
    I personally like 822 better...but 681 should work with your connection.

    Check your APN settings: Options / Advanced Options / TCP/IP

    Make sure the top box "APN Settings Enabled" is checked.

    Make sure the APN specified on the next line is appropriate for your carrier. In my case, I'm on t-mobile, so my APN is "epc.tmobile.com". Every carrier has their own APN. This is the "Access Point Name". If your APN doesn't appear to be related to your carrier, you should find out the appropriate name and make sure it's save in that option.
    well i can use the internet throw edge normally, everything works but when i try to use my wifi it wont work
    anyways do u think i should update to 822?? is it really better??
    08-15-10 02:25 PM
  4. vinmontRD's Avatar
    well i can use the internet throw edge normally, everything works but when i try to use my wifi it wont work
    anyways do u think i should update to 822?? is it really better??
    I like 822 -- but a lot of people have used, and are still using, 681 -- so I wouldn't think that's the problem. I wouldn't focus on that just now. You can always upgrade later if you choose. For now, I suggest concentrating on the WiFi issue.

    So -- if you're connecting OK via EDGE, your APN seems to be set correctly.

    Let's look at WiFi:

    I suggest working through the Mobile Network and WiFi settings one by one.

    First - Options / Mobile Network:

    I have:
    Data Services - On
    While Roaming - On (choose carefully -- could be expensive depending on your plan and use of the network)
    Connection Preference: Wi-Fi Preferred -- this will use Wi-Fi whenever it's available, in preference to GPRS/EDGE
    Network Selection Mode: Automatic

    Depending on choices for the options above, you might never be able to connect to Wi-Fi -- important first place to check.

    Next: Options / Wi-Fi
    I have checked "Prompt me when manual connection or login is required"

    I also have half a dozen Wi-Fi profiles saved. If you don't have any yet, you'll have to create one for each Wi-Fi access point you'd like to connect to (although "open" unsecured ones that look alike generally match, so you can walk from one bestbuy to another and generally connect automatically if you have one bestbuy profile defined, for example).

    From the first screen in Wi-Fi options, press the menu buttom and select Wi-Fi Tools. You'll have a choice of Wi-Fi Diagnostics, Site Survey, DNS Lookup and Ping. The first two are important. The Diagnostics will tell you how you're connected, what's working and what isn't with a Wi-Fi connection.

    If you don't have a profile saved yet, scroll down to the empty "Saved Wi-Fi Profiles" list, press the menu button and select "New". On the next screen, you'll have options for "Scan for Networks", "Manually Add Network" and a few others. Try "Scan for Networks" -- this should find your local Wi-Fi access point, allow you to enter a password if one is defined for the connection, and then connect and offer an option to save the connection as a profile. If you've done that successfully, and have "Wi-Fi Preferred" as described under the Network Connections options, you should auto-connect to the Wi-Fi access point whenever you're in range.

    Try all this and then post back results.
    08-15-10 02:39 PM
  5. sammymeken's Avatar
    I like 822 -- but a lot of people have used, and are still using, 681 -- so I wouldn't think that's the problem. I wouldn't focus on that just now. You can always upgrade later if you choose. For now, I suggest concentrating on the WiFi issue.

    So -- if you're connecting OK via EDGE, your APN seems to be set correctly.

    Let's look at WiFi:

    I suggest working through the Mobile Network and WiFi settings one by one.

    First - Options / Mobile Network:

    I have:
    Data Services - On
    While Roaming - On (choose carefully -- could be expensive depending on your plan and use of the network)
    Connection Preference: Wi-Fi Preferred -- this will use Wi-Fi whenever it's available, in preference to GPRS/EDGE
    Network Selection Mode: Automatic

    Depending on choices for the options above, you might never be able to connect to Wi-Fi -- important first place to check.

    Next: Options / Wi-Fi
    I have checked "Prompt me when manual connection or login is required"

    I also have half a dozen Wi-Fi profiles saved. If you don't have any yet, you'll have to create one for each Wi-Fi access point you'd like to connect to (although "open" unsecured ones that look alike generally match, so you can walk from one bestbuy to another and generally connect automatically if you have one bestbuy profile defined, for example).

    From the first screen in Wi-Fi options, press the menu buttom and select Wi-Fi Tools. You'll have a choice of Wi-Fi Diagnostics, Site Survey, DNS Lookup and Ping. The first two are important. The Diagnostics will tell you how you're connected, what's working and what isn't with a Wi-Fi connection.

    If you don't have a profile saved yet, scroll down to the empty "Saved Wi-Fi Profiles" list, press the menu button and select "New". On the next screen, you'll have options for "Scan for Networks", "Manually Add Network" and a few others. Try "Scan for Networks" -- this should find your local Wi-Fi access point, allow you to enter a password if one is defined for the connection, and then connect and offer an option to save the connection as a profile. If you've done that successfully, and have "Wi-Fi Preferred" as described under the Network Connections options, you should auto-connect to the Wi-Fi access point whenever you're in range.

    Try all this and then post back results.

    well i checked everything you said but still the same nothing just saying unable to find requested server but one thing the Connection Preference idont have it at all
    08-16-10 01:57 PM
  6. vinmontRD's Avatar
    well i checked everything you said but still the same nothing just saying unable to find requested server but one thing the Connection Preference idont have it at all
    This makes me think that perhaps UMA is not enabled for your BB. All BB's that can support UMA (also known as "GAN") may be capable, but having the feature turned on is carrier-specific. This is controlled through a combination of the VendorID (a 3-digit code that identified the carrier that originally sold the Blackberry) and the ALX files provided with the OS.

    The VendorID is stored in a place that's generally inaccessible to those of us who muck around inside Blackberry's. There were directions floating around the net about a year ago for "de-branding" your blackberry, but these relied on leaked proprietary files (program and data). I believe the links where these resided were taken down -- not sure if re-posted -- or even if this is a safe procedure.

    But: the point here is that if your BB is originally from a vendor that does NOT support UMA, then it may be necessary to edit ALX files each time you update your OS, so that the UMA support files with the OS are installed in your Blackberry.

    As I recall, two files in particular -- Device.alx and Blackberry.alx -- both part of your OS install (these files appear on your pc after you run the setup program on the PC) -- have sections that look for "UMA=true" (making sure the device itself handles UMA) and "VendorID=100" (in this case, it's look for T-Mobile USA, for example) -- and if this combination is found, the COD files referenced in that section of the ALX will be installed in your device. If the VendorID is wrong -- then the UMA files will not be installed.

    You can manually edit the ALX's (suggest you search and find a couple of articles on this), and add your VendorID in (also easy to locate the list of Blackberry vendorID's via google) to the sections referencing the UMA code if it's not an original T-Mobile Blackberry (or other one, such as Rogers, that supports UMA).

    Finally -- I found one more interesting item, from RIM, that talks about enabling UMA on the device if the Connection Preference item doesn't appear. The article is here, and it states the following:

    If the Connection Preference icon does not display, at the Network icon, type ALT-GANN to turn on UMA connectivity.

    First I've seen this -- probably worth a try. (Hmmm...just looked closer: appears to be a BES configuration book -- probably referring to something on the PC side, but not sure. Suggest you read more closely to be sure before playing, I don't have the time right now - sorry!)

    One last item: there have been a few posts recently about people buying BB's that were originally from non-UMA carriers, and describing a process to make this available via engineering screen settings, etc. If you search a bit, you should be able to find these too.

    Good luck! Let us know what works...
    Last edited by vinmontRD; 08-16-10 at 04:04 PM.
    08-16-10 04:02 PM
LINK TO POST COPIED TO CLIPBOARD