1. grahamf's Avatar
    So basically Last night I opened social feeds on my Pearl and all of a sudden the screen look more or less like this image:

    I had this long paragraph typed out but my internet connection glitched.
    the First pull, it had a lot of artifacts in the corners and the progress bar and eventually glitched completely
    the Second pull, it had minor artifacts, but booted and seemed to have no problems.
    this morning, I woke up to it glitching again.
    first three battery pulls, it glitched.
    the fourth time, it froze on the loading screen. However I received an email and call notification, and was able to hold the phone conversation fine.
    After playing with it, I realized it was working fine, other than the screen.
    I'm trying to revert back to OS 5, but is it toast hardware-wise?
    11-22-10 10:12 AM
  2. kbz1960's Avatar
    Kind of looking like some bad hardware. How long do you leave the battery out for? Maybe a longer time might help?
    11-22-10 10:28 AM
  3. watty85's Avatar
    Not 100% sure, but sounds like it may be a physical problem with your LCD.

    If the O/S revert doesn't resolve the problem, you could try taking it apart and re-seating the LCD cable. If your comfortable doing that. I'm sure it's not needed to be said, but I'd do a Full backup before you try anything. (If you haven't already)
    11-22-10 10:30 AM
  4. grahamf's Avatar
    I've tried a full backup.

    It still has some glitching in the bottom corners, but otherwise working fine.

    It's possible that the cable is loose, as it fell once and I had to partially take it apart to get everything to sit properly.
    11-22-10 10:31 AM
  5. Fubaz's Avatar
    if it fell you could have broken something internally on the lcd.

    id get a replacement if its still under warranty. you dont know if its going to worsen.
    I would say the lcd is pooched.
    11-22-10 10:33 AM
  6. grahamf's Avatar
    Meh, I only paid $60 for it.
    11-22-10 11:12 AM
  7. aznlgcy's Avatar
    It might be a broken flex cable.
    11-22-10 01:18 PM
  8. grahamf's Avatar
    It now seems to be fine. I haven't tried Social feeds again, but there are NO artifacts or glitching.
    11-22-10 08:05 PM
  9. grahamf's Avatar
    *Update*
    No problems since the incident.
    Still have no idea what the **** happened.
    12-06-10 12:52 PM
  10. dictoresno's Avatar
    looks like either a hardware malfunction or flex cable issue. if its working fine now, then who knows. if it happens again, maybe take it apart and make sure the flex cable is properly snapped into the circuit board.
    12-07-10 12:32 AM
LINK TO POST COPIED TO CLIPBOARD