1. AYARI BEDIE's Avatar
    DEAR ALL :
    I have a big problem with my Blackberry 8900 Curve this morning, it will not turn on, if you could help me, I would be very grateful.
    Thank you all
    09-03-11 07:34 AM
  2. Iceman's Avatar
    I know this sounds elementary but I have to ask the following:

    1. Have you let the battery die by chance?
    2. Have you tried a battery pull? If not take battery out of device and wait 30 seconds. Place battery back into device and try boot sequence.
    3. It hasn't been in/or around water has it?
    AYARI BEDIE likes this.
    09-03-11 07:42 AM
  3. jonathon.94's Avatar
    Also does it show any red light when you try to turn it on.

    Posted from my CrackBerry at wapforums.crackberry.com
    AYARI BEDIE likes this.
    09-03-11 07:49 AM
  4. AYARI BEDIE's Avatar
    ok the ansr for your question
    1 yesterday neight I forget to put my bb in the charge
    2-i tryed to remouve the battery but nothing happened just the led red is turn on
    3-I don't understand the last question
    09-03-11 07:49 AM
  5. dictoresno's Avatar
    ok the ansr for your question
    1 yesterday neight I forget to put my bb in the charge
    2-i tryed to remouve the battery but nothing happened just the led red is turn on
    3-I don't understand the last question
    soooooooooooooo. plug it in and charge it for awhile then try again. i mean really???
    AYARI BEDIE likes this.
    09-03-11 08:37 AM
  6. AYARI BEDIE's Avatar
    I put it in the charge 5 hours but the same problem
    09-03-11 09:23 AM
  7. SwitchBeach's Avatar
    Was the device exposed to ANY moisture at all? Even a little tiny bit?
    AYARI BEDIE likes this.
    09-03-11 09:59 AM
  8. AYARI BEDIE's Avatar
    is not exposed to any moisture
    09-03-11 11:02 AM
  9. SwitchBeach's Avatar
    Has it been dropped?

    Steamy bathroom, sweaty pocket, wet hands, wet hair, rain, snow, high humidity?

    It is difficult for others to help if you are not giving much information.
    09-03-11 11:08 AM
  10. bustermin's Avatar
    Has it been dropped latley? have you tried turning it on WHILE plugged into the charger or tried a different battery? try plugging it into pc and see if it the computer can connect with the device, if not then open ddm and try to restore or reinstall OS as last resort. if none of that works I would suspect some type of hardware damage.
    09-03-11 11:08 AM
  11. AYARI BEDIE's Avatar
    yesterday night a put it in the tabel and I m going to work and the morning when I m caming I found that the bb don't work I try to put it , work , but they didn't turn on
    09-03-11 11:27 AM
  12. AYARI BEDIE's Avatar
    ok I'will try that mr bustermin
    09-03-11 11:28 AM
  13. bustermin's Avatar
    yesterday night a put it in the tabel and I m going to work and the morning when I m caming I found that the bb don't work I try to put it , work , but they didn't turn on
    This doesnt mean it was not exposed to the previously mentioned conditions PRIOR to you putting it on the table. Have you tried doing any of the suggestions to help people help you. with no more information and no other history is will be difficult to help.
    09-03-11 11:31 AM
  14. jonathon.94's Avatar
    It could be POSSIBLE that he could have a nuked OS does anyone else agree?
    09-03-11 11:40 AM
  15. rrrebo's Avatar
    Yup, try plugging it into your PC and reloading the OS. It's also possible that and 8900 battery has reached the end of its service life and died permanently. Has your battery life been short lately?

    Posted from my CrackBerry at wapforums.crackberry.com
    09-03-11 12:01 PM
  16. AYARI BEDIE's Avatar
    dear friend I try all the possibilte I put it 5 hors in the charge put he didn't turn on I put it olso in the cabel usb and he didn't turn of just the red led his falchin 3 time and he is stoped right now
    09-03-11 01:26 PM
  17. chiefbroski's Avatar
    You're trying to charge it using the usb cable to computer aren't you? Don't do this. The battery is really low. Use a WALL CHARGER. Should fix the problem. Happened to my Storm. Let me know if this works.

    Posted from my CrackBerry at wapforums.crackberry.com
    AYARI BEDIE likes this.
    09-03-11 01:32 PM
  18. AYARI BEDIE's Avatar
    dear friend :
    I didn't find any soulution for my BB I put it in charge 5 hours but he didn't turn on , I tryed with USB cabel and he didn't turn on also ,for the red led in the first he work but when I put it in the PC he flaching 3 times or 4 times and nothing it's happened ,and for your information my battery has life been short lately , and I didn't put it in the high humidity also I didn't try with other battery .
    can you give me other solution please.
    09-03-11 05:22 PM
  19. calicocat2010's Avatar
    Get a New battery, or new phone.
    09-04-11 02:10 AM
  20. AYARI BEDIE's Avatar
    My friend my blackberry turn on the solution is to put the BB in wall charger for 5 hous and he will tun on thank you all fou your saport.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-04-11 02:26 PM
  21. Laura Knotek's Avatar
    My friend my blackberry turn on the solution is to put the BB in wall charger for 5 hous and he will tun on thank you all fou your saport.

    Posted from my CrackBerry at wapforums.crackberry.com
    Buy a new battery.
    09-04-11 03:34 PM
  22. Rootbrian's Avatar
    Buying a new battery would help. Dirt cheap from ebay, $7 or $17, somewhere around that.

    Google three beeps, you'll find that it relates to a board issue, since blackberries are like computers. If they're short beeps, or long beeps.

    Three long: keyboard cord/connector error. (Short on the circuit board)
    Three short: base 64k RAM error. (Flash/Memory is worn out), aka paperweight.

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by Rootbrian; 09-04-11 at 06:00 PM.
    09-04-11 05:57 PM
LINK TO POST COPIED TO CLIPBOARD