1. tone7888's Avatar
    Sad to report my wonderful Blackberry bold has moved on. Last Thursday I received a white screen with a battery and lightning running through it. When I visited the AT&T store they removed my old battery and put one in they had in the back. Well when they did that there was a 507 error, no operating system. So not sure what happened they think it may have been a power surge. But it was under warranty so they gave me a new phone but claimed my battery showed a little water damage, so no free battery. But my battery will be here Wednesday so I will back in business. Has anyone else experienced this?
    Last edited by tone7888; 06-24-09 at 07:45 PM.
    06-24-09 07:35 PM
  2. Username00089's Avatar
    A bad battery wouldn't wipe the OS. That's all I'm going to say.
    06-24-09 07:37 PM
  3. username0022's Avatar
    I would've tried, http://forums.crackberry.com/f3/how-...ckberry-32322/, before heading into the AT&T store where they definitely wouldn't have been able to solve your problems without screwing you over, first...

    But as forever said, I'm not thinking a bad battery was the cause.
    06-24-09 07:39 PM
  4. giancarlo93's Avatar
    Sad to report my wonderful Blackberry bold has moved on. Last Thursday I recieved a white screen with a battery and lightning running through it. When I visited the AT&T store they removed my old battery and put one in they had in the back. Well when they did that there was a 507 error, no operating system. So not sure what happened they think it may have been a power surge. But it was under waranty so they gave me a new phone but claimed my batter showed a little water damage, so no free battery. But my battery will be her Wednesday so I will back in bussiness. Has anyone else experienced this?
    I just got a bold that fell into water.
    It worked perfect but the battery was dead...
    I bought a new one and it show me the white screen with de battery and lightning running trought it. I just conected it to the pc and reload the OS.
    Now the phone works great.
    06-24-09 07:43 PM
  5. tone7888's Avatar
    I wonder if they did something, and thats why there was no big fuss giving me a new Bold for free. Anyway I will remember that next time I see that screen, giancarlo93. It was so weird because It had been working fine all day, I used the USB to charge it at work, took it off the charge placed it in the case. I went lunch and when I went to look at the phone there goes the white screen.
    06-24-09 08:10 PM
  6. giancarlo93's Avatar
    I wonder if they did something, and thats why there was no big fuss giving me a new Bold for free. Anyway I will remember that next time I see that screen, giancarlo93. It was so weird because It had been working fine all day, I used the USB to charge it at work, took it off the charge placed it in the case. I went lunch and when I went to look at the phone there goes the white screen.
    Sorry but I dont know whats happening with yours.
    Mine was a wet bold so I though it was the battery that died with the water
    06-24-09 09:21 PM
LINK TO POST COPIED TO CLIPBOARD