1. Brazen9000's Avatar
    The screen on my Torch 9800 has started to behave erratically. I touch an icon on the right hand side and an icon on the left hand side lights up. Then it goes for a few hours working perfectly and then again, bang, back to bizarro land.

    I was reluctant to call Rogers (my carrier) for help for two reason. (1) It's not a phone they sold me. I've bought iPhones from them but missed BB and went back to Blackberry by trading for a Torch (that was originally with AT&T).

    (2) I pay Rogers about $1500 a year. They have shafted me at every turn. I brought an iPhone 3GS into the store with a problem. They guy looked at it, saw there was no water damage and sent the phone away for repair. I got a new one sent out. Then, the guys it was sent to said it was water damaged and I was slapped with a $500 bill for the new phone! I asked for the old one back and asked to return the new one. They said I couldn't that my old one had been thrown away. Did it get wet in transit? No idea, all I know is that I was $500 out of pocket.

    Then there was Rogers brilliant iPhone 4 pr. They offer it as an upgrade to me. But there's none in stock. It's backordered. By the time they get some in the offer to me and others of an upgrade to it has expired! Brilliant Rogers, just brilliant.

    There have been many more such incidents.

    So today I bit the bullet and called Rogers for help about my beloved Torch. As expected (although this time they may have had cause). They told me, essentially,to go procreate myself.

    So, any idea what I can do to either fix the problem or, if it's mechanical, get some help from somewhere?
    02-13-11 12:23 PM
  2. K Bear's Avatar
    Hate to say it, but you are SOL.
    02-13-11 12:31 PM
  3. Brazen9000's Avatar
    I figured I've noticed it is worsened under updating the OS to 6.0.0.0.480. I may simply restore the initial os.
    02-13-11 01:31 PM
  4. K Bear's Avatar
    I could suggest doing a clean wipe, then reload the OS. It may help, but I believe that your problem is hardware related, not software related.
    02-13-11 02:36 PM
  5. anon1937793's Avatar
    Definitely try doing a wipe with BBSAK and reinstalling the OS. Unfortunately however, it sounds like a hardware issue.

    I hate Rogers too... Between Robbers and Fido over the last 8 years I think I have spent around 10k on my cell phone alone, and still only when I threaten to switch carriers can I get anything out of them...

    EDIT: And I also use an unlocked phone, and if I ever call in with a problem they say go **** yourself and then offer to sell me one of their phones...
    Last edited by Alex338; 02-13-11 at 11:34 PM.
    02-13-11 11:32 PM
  6. RegN's Avatar
    I don't like rodgers cause there serice area sucks for me. But as your gripes with them go they are the same as bell or telus. I hated telus and switched to virgin. Guess what? They just want my money too make a big deal of answering the phone to talk to you. Only thing is they say the words. Go pound sand and have a nice day

    Posted from my CrackBerry at wapforums.crackberry.com
    02-14-11 09:52 AM
  7. pkcable's Avatar
    Sounds like hardware to me also, and I hate to even say it, BUT it sounds like moisture damage. You might want to try the rice trick. That is placing the device, battery removed in a container of uncooked rice for 24 to 48 hours to draw our moisture. Also there are BB repair places in most major cities, in particular near Montreal Canada and New York US.
    Brazen9000 likes this.
    02-14-11 10:00 AM
LINK TO POST COPIED TO CLIPBOARD