1. schaidshaw02's Avatar
    I hae had people in the past send me MMS messages, only to have them lost forever. I never recieved them. Is it something with the phone or is there a setting that I can change? Oh, I have the 8830 World Phone for Verizon.
    07-31-08 04:51 PM
  2. jenaywins's Avatar
    Check your available memoury. Options>Status.
    07-31-08 04:52 PM
  3. theprep's Avatar
    The 8830 can't get mms. It'll direct you to pix place.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-31-08 05:14 PM
  4. jenaywins's Avatar
    I was almost positive that the WE could still receive MMS, you just cannot send them.
    07-31-08 05:16 PM
  5. 49ways's Avatar
    According to phonescoop.com, some versions of the 8830 support MMS.
    07-31-08 05:29 PM
  6. schaidshaw02's Avatar
    It doesn't make any sense if you can't recieve them....
    07-31-08 05:29 PM
  7. mab4285's Avatar
    Mwahahahah....somebody else can't get MMS besides us folks over at sprint.

    LOL...just jokin with you guys!

    Posted from my CrackBerry at wapforums.crackberry.com
    07-31-08 05:34 PM
  8. 49ways's Avatar
    I just don't know the answer since I don't have an 8830. And I've never used one.
    07-31-08 05:35 PM
  9. i2sam77@yahoo.com's Avatar
    You should at least receive a message saying message could not be received if it was a memory issue. options/settings/MMS/Multimedia reception set to Always You can also go to
    options/settings/smstext/network to send over,choose the the appropriate setting. If you have veriz you will choose GPRS.
    Let me know if this works
    08-01-08 09:09 AM
  10. Fubarberry89's Avatar
    Mine will take me to the online photo album, but i've never been able to send mms
    08-01-08 10:02 AM