1. eldorado01's Avatar
    First of all, I'm new to the forum and I apologize in advance if I'm repeating an already existing thread or posting on the wrong place.

    I just got two Verizon 9650s yesterday, one for my wife and one for me. She asked me to set up the Bluetooth on her 2008 Mercedes C300. I paired them, entered the code 0000 on both places and they shook hands.

    Her car will take incoming phone calls normally, make outside calls if dialed through the phone keypad because the car won't recognize or accept her contacts, and, if I call from my 9650, her phone will ring, not the car. iI will then give her an option to accept the call on the car (bluetooth) or the handset, she chooses bluetooth and then my call will transfer to the sound system.

    It recognizes her phone (called Jeanberry) but the screen display unknown.

    Any ideas or help? Please help a newbie.
    09-04-10 06:07 PM
  2. Monty2004's Avatar
    Trade the Mercedes for a BMW. It works fine on my X5.
    09-04-10 10:23 PM
  3. pammydd's Avatar
    I'm having the same problem with my bold and my husband is having the same problem with his storm. The screen just says unknown caller and the bluetooth takes over the radio. Both of ours are after market radios not factory in our vehicles. Mine worked fine on my van until about 3 day's ago and my husbands only worked for a couple of weeks after he got his storm 2. Any solutions would be appreciated
    09-04-10 10:41 PM
  4. eldorado01's Avatar
    To a moderator: would it be better to move this thread to the bluetooth section? Thanks.
    09-05-10 11:20 AM
  5. TheScionicMan's Avatar
    Trade the Mercedes for a BMW. It works fine on my X5.
    What advice would you give on a problem in a BMW? According to RIM support and BMW website, 9650 is not supported. That's pretty much when they tell me I'm SOL. It will pair but just connects and disconnects...
    09-10-10 06:46 PM
  6. Monty2004's Avatar
    What advice would you give on a problem in a BMW? According to RIM support and BMW website, 9650 is not supported. That's pretty much when they tell me I'm SOL. It will pair but just connects and disconnects...
    True, it's not on BMW's official list, but it does work correctly in my case. If I had a problem, I would be out of luck since they would take the party line of it being unsupported. It takes time, but it will eventually show up on their list.
    09-10-10 10:31 PM
  7. thenameless1's Avatar
    Trade the Mercedes for a BMW. It works fine on my X5.
    +1

    (Audi works great too)

    09-11-10 05:29 AM
  8. mushie143's Avatar
    I'm having a Mercedes/Blackberry issue too. I have a Bold 9650 that I use via Bluetooth in my 2010 E350. My telephone # is permanently blocked through Verizon (have to dial *82 to unblock) but when I am in my car and dial a # it will automatically unblock my #. Has anyone ever had this happened to them?
    09-11-10 12:44 PM
  9. Kilgore Trout's Avatar
    I have a BMW 3-series. Used a BB Tour (9630) in it for the last year with no problems whatsoever. Bluetooth worked fantastic. Last night, we tried to pair my sister's BB Bold (9650) and had one problem after another. It would connect, but phone book did not load and the connection was sporadic at best.
    11-26-10 12:57 PM
LINK TO POST COPIED TO CLIPBOARD