1. go1ndr's Avatar
    My wife's 2009 MBZ C-300 wouldn't pair with her new 9800 Torch and caused constant ringing when both pairing with car and pairing with headset. No matter what we did, it wouldn't stop. The minute the car was turned on and radio on (car is bluetooth compatable) her phone would start ringing and wouldn't stop--same with her headset. I deleted the devices and reinstalled them but the outcome was the same. I went to this and other forums and no responces due I would assume the phone being so new. Finally I called tech support and this is what I found to be the answer.
    OK-for anyone else that may have this problem with the 9800 torch and Mercedes Benz pairing (or pairing any other device) here is the fix for the problem.
    The answer is to delete devices under bluetooth settings on phone--then power off phone using the icon on phone; and THEN (and this is the key) take battery out of phone to cause software reboot. Keep battery out of phone for at least 30 seconds to a minute and then reinstall and allow phone to reboot and power back on. Once this is done, re-pair the car and headset if desired and it should work fine. I was on with tech support for over an hour figuring this out and the answer was that it device simply went crazy and needed to be rebooted--which I learned is not done by powering off but "ONLY" by removing the battery. Hope this helps others who may run into this problem!
    Thanks! Go1ndr
    09-13-10 04:07 PM
  2. NoahFecks's Avatar
    A battery pull for 30 seconds is usually the first piece of advice given when something isn't working correctly on any model BlackBerry. Don't know why you wouldn't have gotten this advice in the first place.
    09-13-10 04:54 PM
LINK TO POST COPIED TO CLIPBOARD