1. featherz's Avatar
    but right now it is frustrating me..plz help.

    I just bought my BB curve 8900 and have been having trouble receiving my emails. I went through tmobile and set up my yahoo email and bb email but still am not receiving them to my phone. I'm a BB newbie so I have no idea what to do about this.

    Also my the facebook app wont load I click on it under downloads, type in my e-mail and and password but only get a 'could not connect because a data service is not available' message.

    I've been searching in the forum but haven't come across something that worked anyone have suggestions for a very frustrated BB newbie!
    03-23-10 10:22 PM
  2. Laura Knotek's Avatar
    Do you have a BlackBerry data plan?
    03-23-10 10:27 PM
  3. Crackb3rry420's Avatar
    Def doesn't have data lmao..nd send ur service books for ur email..when u activate ur data

    Posted from my CrackBerry at wapforums.crackberry.com
    03-23-10 10:29 PM
  4. heyitsbailey's Avatar
    isnt the data plan "required" to get a blackberry?

    i dont see why a carrier would give a phone like that and just not give a data plan included (either free or like $20)
    03-23-10 10:39 PM
  5. fedge's Avatar
    but right now it is frustrating me..plz help.

    I just bought my BB curve 8900 and have been having trouble receiving my emails. I went through tmobile and set up my yahoo email and bb email but still am not receiving them to my phone. I'm a BB newbie so I have no idea what to do about this.

    Also my the facebook app wont load I click on it under downloads, type in my e-mail and and password but only get a 'could not connect because a data service is not available' message.

    I've been searching in the forum but haven't come across something that worked anyone have suggestions for a very frustrated BB newbie!
    1st like the other do you have a data plan ? 2nd have you tried povisioning your browser or calling T-mobile to setup your data service on your device via 611 ?
    03-23-10 10:52 PM
  6. featherz's Avatar
    I do have data service which is why this is so frustrating.
    03-23-10 11:07 PM
  7. heyitsbailey's Avatar
    ok

    well where it shows if you got 3g, is it all caps (all data) or lower case?
    or does it say GSM?
    03-23-10 11:10 PM
  8. Laura Knotek's Avatar
    Try logging in to your BIS here and resending your service books.
    03-23-10 11:11 PM
  9. heyitsbailey's Avatar
    you can also resend your service books if you go to Settings > Options > advanced Options > Host Routing Tables. Press Menu and click "resend service books". hope that works too
    03-23-10 11:12 PM
  10. Greasemonkeyjoe's Avatar
    I would just call TMO from another line and have them walk you through it. It may be something on their end or just something stupid.
    03-23-10 11:51 PM
  11. F0nage's Avatar
    but right now it is frustrating me..plz help.
    Don't worry, you will love it when you get it working. Normally it takes no effort at all, just turn it on and go. Sometimes you need to double check a few things.
    03-24-10 04:49 AM
  12. heyitsbailey's Avatar
    Have you tried a Battery Pull?
    03-24-10 10:44 AM
  13. qbnkelt's Avatar
    I do have data service which is why this is so frustrating.
    You have data service, but do you have a Blackberry plan?
    03-24-10 11:33 AM
  14. Branta's Avatar
    isnt the data plan "required" to get a blackberry?

    i dont see why a carrier would give a phone like that and just not give a data plan included (either free or like $20)
    There can be a difference between what you need, what you ordered, and what actually gets activated on your account. Cockups happen
    03-24-10 11:35 AM
LINK TO POST COPIED TO CLIPBOARD