Built for Business - Learn more about BlackBerry KEY2
  1. realized's Avatar
    I live in Orange County, California, where 3G is slow and AT&T rarely works. When my phone thinks it has service(will show 3G and 2-3 bars, but wont have any service) , and I have WIFI, it tries to use the 3G instead of WIFI

    A workaround for me to get online is to disable my mobile network and just have my WIFI enabled. Then I can go online and do what I need to do. Later I need to remember to re-enable my mobile network so I can make and receive calls and txt messages.
    12-14-09 01:18 PM
  2. Username00089's Avatar
    If Wi-Fi is already on and actually connected and your Wi-Fi turns off and goes to
    3G then there is something wrong with your Wi-Fi connection.
    12-14-09 01:21 PM
  3. realized's Avatar
    There is nothing wrong with the wifi, its just the phone tries to use 3g for internet first.

    if i disable my phone and only have wifi enabled, everything is perfect.

    i go through this daily
    12-14-09 01:50 PM
  4. Username00089's Avatar
    There is nothing wrong with the wifi, its just the phone tries to use 3g for internet first.

    if i disable my phone and only have wifi enabled, everything is perfect.

    i go through this daily
    If Wi-Fi is actually enabled and whited out, the phone does not try to use
    the cellular connection first when using the internet. If Wi-Fi is whited out,
    it takes precedence for data on the phone. BBM, browser, etc.

    It should auotmatically use the hotspot browser when connected. If not, you
    need to manually change it in the settings in the browser.
    12-14-09 01:56 PM
  5. sourkevin's Avatar
    mine always defaults to 3G even if the wifi is on and connected (white not gray)
    12-14-09 03:25 PM
  6. Username00089's Avatar
    mine always defaults to 3G even if the wifi is on and connected (white not gray)
    You need to set it to the hotspot browser then
    12-14-09 03:48 PM
  7. dcgore's Avatar
    Hmmm im thinking you need to turn the radio off. Try the suggestion above and let us know if that does it please.
    12-14-09 03:53 PM
  8. sourkevin's Avatar
    You need to set it to the hotspot browser then
    I have the left key to short cut to browser... tried looking specially for the HotSpot but only found the MediaNet.... didnt think that helped any

    on a side note... too bad you cant look at router(linksys) pages while on the bold any advice? Had to use my ps3 to add a MAC addy to the router....
    Last edited by sourkevin; 12-14-09 at 06:17 PM. Reason: Retarded
    12-14-09 06:16 PM
  9. Username00089's Avatar
    I have the left key to short cut to browser... tried looking specially for the HotSpot but only found the MediaNet.... didnt think that helped any

    on a side note... too bad you cant look at router(linksys) pages while on the bold any advice? Had to use my ps3 to add a MAC addy to the router....
    When you open your browser go to the options. You'll find the setting there.
    12-14-09 06:37 PM
  10. digitalb0y's Avatar
    Whenever I'm connected to a router the 3G icon top right disappears and I see the WiFi icon. No extra settings were needed and I never switch to the hotspot browser. What happens if you disable 2G or 3G? Maybe that icon's only coming back when you're handing off between them?

    I you're really sure it's using mobile data and not WiFi you can just set Manage Connections to one of your convenience keys and switch off either the radio or your data plan. The shortcut key for the browser is B, by the way, as long as "Dialing From the Homescreen" is set to No. No need to waste a convenience key on the browser.

    If you are losing your connection here and there it could fail over to 3G, and something's wrong if you can't see your router from your Bold (unless you have the router set not to broadcast your SSID). I'd delete and recreate the WiFi connection, and perhaps check settings on your router to make sure nothing is set to reset your connection.
    12-15-09 02:19 AM
  11. psiclne's Avatar
    I'm in Irvine/Tustin and I always get full 5 bars on 3G.

    If you open the browser before wifi is connected the device will stay on 3G, correct me if I'm wrong.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-15-09 05:19 AM
  12. digitalb0y's Avatar
    If you open the browser before wifi is connected the device will stay on 3G, correct me if I'm wrong.
    Not on mine.
    12-15-09 05:34 AM
  13. Username00089's Avatar
    I'm in Irvine/Tustin and I always get full 5 bars on 3G.

    If you open the browser before wifi is connected the device will stay on 3G, correct me if I'm wrong.

    Posted from my CrackBerry at wapforums.crackberry.com
    That actually used to happen to me on certain OS's.
    12-15-09 09:47 AM
  14. sourkevin's Avatar
    When i swapped into HotSpot Browser and the use the internet, the WIFI was used as the primary connection, however, if your out of wifi the phone yells at you and states that the HotSpot in only enabled for Wifi...

    so back at square one... how do we set up the browser to use the WIFI first, and then 3G/Edge if there is no Wifi to use without changing settings?
    12-15-09 01:25 PM
  15. sneakytiki64's Avatar
    This doesn't answer your question but switch your phone to only use 2G.... EDGE class 12 is just as fast for me in Orange county as the 3G and 100% stable. At least when your phone uses the radio first it will work lol....
    Last edited by sneakytiki64; 12-15-09 at 02:34 PM.
    12-15-09 02:23 PM
LINK TO POST COPIED TO CLIPBOARD