1. shah1237's Avatar
    Hello friends,

    I got a replacement handset and the problem of wifi seems to still exist.
    I searched on the forum, and found articles to enable wifi for browser but they donot work.
    here is my situation.

    I want to connect to wifi and do browsing but dont want to use my data plan
    usage. I have set the data connections off and switched on wifi.

    I can connect to wifi, it shows connected, but when i go to browser type in any website it give error, " unable to connect to the internet, please try again later."


    now if i go and switch on data connections, i can browse but i dnt knw whether it is using my wifi network or coming off from my data usage.
    this is the part i am trying to work out....

    i come from a windows phone and it was easy to jst switch off data and use jst wifi for everything.

    i am guessing, there is some settings which i am not aware of.

    Also, the phone does not identify wireless n routers, even though the phone is wifi enabled (rim website says it). I have to change the frequency from 5ghz to 2.5ghz for the phone to identify my router.

    can somebody help me with this.
    Phone: Torch
    Operator: Bell Canda
    Router: dual band wireless n & g
    10-05-10 10:14 PM
  2. Rikter's Avatar
    Have you tried this:
    settings-adv settings-browser-hotspot browser instead of Bell or whatever it is currently listed as?
    10-05-10 11:01 PM
  3. javatyger's Avatar
    BlackBerry devices are designed to disable the browser completely if u turn off data - just works that way. Even if you're on Wifi, it won't do any browsing unless you turn on your data. Now saying that, when you're on wifi, and on the Torch it will show you're connected by saying Bell - <network name> and your wifi symbol will be a bold white color. Means no data been used on Bell, just your wifi.

    As for N, I'm not too sure about it. The torch is b/g/n enabled, so should be working. Good luck on that one.

    Hope this helps and take care.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-05-10 11:03 PM
  4. branflakes's Avatar
    Some smartphones (not sure on Torch) only use the 2.4Ghz range of N, not 5 Ghz. Again, not 100% sure if that's true on the Torch, but might be part of your problem.
    10-06-10 01:15 AM
LINK TO POST COPIED TO CLIPBOARD