1. TearBear's Avatar
    I just got this phone at the end of December and I would only assume that it would have had the latest OS in it. I just tried to install AIM on this thing and it said my OS was to old. How do I find out what I have and what do I do to fix it... I'm already scared cause I've read these posts of people upgrading their OS and the BB going south. HELP PLEASE... I really don't want to be a nuisance.
    01-18-09 08:24 PM
  2. hilmar2k's Avatar
    Options -> About

    The OS version will be the third line (at least it is on my Pearl).
    01-18-09 08:29 PM
  3. AStranger's Avatar
    Check options then About. That will tell you the OS version you are running.

    Check the forum for your device for a sticky about the latest version for you device.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-18-09 08:29 PM
  4. VIOLATOR's Avatar
    Press ALT - Left SHIFT & H


    A "Help Me" screen will pop up. Look at the"App Version". You probably have 4.2.


    David
    Last edited by VIOLATOR; 01-18-09 at 09:29 PM.
    01-18-09 08:30 PM
  5. markgopher's Avatar
    Go to "Options", then "About" and it will tell you which OS you have.
    If you look in the 83xx forum, there are stickies at the top that give directions on upgrading the OS to 4.5. I followed the directions and upgraded without any problems at all.
    01-18-09 08:31 PM
LINK TO POST COPIED TO CLIPBOARD