1. HarrishMasher's Avatar
    It seems many people have problems with a 10 to 15 minute lag receiving emails from Hotmail on their Blackberries. Historically I never had a problem and always got my Hotmail emails instantly. However, since I got my Torch I have had a 15 minute delay. And it has been driving me insane for a couple of months.

    Not only was there a delay, but when I read a message on my Berry it would not show up as read when I logged into my hotmail acct on my computer. Nor would messages I sent from my berry show up in my sent folder in my hotmail account. This drove me insane as well. Especially because I use my hotmail account for business.

    Problem solved. Talking with ATT technical service, they diagnosed the problem...the problem was actually with my online BIS account with ATT...

    I couldn't log in to my BIS account (att.blackberry.com) since I got my new Torch. Here's where the rub lies...ATT had both my previous Bold and my new Torch listed as my devices for my Hotmail account. This confused the system and would not let me login to my BIS.

    Next it also creates a problem with emails being routed from my Hotmail account to my Berry. Hotmail looks for my old device first, after it doesn't find it, it then sends the emails to my new Torch. Hence the delay.

    While speaking to ATT technical service they deleted my old Bold from my BIS account and deleted my hotmail acount as well. They reset my login for my BIS account and I logged in and added my Hotmail account. It works perfect now! I get my emails instantly! And the other problems are cleared up as well...my messages show up as read in my online Hotmail account, and the emails I send from my Berry show up in my sent folder on my online Hotmail account as well!

    So if you are not receiving your Hotmails instantly. Call your provider and make sure only 1 device is registered with on your BIS.

    I'm thrilled I figured this out. All the other fixes I see here did not work for me, and this was clearly the real problem all along. I'm sure some of you that have replaced old Berry's with new ones are suffering from this same problem.

    Good luck!
    Last edited by HarrishMasher; 12-05-10 at 02:24 PM.
    reverepats likes this.
    12-05-10 02:15 PM
  2. T
    Thanks for this tip. I'm glad it fixed things for you, but I'm not so sure this is the solution for all. I experience the delay with hotmail, and this is my first and only BlackBerry.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-05-10 04:44 PM
  3. howarmat's Avatar
    old hotmail accounts had a protocol (MIcrosoft Mobile Services Protocol) that allowed them to be instant. If you create a new BIS account you will lose this protocol and it will be delayed again. If the OP deletes his hotmail account and re adds it to his BIS he will then have the delay back. This is more a FYI than anything else. Hotmail is no longer instant for new BB subscribers
    12-05-10 04:51 PM
  4. HarrishMasher's Avatar
    old hotmail accounts had a protocol (MIcrosoft Mobile Services Protocol) that allowed them to be instant. If you create a new BIS account you will lose this protocol and it will be delayed again. If the OP deletes his hotmail account and re adds it to his BIS he will then have the delay back. This is more a FYI than anything else. Hotmail is no longer instant for new BB subscribers
    I did in fact delete my hotmail account from my BIS and added it back. This is the first time it has worked correctly in months. I've been getting all of my emails instantly all day. So I'm not quite sure you are correct about this, certainly not in my case.

    I've also been testing it by sending myself emails from my other email accounts (not hotmail) to my hotmail account and they come instantly! I've done it about 10x throughout the day from 3 other email accounts...all instant!
    Last edited by HarrishMasher; 12-05-10 at 07:51 PM.
    12-05-10 07:48 PM
  5. HarrishMasher's Avatar
    Thanks for this tip. I'm glad it fixed things for you, but I'm not so sure this is the solution for all. I experience the delay with hotmail, and this is my first and only BlackBerry.

    Posted from my CrackBerry at wapforums.crackberry.com
    Okay, but Hotmail might be trying to send email to your previous non Blackberry device if you had it set up for Hotmail. I would check with my carrier to make sure this is not happening.
    12-05-10 07:53 PM
LINK TO POST COPIED TO CLIPBOARD