1. mdreading's Avatar
    I'm using an 8830 connected to our Exchange 2007 server with BES.

    I have many exchange rules set up to file frequent mailings into folders. For the folders that I want delivered to my blackberry, I have enabeld "Folder Redirection". I have also set "hide filed messages = yes".

    Here's my problem...

    When a new message arrrives in one of the folders, the message still shows up in my "Messages" inbox view as well as the folder view. The blackberry clearly knows that the message is destined for a folder since it shows a folder icon in my inbox and also shows the folder name when I open up the messages.

    If I open the message, the message no longer shows up in the inbox view. and (correctly) only shows up in the folder view.

    So it seems that "Hiled filed messages" is only working for messages that are filed *and* read.

    How do I keep these message from showing up in my inbox view?

    -- Mike
    05-12-08 11:25 AM
  2. Gougounne's Avatar

    I'm also looking for this solution.... Anyone helped so far ?
    06-22-09 08:51 AM
  3. gmplague's Avatar
    anyone have a solution to this issue?
    06-25-09 08:00 AM
  4. LilTroyTroy's Avatar
    I'm experiencing similar issues (with all the proper settings correctly configured.) Prior to these issues, my blackberry Curve 8330 was working fine hiding sent messages upwards until sometime last week. I received some sort of prompt that asked if I would like to activate my BB as a server. Now I have no idea where or why that came up. Obviously I denied the request but since then my filed messages haven't been working. Don't know if thats related somehow but I thought Id throw that in there in case someone else had the same prompt prior to their problems. As far as Outlook goes, its functioning fine moving the messages to the designated folders I created and of course, it stays up and running so my rules continue to work.

    In any case, here's what I've tried so far: I reactivated my account on the BES server, still didn't hide filed messages. Wiped the blackberry then did another activation. Still doesn't hide filed messages. So now I'm at a loss, I have no idea what else to change or check.

    I'm running OS version (188)
    08-12-09 11:56 AM
  5. Mtnhorse's Avatar
    Has anyone found a fix for this?? I just got an 8900 from my employer and have it's doing exactly as described here.


    10-07-09 06:51 PM
  6. JRWilliams308's Avatar
    I've noticed the Bold 9700 and Curve 9630 (OS v has a Hide Read Filed Messages option where in prior OS versions it was simply Hide Filed Messages. The functionality we're experiencing and reporting in this thread seems to be by RIM's design. My question is WHY???? I would think the ability to hide filed messages makes more sense and is consisent with prior versions. We should have at least been provided both options.

    If anyone has a work around for this, I'd love to know it.
    12-17-09 02:44 PM
  7. tadearden's Avatar
    I have the same issue. Did anyone find a solution?
    06-03-10 01:38 PM
  8. sjcdmill's Avatar
    Best solution you have is to create a shortcut to a saved search that only consists of messages currently in the inbox.



    Thank you for contacting BlackBerry Customer Support.

    Here is a link to an article in our BlackBerry Technical Solution Center that contains a description of the issue we discussed.

    Article Title: Changing the default view of the messages list to show only enterprise messages from the Inbox that have been redirected by a BlackBerry Enterprise Server

    Article Number: KB10395

    Link: I am too new to post a link...

    KB10395-Changing the default view of the messages list to show only enterprise messages from the Inbox that have been redirected by a BlackBerry Enterprise Server

    Also, the fact that you are unable to hide unread filed messages in device software 5.0.2 and unable to change default folder for inbox is because these are by design in software 5.0.2.

    Should you require further information on this subject, please don't hesitate to contact us. Thank you again for contacting us.


    Best Regards,
    09-09-10 04:24 PM