1. morfy50's Avatar
    So I've never been able to connect to my wifi at work (at home it works great though!). I've tried with multiple BB's, it's a no go. Maybe someone can help.

    We have a firewall and I can see the BB listed with an IP address on the firewall; however, the "wifi" symbol on the BB is gray and black and wifi definitely is not working. The router is a Linksys WRT54G ver.2

    I'm sure it has something to do with the firewall, although I have no idea what. I'm not too concerned but it just burns me that the iPhone/Android users connect so easily yet my BB can't

    Here are the Diagnostics:
    Wi-Fi
    Current Profile: SMC
    SSID: SMC
    AP MAC Address: 00:0F:66:0C:EC:CC
    Security Type: Pre-Shared Key (PSK)
    Association: Successful
    Authentication: Successful
    Local IP Address: 192.168.0.93
    Signal Level: -44 dBm
    Connection Data Rate: 48 Mbps
    Status: Network acquired
    Authentication Failure Reason:

    Network Type: 802.11b/g
    Network Channel: 6
    Pairwise Cipher: CCMP
    Group Cipher: CCMP
    Gateway Address: 192.168.0.1
    DHCP: Successful
    Primary DNS: 192.168.0.1
    Secondary DNS: 0.0.0.0
    DNS suffix:
    Subnet Mask: 255.255.255.0
    Server Domain Suffix:
    Certificate: Not Applicable
    Software Token: Not Applicable
    Hotspot Code:
    Hotspot Message: Not Applicable
    Hotspot Status: Not Applicable

    VPN
    Current Profile:
    Concentrator Address:
    Contact: N/A
    Authentication: N/A
    Secure Device IP:
    Status: VPN profile is not found.
    Resolving Concentrator: N/A
    Concentrator IP:
    Primary DNS:
    Secondary DNS:
    DNS Suffix:
    Secure Subnet Mask:
    Retry at:
    Session Lifetime:
    Re-login at:
    Failed Login Attempts: 0
    Certificate: Not Applicable
    Software Token:

    BlackBerry Infrastructure
    Address Used: //rcp.na.blackberry.com:443
    IP Used:
    Connecting: Error
    Authenticating router: N/A
    Authenticating server: N/A
    Last Contact At:
    Last edited by morfy50; 03-15-10 at 12:55 PM.
    03-15-10 12:53 PM
  2. kparton's Avatar
    the text in red doesn't mean anything, your wifi connection looks fine.

    The grey Wi-Fi icon means your Blackberry cant connect to BIS via Wi-Fi which could be down to your workplace's firewall blocking port 443.

    If your berry is connected to the Wi-Fi router then it will state the profile name above the clock, to the right of the Mobile Network name. If it is connected, then load up Blackberry browser and goto the options --> General options and change the default browser to "Hotspot Browser" and then see if you can browse the internet. If you can then your browsing via the Wifi Router and the internet connection behind it.

    take a look what I said Here, i've tried to explain it a bit more detail.
    Last edited by kparton; 03-15-10 at 01:08 PM.
    03-15-10 01:04 PM
  3. morfy50's Avatar
    the text in red doesn't mean anything, your wifi connection looks fine.

    The grey Wi-Fi icon means your Blackberry cant connect to BIS via Wi-Fi which could be down to your workplace's firewall blocking port 443.

    If your berry is connected to the Wi-Fi router then it will state the profile name above the clock, to the right of the Mobile Network name. If it is connected, then load up Blackberry browser and goto the options --> General options and change the default browser to "Hotspot Browser" and then see if you can browse the internet. If you can then your browsing via the Wifi Router and the internet connection behind it.

    take a look what I said Here, i've tried to explain it a bit more detail.
    Thanks kparton. I've already tried browsing via Hotspot browser, it doesn't work. All sites return the popup error "Unable to find the requested server."

    I do have my wifi network showing above the clock just fine. "Rogers - SMC"

    Also, in Options > Manage Connections the Wi-Fi is shown as a black box with a white horizontal line through it. Not like it does at my home & elsewhere, with the green checkmark.

    Any other ideas?
    03-15-10 01:24 PM
  4. kparton's Avatar
    The black line means that your berry is connected to BIS via the mobile connection, not the Wi-Fi connection.

    Your berry must be connected to the Wifi router since the profile name is listed above the clock so it can only be one other thing really...

    ...the Default gateway must be incorrect.

    I can see from your previous post that the default gateway is set to: 192.168.0.1 - this is the ip address of the device which the berry is trying to access the outside world.

    Is that a router or a server?

    You may need to ask the it technician there or someone with this information as your berry might have the incorrect IP address/gateway details.
    03-15-10 01:25 PM
  5. morfy50's Avatar
    Hmmm.... intetesting.

    I cannot ping our gateway (router) 192.168.0.1 from the BB, yet I can ping it from any computer. BB just says "Ping request timeout".

    No clue how to fix it, but at least I have some idea what's going on. It's a shame it's so difficult.
    03-15-10 01:49 PM
LINK TO POST COPIED TO CLIPBOARD