1. hensonator's Avatar
    So, I picked up a (I'm on Tmobile) blackberry 8900 second-hand... Everything looks good blah blah
    Don't have a data plan (hate me :[ if you will), and don't plan on getting one.

    So I have spent the majority of the day&night familiarizing myself with it, and I have wifi problems (sigh.. who doesn't?)

    So my data services is "off" as to not get any unwanted charges
    Connection preference is set to mobile network only
    Browser is set to hotspot (or wifi for the more up-to-date versions) browser only
    My wi-fi is set up correctly to my knowledge.. when I scan for networks, it says it's connected to my house network and shows 3/5 green bars

    HOWEVER (now here comes the sadness)
    When I go to manage connections, mobile network has a green check mark, BUT Wi-Fi has a white dash! Strangely though, next to Wi-Fi, it has my wireless house network next to it written in green

    Going to Wi-Fi options => menu=> Wi-Fi Tools => Wi-Fi Diagnostics, it shows current profile, ssid, signal level, etc (it shows everything), except on status, it says "IP address no longer valid"

    Scrolling down to UMA, it shows a green checkmark in the "UMA wi-fi available" box, a white slash in the "connection" box, and in status it says "wi-fi connection successful"

    And in the upper right hand corner of the main screen, it says edge (in lower cased letters), and shows a greyed out wifi icon :[

    And on the top mid, it says "T-mobile-pjoh (the name of my wireless internet ssid)

    When I try to load up a webpage on the browser, it says "A communication failure has occurred. The server may be busy..." blah blah blah

    I tried searching it up everywhere on these forums and google, but I can't find a solution to my problemssssss!!!!!!

    Also, the router I'm using is a D-link G Router. I can get the specfic model too, but I don't think the problem is in the router.........
    Oh and yes, I've tried all the things in the Wi-Fi FAQ/troubleshooting thread
    PS. I'm running v4.6 (IS A FIRMWARE UPDATE IN NEEEEEEEEED?!?!?!)



    PLEASE HELPPPPPPPPP!!!!! My life is miserable because of thissssssssssssssss
    :[
    Last edited by hensonator; 08-03-10 at 04:21 AM.
    08-03-10 04:18 AM
  2. dictoresno's Avatar
    your phone will always have a greyed out wifi icon, since you dont have a BB data plan. if you had a BB plan, it would be white.

    try turning your data services on, i believe that controls all data including what comes in over wifi.
    08-03-10 05:02 AM
  3. hensonator's Avatar
    Ah, it worked! Thank you so much dictoresno!

    I just have one question...
    With my data services on, does that leave me vulnerable to data charge when I'm out of a wifi spot?
    08-03-10 05:09 AM
  4. driftin240's Avatar
    Ah, it worked! Thank you so much dictoresno!

    I just have one question...
    With my data services on, does that leave me vulnerable to data charge when I'm out of a wifi spot?
    It probably does, but with some carriers, you won't be allowed to use data if you don't have it set up on your plan.
    08-04-10 06:19 PM
LINK TO POST COPIED TO CLIPBOARD