1. danielaEM's Avatar
    Im having 2 issues with my phone- Pearl 8110 with AT&T, in Mexico its picking up MOVISTAR

    I am in Mexico and for some reason my Caller ID now only works for incoming local calls from Mexico. All calls from the US appear as UNKNOWN. Very frustrating!! I beleive the caller ID worked fine when it was picking up TELCEL but now it only picks up MOVISTAR

    After being on the phone with ATT for over an hr, they couldnt help.

    I already tried the following:
    Security options> General Settings
    1. Enabled Content Compression
    2. Enabled Content Protection, include Address Book to NO


    I tried changing the network but in Manage connections> Mobile Network Options; i only get the following 2 options:
    Data services which is ON
    Mobile Network which is MOVISTAR

    it does not give me the option to change to manual or change the network.

    HELP!! how can i fix this. All i really want is for my caller ID to work.

    My moms phone is picking up TELCEL and her caller ID works fine. HELP HELP HELP

    thank you@
    05-01-10 11:31 PM
  2. GiovanniA's Avatar
    I have the same situation on my 9700 Bold, but not only does caller ID not work my voicemail does not go directly to it when I have missed calls. The caller has to redial my number in order to access my vm. All of this is only on the Movistar network. I have used AT&T since 2005 and have used it in Mexico since with no problems but since November of 2009 it started switching over to Movistar and then back to Telcel but after weeks on each. Movistar doesn't have 3G but Telcel does.

    Please if any body knows what to do to change networks please advise. Thank you!

    Posted from my CrackBerry at wapforums.crackberry.com
    05-15-10 04:13 AM
  3. colinweeks's Avatar
    I have the same problem. i am an ATT subscriber. My caller-id always worked well in mexico with Telcel and Movistar. Toward the end of 2009 i stopped picking up Telcel and it was only Movistar. Same time my caller id stopped working. Every incoming call (except Mexican numbers) comes up "UNKNOWN". Has anybody figured this out? It is really frustrating.

    Thanks a lot.

    Colin
    06-04-10 11:35 AM
  4. albee 1's Avatar
    Check your smart dialing features. Your country code may have changed. Menu/Options/Phone Options/Smart Dialing. Good luck.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-04-10 02:54 PM
  5. thejgeffect's Avatar
    Yeah my caller ID came up as UNKNOWN in MX also. Didn't bother me to much though.
    06-04-10 10:48 PM
LINK TO POST COPIED TO CLIPBOARD