1. UKTom12's Avatar
    ive have recently bought a supertooth buddy handsfree bluetooth device for my car. but when i try to connect to my bb curve 8520 it can not find it and my phone cant find the device either. however, i can connect to my friends phone and his phone can connect to the device. I think the problem might be that my bluetooth connection has a white dash next to it, not a green tick like the wifi and mobile network but i dont know what it means or how to change it.
    If anyone can help i would be very grateful.
    09-27-11 04:40 PM
  2. fatih.kurnaz's Avatar
    On BlueTooth settings, you must set discoverable option ticked.
    Did you do that?


    Sent from my iPhone using Tapatalk
    09-27-11 04:49 PM
  3. UKTom12's Avatar
    On BlueTooth settings, you must set discoverable option ticked.
    Did you do that?


    Sent from my iPhone using Tapatalk
    yes, the discoverable option is set to yes.
    09-27-11 04:55 PM
  4. fatih.kurnaz's Avatar
    What is your friends device model?
    And Did you try removing battery at all?


    Sent from my iPhone using Tapatalk
    09-27-11 04:58 PM
  5. UKTom12's Avatar
    What is your friends device model?
    And Did you try removing battery at all?


    Sent from my iPhone using Tapatalk
    he has a nokia. and when i search i can find his and he can find mine. but when i try to connect to the car device i cannot but his does straight away. the car device does work with bb's as many people who reviewed the product used bb's.
    09-27-11 05:02 PM
  6. fatih.kurnaz's Avatar
    Ok thanks for your clarify.
    Then you should do a battery pull.
    If done, then check from other 8520 users a friend of yours maybe.
    If they can see, you have a problem with your BT or your software.



    Sent from my iPhone using Tapatalk
    09-27-11 05:06 PM
  7. UKTom12's Avatar
    Ok thanks for your clarify.
    Then you should do a battery pull.
    If done, then check from other 8520 users a friend of yours maybe.
    If they can see, you have a problem with your BT or your software.



    Sent from my iPhone using Tapatalk
    i just used my brothers bb battery and its still all the same....
    09-27-11 05:27 PM
  8. Jaguarr40's Avatar
    Since your BT is on discoverable then you have gone I to the network connections and turned it on??

    If so what process are you doing exactly to connect?
    09-27-11 05:49 PM
  9. UKTom12's Avatar
    Since your BT is on discoverable then you have gone I to the network connections and turned it on??

    If so what process are you doing exactly to connect?
    i have turned the bluetooth on. i can see the sign in the top corner. and when i push the button on the car device to connect to the phone nothing happen. But on my mates phone a notice comes up saying that he is connected to the car device.
    09-27-11 06:08 PM
  10. Jaguarr40's Avatar
    i have turned the bluetooth on. i can see the sign in the top corner. and when i push the button on the car device to connect to the phone nothing happen. But on my mates phone a notice comes up saying that he is connected to the car device.
    Another stupid question? Ok so you have the BT turned on with the BT icon showing on your device. Have you paired your BB to the car BT device that you put in the car?
    There is a way on ALL devices to place it in paring mode first, then go to your BB to search for the device and as it searches and finds it , it is going to ask for a 4 digit password, default is usually 4 zeros and once you do that you should see the device on your phone and be good to go.
    09-27-11 06:14 PM
  11. UKTom12's Avatar
    Another stupid question? Ok so you have the BT turned on with the BT icon showing on your device. Have you paired your BB to the car BT device that you put in the car?
    There is a way on ALL devices to place it in paring mode first, then go to your BB to search for the device and as it searches and finds it , it is going to ask for a 4 digit password, default is usually 4 zeros and once you do that you should see the device on your phone and be good to go.
    my device can not even find the device of the car and visa versa. thats all i need to do is pair them as i have the code. but thats the problem, i cant. do you think it is somthing to do with the BT not having a green tick next to it?
    09-27-11 06:20 PM
  12. Jaguarr40's Avatar
    my device can not even find the device of the car and visa versa. thats all i need to do is pair them as i have the code. but thats the problem, i cant. do you think it is somthing to do with the BT not having a green tick next to it?
    If you have the BT showing on the main screen it means it is on, the green mark is when you are connected and your LED will blink blue.

    The BT car devicehas to be placed from the insructions into paring mode, Do you know what I mean?
    Then you BB will look for the device and ask you for the password, when done putting them in or before I forget when I did mine but mine is built into my car, nonetheless your BB will read what device it is called and then it should be hokked up and your blue LEd will flash.
    09-27-11 07:12 PM
  13. UKTom12's Avatar
    If you have the BT showing on the main screen it means it is on, the green mark is when you are connected and your LED will blink blue.

    The BT car devicehas to be placed from the insructions into paring mode, Do you know what I mean?
    Then you BB will look for the device and ask you for the password, when done putting them in or before I forget when I did mine but mine is built into my car, nonetheless your BB will read what device it is called and then it should be hokked up and your blue LEd will flash.
    i think i understand what you are saying. but there is only 4 buttons on the car device, and even when i listen/search for the device on my bb i can not find it. on the instructions it say when they are paired the code is 0000, so i think it is on pair mode but they cannot pair as they cannot find eachother.
    09-28-11 06:45 AM
  14. oliver7218's Avatar
    normally you have to hold down the button on your wireless device until the little coloured light flashes, once it flashes then go to your B/B and select the search, it then should hopefully pick up the signal. if you are just pressing the button once on the wireless device it does nothing, you have to hold it down for a few seconds at least that is how mine works.
    09-28-11 08:43 AM
  15. UKTom12's Avatar
    normally you have to hold down the button on your wireless device until the little coloured light flashes, once it flashes then go to your B/B and select the search, it then should hopefully pick up the signal. if you are just pressing the button once on the wireless device it does nothing, you have to hold it down for a few seconds at least that is how mine works.
    tried that mate, still not working. i have no idea what to do next. it must be a problem with my bb as the device works fine with all the other phones i have tried it with.
    09-28-11 03:54 PM
  16. Jaguarr40's Avatar
    i think i understand what you are saying. but there is only 4 buttons on the car device, and even when i listen/search for the device on my bb i can not find it. on the instructions it say when they are paired the code is 0000, so i think it is on pair mode but they cannot pair as they cannot find eachother.
    OK here what I would do if you don't or already tried what Oliver sugessted to you. Take your BB and the BT device to where you bought it. Let them know you are having trouble and if they will exchange a new one for you let them show you how to properly place the BT device into paring mode and check your settings on your phone. Hopefully they will hook you up and you can go on your way with working devices.
    09-28-11 07:58 PM
  17. UKTom12's Avatar
    OK here what I would do if you don't or already tried what Oliver sugessted to you. Take your BB and the BT device to where you bought it. Let them know you are having trouble and if they will exchange a new one for you let them show you how to properly place the BT device into paring mode and check your settings on your phone. Hopefully they will hook you up and you can go on your way with working devices.
    you probaly going to have to do that. thanks for your help.
    09-29-11 07:00 AM
  18. albomo's Avatar
    3. How do I pair my SuperTooth Buddy with a Bluetooth mobile phone?

    Pair the SUPERTOOTH BUDDY to your Bluetooth mobile phone to create the link or audio connection between the two. The pairing process is required only once for each phone.

    Full Auto Pairing Procedure:
    IMPORTANT: Please check if your phones Bluetooth is enabled and discoverable. Then place your phone and the handsfree kit close to each other.

    From OFF, press and hold the On/Off (8) button of the handsfree kit until the Bluetooth Indicator (4) turns blinking red/blue. Then press the MFB (6) button to search your phone. Note: The handsfree kit will search only for 1 minute. If your phone is not found, press the MFB (6) button again.


    When the handsfree kit finds the phone, accept any connection or pairing prompts on your phone. The handsfree kit is now paired and ready to use. Note: Older phones will ask for the password/pin code. Enter 0000 and press OK. The handsfree kit is now paired and ready to use.
    Normal Pairing Procedure:

    From OFF, press and hold the On/Off (8) button until the Bluetooth Indicator (4) turns blinking red/blue. The handsfree kit is now in pairing mode.


    While the handsfree kit is in pairing mode, access the Bluetooth menu of your phone. Turn on the Bluetooth function and execute a Bluetooth search. (See your phones manual.)
    When the phone displays the list of Bluetooth devices, select ST BUDDY.


    If the phone asks for the password/pin code, enter 0000 and press Ok.
    The handsfree kit is now ready to use.
    02-07-12 03:18 PM
  19. 13echo4's Avatar
    Go into bluetooth connections select add new device select listen. Then follow directions above.
    02-07-12 08:49 PM
  20. RoseBud68's Avatar
    I think after 6 months UKTOM12 may have figured it out.
    02-07-12 09:25 PM
  21. 13echo4's Avatar
    Lmao I didn't notice the date.
    02-07-12 11:29 PM
LINK TO POST COPIED TO CLIPBOARD