1. yeah1's Avatar
    Hi,

    I have searched the forums, but I can't seem to find a solution. I know WIFI calling is supported with OS 7.1 on the 9810. Until now, I didn't have the service from Rogers, but now I do! But I still can't find any option or any indication how to make WiFi calls.

    I've resent service books, pulled battery. I also can't find the "Preferred Network For Calls" option people seem to be talking about (checked in Mobile Networks).

    So, how exactly do I make WiFi calls? Where do I find this feature in the options?

    Thanks

    ===EDIT: Was able to find the solution through some research online and some testing===
    ---HOW TO:---
    So to summarize:
    My phone is non a Rogers branded phone, and even though I got Wifi Calling added on my Rogers account, the option for "Wifi Preferred" that everyone else is referring to was not there for me.

    I believe the problem had to do with the fact that my phone was not originally from Rogers, as somebody in this thread mentioned.

    What I did (everything here is included for informational purposes, use at your own risk):
    Access engineering screen (there are numerous guides online for this, so this is not hard to find)

    On the Engineering Screen go to Radio Engineering Screens >> 3GPP Radio Engineering Screens >> Utilities >> Session Manager
    On that screen, click the Menu key, and click UMA options
    On the new screen, click the Menu key, and click on New

    You will now be on the screen to add a UMA profile. These are the settings that worked for me on Rogers.

    Display name: Factory Provisioning
    Operator name: Rogers
    UMA protocol version UMA v. 1.0.4
    Provisioning UNC address: hbsc.uma.rogers.com
    Provisioning UNC port: 14001
    Provisioning SEGW address: segw.uma.rogers.com
    SEGW certificate: ca.rogers.com (on my phone, this was in an unlabeled drop down menu, just find the ca.rogers.com option and select that)

    ---END---

    That did it for me, and hopefully this will make it easier for others since all of the information is not available in one place anywhere that I've looked. Note some sites mention that you need to download ca.rogers.com certificates; I did not. I think as long as that option is on that drop down menu, you don't need to find these certificates.

    Now, when you go to Mobile Network Options, the option to choose Wifi Preferred is there, and Wifi Calling works fine!

    Remember, you still need wifi calling on your account.
    Last edited by yeah1; 03-29-12 at 06:43 PM. Reason: Including solution for other people's benefit
    aha likes this.
    02-28-12 02:50 PM
  2. AcADIeN's Avatar
    Hi,

    I have searched the forums, but I can't seem to find a solution. I know WIFI calling is supported with OS 7.1 on the 9810. Until now, I didn't have the service from Rogers, but now I do! But I still can't find any option or any indication how to make WiFi calls.

    I've resent service books, pulled battery. I also can't find the "Preferred Network For Calls" option people seem to be talking about (checked in Mobile Networks).

    So, how exactly do I make WiFi calls? Where do I find this feature in the options?

    Thanks
    It should work right away, its not an option you turn on.

    If you are still not seeing the icon on top right, you will have to try stuff, like setting an ip on your device instead of using dhcp, there is also stuff you can set on your router like the beacon and some other function (I'm not in front of my pc so I can't tell you all the option but search for "uma wifi advance setting" on google). If you still doesn't see the icon on top right then it could be rogers.
    02-28-12 04:53 PM
  3. wing2299's Avatar
    Go to "Networks and Connections" -> "Mobile Network", do you have the option in the "Preferred Network for Calls"?

    Mine have "Mobile Network Only", "Mobile Network Preferred", "Wi-Fi Calling Only" & "Wi-Fi Calling Preferred".
    02-28-12 06:54 PM
  4. yeah1's Avatar
    I don't have that option! What could be the reason for that? This is the second os 7.1 installation on my phone and neither had it.
    02-28-12 08:00 PM
  5. robsteve's Avatar
    Is your phone a Rogers branded phone? If it isn't they may have to put your imei into their system for the service to show up on the phone.
    02-28-12 09:57 PM
  6. yeah1's Avatar
    Is your phone a Rogers branded phone? If it isn't they may have to put your imei into their system for the service to show up on the phone.
    It is not a Rogers branded phone. Hmm, you think that is why its not showing up? So I should call them and ask to add my IMEI to what exactly? Thanks for your help!
    02-29-12 01:30 AM
  7. aha's Avatar
    I am interested in this too. Please update your result, thanks!

    So with wifi calling I should be able to avoid roaming charges as long as I have wifi, right?
    02-29-12 06:10 AM
  8. AcADIeN's Avatar
    here is what you should see, you can see wifi prefer in the setting, and the wifi icon on the second screenshot (top right)
    02-29-12 06:47 AM
  9. robsteve's Avatar
    It is not a Rogers branded phone. Hmm, you think that is why its not showing up? So I should call them and ask to add my IMEI to what exactly? Thanks for your help!
    They need to add it to their system/cellular switches. I don't know if they can just add it to your account or need a network engineer to do it. It may also not be possible to do. I have read similar situations with Rogers phones on AT&T not getting the AT&T features and having to associate an AT&T imei with the sim card even though it is in a Rogers phone.

    It may be easier just to get a Rogers phone,
    02-29-12 01:43 PM
  10. robsteve's Avatar
    I am interested in this too. Please update your result, thanks!

    So with wifi calling I should be able to avoid roaming charges as long as I have wifi, right?
    Go onto the myRogers web site and the details are in the add-ons section.
    02-29-12 01:45 PM
  11. andy957's Avatar
    Hi,

    I have searched the forums, but I can't seem to find a solution. I know WIFI calling is supported with OS 7.1 on the 9810. Until now, I didn't have the service from Rogers, but now I do! But I still can't find any option or any indication how to make WiFi calls.

    I've resent service books, pulled battery. I also can't find the "Preferred Network For Calls" option people seem to be talking about (checked in Mobile Networks).

    So, how exactly do I make WiFi calls? Where do I find this feature in the options?

    Thanks
    Could this have something to do with the fact that Rogers hasn't released 7.1 for any of their devices yet?
    02-29-12 02:26 PM
  12. AcADIeN's Avatar
    Could this have something to do with the fact that Rogers hasn't released 7.1 for any of their devices yet?
    No, as a business customer that use UMA and that is a critical thing for us, I can say that we all use leaked os, all on rogers and wifi calling working fine.

    One problem we had though is that our dhcp server doesn't seem to be fast enough for the blackberry(a lot of traffic on our network), so we had to specify ips on all phone to make it stable.
    Last edited by AcADIeN; 02-29-12 at 02:40 PM.
    02-29-12 02:38 PM
  13. yeah1's Avatar
    here is what you should see, you can see wifi prefer in the setting, and the wifi icon on the second screenshot (top right)
    Thanks for the screenshots, but I don't have that option section there. I guess I will call Rogers, thanks for your help everyone.

    Does anyone have any experience with this? Using wifi calling with a non-Rogers phone?
    03-01-12 09:35 AM
  14. cem1704's Avatar
    Hi guys just joined and was wondering if you would be able to answerthis question fro me .
    my old blacberry bold died and it was sent back to tmobile who then issued me with a new blackberry so obv a new pin.

    What i wanted to know is what happens to the data on the old pin. and more importantly if i was bbm'ing someone who has there phone settings saved to save bbm conversations would they now be DELETED for good off of their phone or would they still have copys of the messages even tho my pin has been sent back to the phone company and been destroyed as the fone was beyond repair..

    please can you try help
    much appreciated guys
    03-01-12 09:36 AM
  15. AcADIeN's Avatar
    Hi guys just joined and was wondering if you would be able to answerthis question fro me .
    my old blacberry bold died and it was sent back to tmobile who then issued me with a new blackberry so obv a new pin.

    What i wanted to know is what happens to the data on the old pin. and more importantly if i was bbm'ing someone who has there phone settings saved to save bbm conversations would they now be DELETED for good off of their phone or would they still have copys of the messages even tho my pin has been sent back to the phone company and been destroyed as the fone was beyond repair..

    please can you try help
    much appreciated guys

    Nice hijack! please create your own thread if you need help.
    Last edited by AcADIeN; 03-01-12 at 12:47 PM.
    03-01-12 10:04 AM
  16. yeah1's Avatar
    LOL seriously, I'd understand if it was related, but not even remotely related issue! haha
    03-01-12 11:56 AM
  17. yeah1's Avatar
    Hi everyone,

    Just thought I'd give everyone an update since I looked all over the place to figure this out and it wasn't the easiest thing in the world. Hopefully this helps other members, and hopefully "aha" you see this as well.

    ---HOW TO:---
    So to summarize:
    My phone is non a Rogers branded phone, and even though I got Wifi Calling added on my Rogers account, the option for "Wifi Preferred" that everyone else is referring to was not there for me.

    I believe the problem had to do with the fact that my phone was not originally from Rogers, as somebody in this thread mentioned.

    What I did (everything here is included for informational purposes, use at your own risk):
    Access engineering screen (there are numerous guides online for this, so this is not hard to find)

    On the Engineering Screen go to Radio Engineering Screens >> 3GPP Radio Engineering Screens >> Utilities >> Session Manager
    On that screen, click the Menu key, and click UMA options
    On the new screen, click the Menu key, and click on New

    You will not be on the screen to add a UMA profile. These are the settings that worked for me on Rogers.

    Display name: Factory Provisioning
    Operator name: Rogers
    UMA protocol version UMA v. 1.0.4
    Provisioning UNC address: hbsc.uma.rogers.com
    Provisioning UNC port: 14001
    Provisioning SEGW address: segw.uma.rogers.com
    SEGW certificate: ca.rogers.com (on my phone, this was in an unlabeled drop down menu, just find the ca.rogers.com option and select that)

    ---END---

    That did it for me, and hopefully this will make it easier for others since all of the information is not available in one place anywhere that I've looked. Note some sites mention that you need to download ca.rogers.com certificates; I did not. I think as long as that option is on that drop down menu, you don't need to find these certificates.

    Now, when you go to Mobile Network Options, the option to choose Wifi Preferred is there, and Wifi Calling works fine!

    Remember, you still need wifi calling on your account.
    aha likes this.
    03-29-12 06:40 PM
  18. aha's Avatar
    Thank you yeah1!

    Here is the Engineering Screen Unlock Code Generator For BlackBerry Torch2 9810 that worked for me.

    Below is the settings that seems to work for me:

    Display name: Factory Provisioning
    Operator name: Rogers
    UMA protocol version UMA v. 1.0.4
    Provisioning UNC address: default
    Provisioning UNC port: 14001
    Provisioning SEGW address: default
    SEGW certificate: ca.rogers.com

    After going through yeah1's procedure, the WiFi- Calling Preferred option is available for me now in Mobile Network Settings screen.

    Hope this helps.
    Last edited by aha; 03-29-12 at 11:16 PM. Reason: Found the solution
    03-29-12 09:12 PM
  19. Kofig1's Avatar
    lol that is a serious attempt to hijack there tho...what a terroist!
    03-29-12 10:30 PM
LINK TO POST COPIED TO CLIPBOARD