1. tcseacliff's Avatar
    I am hoping to get help with something. I have read all the forum questions after a search regarding the app loader. I have a torch and have been successfully upgrading the OS , since new . am currently using the 526.but I never seem to get it to load the way I read it should. when I go through the steps, and get to app loader, the vendor file is NEVER there. then, when I click on the loader, it proceeds to "load" but it doesn't just gets to the finish and says it is successfully loaded. I then open the BBsak and click, reconnect then load OS and it works, but have never got it to load onto the phone from just clicking the loader file. what am I missing? have never loaded any from app loader , only from BBsak? and why is there never a vendor xl file? I have been looking for it since my 8900 curve and my BOLD 9000!
    Last edited by tcseacliff; 04-05-11 at 09:12 PM. Reason: spell check
    04-05-11 09:10 PM
  2. GTWalling's Avatar
    The vendor file is in the same directory as the App Loader. It would be down towards the bottom.
    04-05-11 10:47 PM
  3. tcseacliff's Avatar
    It is not here, which is why I posted the question. like I said, have yet to see it in all my upgrades with my curve,8900, My BOLD 9000 ,and now my 9800. the only file that is close is called device xml, xml document. I wanted to find out what I am doing wrong that my vendor xml is never there, which to me, could answer why my app loader appears to load but doesn't.

    [IMG]mailhtml:mid://00000045/!cid:002801cbf4c2$0f13a6d0$756BF0A9@OwnerPC[/IMG]

    this is a current pic of app loader file-no vendor , just device xml?
    Last edited by tcseacliff; 04-06-11 at 09:27 PM. Reason: add link
    04-06-11 09:15 PM
  4. jeffh's Avatar
    Where are you getting your OS files? If you are downloading them from your carrier, the presence or absence of vendor.xml is irrelevant. vendor.xml only matters if you are installing an OS released by a carrier other than the one that branded your device. If you are loading hybrid OS files, they may not include a vendor.xml file. I don't know any other reason why you would not have one.
    04-06-11 09:38 PM
  5. tcseacliff's Avatar
    got the latest one from the "sticky" in the 9800 forums . the other glitch I have is when I click app loader and the run wizard , it usually skips a step. the pane where you check what language etc, you want don't want. BBSAK does it better, always have been puzzled as to why it does that. say' sI am successfully loaded and really is not. have to then close out of app loader and do it again through the BBSAK. sometimes ahve to do it a few times to get it to do it right.
    04-06-11 09:43 PM
  6. jeffh's Avatar
    I've never used BBSAK, so I can't help you with how it works, or why. I'll watch the thread and hope you get an answer. I've never read a problem exactly like yours.
    04-06-11 09:52 PM
  7. tcseacliff's Avatar
    i am doing something out of step but do not know what. I am running the 526 on my torch now, and it did the same thing. click app loader, the wizard starts, the phone blinks, 15 sec later says success. then open the options and read the devie version a nd nothing changes . so have to go into the BBSAK to do it again. would like to learn the app loader way also.
    04-06-11 09:56 PM
  8. jeffh's Avatar
    I recommend the procedure from the BlackBerry 101 Lecture series, here: http://crackberry.com/blackberry-101...ting-system-os. It's a little dated in its version numbers and screen shots, but the procedure works.
    04-06-11 10:04 PM
  9. gbsn's Avatar
    From your first post, you are running .526 and want to install .526 or what version are you tring to install? I kinda slipped on that one since you said you are using .526 so now i dont get what exactly you are trying to do.

    Usually, when apploader doesnt do anything is because you already have the OS installed in the pc in the phone, or there is no os installed in the pc.

    If appworld is bugging out and skipping screens i would suggest uninstalling blackberry desktop manager, restarting the computer, then reinstalling desktop manager and restarting the computer again.
    04-06-11 10:12 PM
  10. tcseacliff's Avatar
    this is a good tutorial on the BBSAK. I think you are all right. I usually delete my old OS and then download the new one , and then this is where I guess I am skipping or missing some thing. I make sure the DM is closed and then run the app loader and it looks like it is installing but doesn't. that is when I close that and go to the BBSAK to do it. gets confusing. and jeffH, the link in here is using the new version of DM. to read the whole thing go back to the forum home page and click on the thread from in the general disc ussion page on the right saying how to load an os by reginold _1986 it is very good
    reginald_1986 likes this.
    04-06-11 10:19 PM
  11. tcseacliff's Avatar
    From your first post, you are running .526 and want to install .526 or what version are you tring to install? I kinda slipped on that one since you said you are using .526 so now i dont get what exactly you are trying to do.

    Usually, when apploader doesnt do anything is because you already have the OS installed in the pc in the phone, or there is no os installed in the pc.

    If appworld is bugging out and skipping screens i would suggest uninstalling blackberry desktop manager, restarting the computer, then reinstalling desktop manager and restarting the computer again.
    I should have answered you also. I know I have the current version. this query is for my future upgrades. it is always a PITA when a leak comes out and I have to go thorough the steps, only to not have app loader finish. I am confused as to why the wizard goes through all the steps from the tutorials but the one step it skips is the language page and then the apps you want/don't want page. the BBSAK usually does it right, but on this install the BBSAK did the exact steps the app loader did and did not load . had to do it again, then it did it right , so I am doing something wrong or skipping a step.
    bugs me that i can't get this seemingly straightforward upgrades right.

    edit* those tips by reginald 1986 is at the tip, and FAQ sub forum when you go to the page for the gen discussion, it is a post from today and very detailed.
    Last edited by tcseacliff; 04-06-11 at 10:31 PM.
    04-06-11 10:27 PM
  12. reginald_1986's Avatar
    Okay this is from what I experience.

    Using loader (apploader) and complete lighting fast. Do this:
    Take out battery, start apploader first until the detect PIN screen. Do not plug in battery. Instead, connect USb cable to phone now and press Next immediately when it lights up. Then, you will get the loader working back. Put in battery somewhere when the process starts.

    Using BBSAK. Follow my guide in the signature

    First of all, of course, make sure the OS is correctly installed in the computer. Make sure the path name everything is correct.

    Drop me a PIN or email if you need any help. Might reply a little late since having problem with my freaking GPS

    @tcseacliff
    Thank you for your comment Appreciate it.
    tcseacliff likes this.
    04-06-11 10:29 PM
  13. tcseacliff's Avatar
    I may try that . sounds like the steps I had to take on my 8900 curve when I did a wipe and bricked it! that was a scary moment. I don't wipe anymore, seems to be necessary.
    04-06-11 10:36 PM
  14. jeffh's Avatar
    The App Loader does the wipe for you. If isn't necessary for you to perform a second wipe.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-06-11 10:48 PM
  15. reginald_1986's Avatar
    I may try that . sounds like the steps I had to take on my 8900 curve when I did a wipe and bricked it! that was a scary moment. I don't wipe anymore, seems to be necessary.
    I bricked my phone 4 times until date. Just say if you need a quick video when you having trouble, use the CB search and find for revive nuked BB

    Every time I bricked my phone, the method "Using loader (apploader) and complete lighting fast. Do this:
    Take out battery, start apploader first until the detect PIN screen. Do not plug in battery. Instead, connect USb cable to phone now and press Next immediately when it lights up. Then, you will get the loader working back. Put in battery somewhere when the process starts" works

    So no worries. With BB, I don't think it is much of a problem but it is definitely scary the first few times you nuked your phone
    04-06-11 10:53 PM
  16. tcseacliff's Avatar
    that is why I am trying to get the app loader right. the BBSAK has a wipe OS button and it really wipes! one time with my curve ,there was a hiccup and i was bricked for a while , quite scary, now I skip the wipe, seems to work.
    04-06-11 10:54 PM
  17. sleepngbear's Avatar
    this is a good tutorial on the BBSAK. I think you are all right. I usually delete my old OS and then download the new one , and then this is where I guess I am skipping or missing some thing. I make sure the DM is closed and then run the app loader and it looks like it is installing but doesn't. that is when I close that and go to the BBSAK to do it. gets confusing. and jeffH, the link in here is using the new version of DM. to read the whole thing go back to the forum home page and click on the thread from in the general disc ussion page on the right saying how to load an os by reginold _1986 it is very good
    It sounds like you've done this a few times already and know your way around; so please forgive me if this is ridiculously obvious, but I haven't seen any reference to it yet: have you actually uninstalled the old OS from your PC before installing the new OS? You said you deleted the old and downloaded the new; I've always understood that you need to uninstall the old OS first using Add/Remove Programs (or whatever it's Win7 equivalent is now), then install the new one by running the .exe file you've downloaded (Step 5 in the tutorial) before running Loader.exe.

    Again, my apologies if my understanding is incorrect or if this has already been covered; just trying to leave no stone unturned.
    04-06-11 11:04 PM
LINK TO POST COPIED TO CLIPBOARD