1. ericgwingarcand's Avatar
    hey guys i live in saskatchewan canada n we recently got G3 network here...GPS settings says its on n location is on n such but when i go into google maps my location is all wrong!

    Also with my Lookout mobile security the Missing Device option still says "turn on GPS Locating".

    Is my GPS actually working or is it getting my location from somthing else? I do have WiFi on. Google Maps navigation is kinda useless if it gives u directions from a wrong starting location...
    10-15-10 01:38 AM
  2. MarkInTombstone's Avatar
    Go into your advanced settings and turn it on. It should say e911 and location ON. That should fix it.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-16-10 06:08 AM
  3. rale2001's Avatar
    My gps options is trippin too on my tmobile 8520 it works sometimes and other times all the options say none and no other options any ideas? sometimes the gps works on my poynt other times not

    Posted from my CrackBerry at wapforums.crackberry.com
    10-22-10 01:46 PM
  4. RWWackostu's Avatar
    My gps options is trippin too on my tmobile 8520 it works sometimes and other times all the options say none and no other options any ideas? sometimes the gps works on my poynt other times not

    Posted from my CrackBerry at wapforums.crackberry.com
    Thats because the 8520 does not have GPS.
    10-22-10 02:42 PM
  5. katzz's Avatar
    My gps options is trippin too on my tmobile 8520 it works sometimes and other times all the options say none and no other options any ideas? sometimes the gps works on my poynt other times not

    Posted from my CrackBerry at wapforums.crackberry.com
    I have same problem, also have stupid green light flashing on and off at top off phone which started aftet I downloaded something off bb apps, any ideas on that? Driving me mad.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-23-10 12:53 AM
  6. RWWackostu's Avatar
    As I stated above, the 8520 does not have GPS. To turn off the green light, go to menu>options>screen/keyboard>LED coverage indicator>toggle to off.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-23-10 02:24 PM
LINK TO POST COPIED TO CLIPBOARD