1. Newt182's Avatar
    Is anyone else having problems with the GPS on thier Torch? Mine just sits there saying "Getting GPS" and I get a red satellite icon with an X at the top of the screen. I took it to the AT&T store and they still dont know why it's not working. I do have the navigation package on my account.
    08-19-10 11:41 PM
  2. gr8ocguy's Avatar
    Spent over two hours at the ATT store today for this very issue. GPS was not working, had the red slash mark on top right. Everything else on the phone was working great, no issues.

    The ATT Rep worked on it a while, finally deleted the GPS program (ATT Navigator) and reinstalled it. Got it working, but then lost all internet access. Got on phone and went through level 1 tech support (25 minutes), then level 2 (1.5 hours) and no one could figure out the issue. They decided to 'wipe' the phone and start over. Make sure you back up your entire phone and all 3rd party apps, before you have them work on it! Haha.... Ultimately, the phone seems to be working fine again. Not sure what the problem was, but obviously there's a glitch in something. (Also, the BB Regional Rep came in the store while I was there and was very pleasant, but didn't hang around to see if the phone ever got straightened out....she bailed when no one was looking!....)
    08-20-10 12:02 AM
  3. Stinsonddog's Avatar
    Curious where were you standing when you first tried this. Sometimes new phones need to be in the wide open sky to catch the first sat.
    08-20-10 12:07 AM
  4. Newt182's Avatar
    I've been trying to get it working since i got the phone last week. Even drove around with it sitting on my dash and it never got a fix on my location.
    08-20-10 12:37 AM
  5. gr8ocguy's Avatar
    Also tried several different areas of town and the ATT folks tried outside as well... It acted like there was some preference switched to the 'off' position. Wouldn't do anything. Anyway, have the phone back to where it was before the problem and it's working flawlessly now! It's history to me now....
    08-20-10 01:13 AM
  6. TrueHappiness's Avatar
    Just use BB maps... screw paying AT&T.... Just another fee for something you can have free.
    08-20-10 01:25 PM
  7. jr5417's Avatar
    I had the same problem. I was at a gas station when it happened. I exited the app and went back in and reput in the address. It worked fine after that. Try resending the service books and a good ol' fashioned battery pull.
    Last edited by jr5417; 08-20-10 at 01:40 PM.
    08-20-10 01:38 PM
  8. gr8ocguy's Avatar
    I like the ATT nav application. Great voice command capability, streams through bluetooth earpiece and loads of extras that I use when I travel frequently. Not a problem paying for a significant workhorse for me... Tried BB maps and for limited needs, it would be fine, but international travel...not so much.
    08-20-10 03:16 PM
  9. Newt182's Avatar
    Still no go for me, AT&T Navigator just sits there trying to get the GPS location. However, google maps locks on in seconds. I've deleted the app, rebooted, reinstalled, still no go.
    08-24-10 08:41 PM
  10. Najo's Avatar
    Sounds like an app issue, g-maps locks faster than my bold did. Same for the nRange golf GPS app.
    08-24-10 08:45 PM
  11. Newt182's Avatar
    Went back to the AT&T store today, they swaped out my torch for a new one and all is well. AT&T navigator works fine.
    08-27-10 12:19 AM
  12. sqa4life's Avatar
    I am having the same issue. AT&T navigator only works after I pulled the battery and put it back.
    08-27-10 12:44 AM
  13. bennydub604's Avatar
    just use bb maps or google maps... works flawlessly with me and i'm in canada. it's probably att's navigator program that's not working not the gps.
    08-27-10 01:46 AM
  14. Crucial_Xtreme's Avatar
    When I'm in D.C. I tend to have a few issue with Navigator. When I'm in NC, I don't have any issues. I think most of it is network related.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-27-10 08:11 AM
  15. mark_rivers19's Avatar
    i have noticed that indoors it takes time to get signal from the satellite..
    but if you're outside, away from skyscrapers.. then the GPS signal is better
    08-27-10 09:25 AM
  16. dragonssports's Avatar
    I have experienced issues with navigator as well, yes i am outside on described issues.
    If I use contacts within navigator to get a route it hangs with the green bar at (I will call it) 99%. Never pulling up a route. If I completely exit the app and then pull up "Recent Places" it loads fine.

    It is also sporadic when trying to "drive to" a contact when I am in my BB address book. I would say less than half the time I can drive to a contact directly from my BB address book. Once again if I shut down navigator and select recent places the route will come up quickly.

    Success of other gps apps

    AllSport-poor
    Greenfinder-no problems
    Golflogix (using storm 1 edition on torch)
    Poynt- no problems
    Google Maps- no problems
    Weatherbug- no problems
    08-28-10 03:29 PM
LINK TO POST COPIED TO CLIPBOARD