1. ryanmercer30's Avatar
    Hey everyone. I joined up to post this after countless reading and searching. I read the Boostberry tut but didnt full understand what boostberry was.

    I have had my 8350i under Telus Mobility for about 2-3 months now and my gps has never worked. I have search the forums here for answers and havent found anything that really helps my problem.

    My Problem: When I go to Options > Advanced Options > GPS > hit the menu button then click "Refresh GPS" it says "Scanning for Satellites..." for about 5-10 minutes. Then I get some error about finding my location. Since I have had my bb it has never found my location whether I am in an open field or in my apartment. It will never find my locaton in BBMaps or Google Maps either (I downloaded it to test).

    Story: I called Telus Mobility support and talked to 3 people but no one would give me a definite answer on what was going on. The one person said she wasn't even sure if Telus had locked the GPS feature on the 8350i, the best answer I got was to bring it into a Telus store so an employee could look at it in person.

    I drove out to a Telus store after talking to Telus support and I was told there that there is a problem with the Mike part of the phone conflicting with the GPS part (he was alittle more technical). He told me to go home and google how to unlock my phone (also added not to tell anyone ) as that is the cure to fix my problem.

    I have tried to google all different kinds of stuff but cant come up with a definite answer on what I need to do. I hope someone on here can help me out. I am sorry for such a long post but I am trying to give as much info out as I can.

    My GPS settings are:
    GPS Data Source: Device GPS
    GPS Services: Location On
    Privacy Setting: Unrestricted

    Option > About:
    Blackberry 8350i
    smartphone (iDEN, Wi-Fi)
    v4.6.1.294 (Platform 3.1.0.28)


    If any additional information is needed just ask. Thanks in advance for trying to help me out.
    01-30-10 08:34 PM
  2. MSIXTEEN's Avatar
    Did you try to updaye your OS. Also try a battery pull then retry to connect. Did you try telenav that comes with phone. Bb maps can take forever sometimes and I live ni ny. But I don't have any problems with tele navi

    Posted from my CrackBerry at wapforums.crackberry.com
    01-31-10 01:46 PM
  3. ryanmercer30's Avatar
    I updated my OS early last week and it completed. I used BBManager to do so. I have pulled the battery before and regularly use a QuickPull app to keep my phone speedy, either with no luck on the gps.

    I am going to google this telenav you mentioned. I dont ever remember hearing about it before so hopefully it will solve my problems.
    02-01-10 10:02 AM
  4. ryanmercer30's Avatar
    I looked into that Telenav and it sounds like in American only type program. I dont recall it coming with my phone and when I go to the website it asks for my carrier and only American companies are listed.
    02-01-10 07:37 PM
  5. Laura Knotek's Avatar
    I looked into that Telenav and it sounds like in American only type program. I dont recall it coming with my phone and when I go to the website it asks for my carrier and only American companies are listed.
    It is not fee, but there is Telus Navigator available. TELUS Navigator | TELUS
    02-01-10 08:26 PM
  6. carshop's Avatar
    drove out to a Telus store after talking to Telus support and I was told there that there is a problem with the Mike part of the phone conflicting with the GPS part (he was alittle more technical). He told me to go home and google how to unlock my phone (also added not to tell anyone ) as that is the cure to fix my problem.

    I'b be asking him to "unlock it"
    02-06-10 09:39 AM
  7. ibbeach0's Avatar
    IThere are difference between the US and CA version of the 8350i. I would try doing a wipe and reload the OS using either bbsak or jl_cmder. Make sure you do a back up before using DM.
    02-06-10 10:06 AM
LINK TO POST COPIED TO CLIPBOARD