04-29-09 10:40 AM
53 123
  1. cschalk's Avatar
    Ok, I have read every single thread I could find on this.. here's my deal:

    I have a Curve 8310,
    I do NOT have the data plan,
    I have downloaded/installed Mobile GMaps gps application,
    I have downloaded/installed a Cache of maps for my location,
    I have GPS turned on (Options > Advanced > Gps > Location ON)
    I have upgraded to Firmware 4.5

    now, As I understand it, even though I don't have the data plan, I should still be able to use the GPS functionality because GPS is free (thanks to Pres. Reagan). And with Mobile GMaps, I don't need to use the TeleNav GPS, which doesn't work without Data Plan.

    So, I installed it all, turned on my MGMaps application and sat in the middle of a park for an hour hoping to find satellites for the GPS to start working, but nothing showed up. It was a bright sunny day, I was outside, but never once found a satellite... My BB didn't even look like it was trying to talk to anything. There was a little compass icon in the top corner, but nothing ever moved, no numbers on the map ever showed up.... nothing.

    What am I doing wrong? I have found a plethora of threads saying that the GPS will work without a data plan (and I know a BB sans data plan is like a bullet without a gun... but it's a work issued BB and they won't allow me to get Data). All I am wondering is if I can get this thing to work or what..

    Thank you in advance for any help you can offer.

    04-13-09 09:34 AM
  2. altournoux's Avatar
    I do understand your frustration as it has been 3 days I'm desperately trying to make it work.
    1) For me the GPS does have anything to do with the data plan unless they blocked the GPS chip activation by some ways... not sure so far.

    2)I have the pretty much the same settings unless the maps. The use I wanna do is simply take pictures with the Geo tagging. (possibly setting off all connections depending the country and the security conditions (could be in a plane for example)

    3) I wish someone could help us
    04-13-09 05:02 PM
  3. hoanhochubodoi's Avatar
    I had a blackberry curve 8310. When i installed 4.2.1 os, gps work fine on it, max 5 sats. But when i upgrade to os, gps don't work. I reinstall 4.2.1 gps still don't work. I think i have some problem with phone software.
    I want to ask one question: is there a software like QPST to access gps chip in 8310 and change Network Settings & Addresses.
    My carrierr:AT&T but i'm living outside america and i don't use any data plan.
    If not, can you suggest me what should do?
    04-17-09 11:46 PM
  4. bimed's Avatar
    To enable the internal GPS just unbrand you BB.
    Mobile GMaps works fine for my curve 8310, you can even log gps data.
    04-18-09 02:15 AM
  5. bimed's Avatar
    I can make a tutorial for this if the 3 of you want this.
    04-18-09 02:17 AM
  6. hoanhochubodoi's Avatar
    I found many people had the same problem.
    Thank you very much if you can help us.
    It took me alot of time to find a way to solve this problem but i couldn't!
    04-18-09 06:48 AM
  7. cschalk's Avatar
    Yeah, I'm interested in finding out how to activate the GPS! that'd be great! Thank You.
    04-18-09 11:13 PM
  8. rapproduca's Avatar
    I don't have the exact link, but google the word "Telmap". I found a post about it in the gps forums. It is a gps service that actually works as long as u just select uk as the country but provide your international and national area code phone number. I was having no luck with my gps no matter what I did and believe me when I say I've tryed EVERYTHING! Now I have full gps, I'm getting connections with like 8 satellites. I can even acquire a connection indoors at home and at work. I don't know how its possible but it works. My gps even now works on blackberry maps and google maps. I'm new to crackberry so I hope I'm not hot by posting this. I just felt I had to pass this information because I know how it feels to not be able to use everything your device has to offer. I have a Curve 8330 with US Cellular on an EV-DO network, and I think I'm close to addiction. Skip it why lie to myself I'm already there. And I'm not complaining.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-19-09 01:39 AM
  9. altournoux's Avatar
    I can make a tutorial for this if the 3 of you want this.
    Yes bimed, we are all interrested to read your tutorial that could solve our GPS activating problem.
    Best regards,
    04-20-09 10:21 AM
  10. altournoux's Avatar
    Also if someone could tell us how to unbrand. I have been looking for hours on the internet and I could not get the right info
    Help us please I don't wanna give up....I only want to use my BB full capabilities that some greedy business man are trying to restraint the of our devices
    04-21-09 07:38 AM
  11. rapproduca's Avatar
    I'm serious just download Telmap navigator to your phone. worth a try aint it?

    Posted from my CrackBerry at wapforums.crackberry.com
    04-21-09 10:56 AM
  12. altournoux's Avatar
    Yes, but I don't want a software.... I just want to lock a few satellites then I can Geo tag my pictures....
    In which way tellmap will help me in this way?
    04-21-09 12:08 PM
  13. austinc70's Avatar
    cna you send me the tutorial on how to unbrand the bb 8330 curve
    04-21-09 03:31 PM
  14. rapproduca's Avatar
    It was only an idea to push your device pick up satellites I could get no connection until I installed that app. It was just an idea I'm still a beginner myself I don't know how it works I just know it did for me. It was just an idea I honestly have no idea it worked until I installed that app I think it maybe has something to do with it being a uk application if u find a better way PLEASE let me know because the app is not really any much better than google and its just taking valuable space. I'm just afraid to uninstall it and risk myself not having a lock on sattelites anymore.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-22-09 11:43 PM
  15. altournoux's Avatar
    Okay so i found out that one way to get the GPS activate is to install an OS from a carrier that allows GPS features and then delete "vender.xml" file before updating your Terminal.

    Does any one know a carrier that got the gps feature activate by default?
    04-25-09 08:58 AM
  16. kristijan_kajic's Avatar
    I can make a tutorial for this if the 3 of you want this.
    hey! can you please send me this tutorial,
    heres the deal i downloaded about 3 different Free GPS mapping programs from some site, about 2 weeks ago, fooled on it for days trying to get some signal and nothing, i have no data plan and im not on any BES, living in croatia, payed for the BB upfront, so its kinda like prepaid in canada or the states, (used to live in canada), i can use most of the features it has to offer, except for the GPS, now the phone is from branded Vodafone... how can i use this.. the service provider has a plan where u pay like $50 per month and the give u Garmin service... bla bla bla... cant i just use some free sofware and just unlock the GPS unit inside it to be able to catch some satelite signals
    04-25-09 09:47 AM
  17. lastraid's Avatar
    GPS I believe uses data, no data plan no GPS
    04-25-09 10:22 AM
  18. kristijan_kajic's Avatar
    ok.....now explain.. data plan... if there is free software such as google maps.. in the app setting.. premisions: Connection Allow, interactions Allow, and user data Allow.... the BB device has a GPS reception unit inside it.. software to map where u are located .. what other data plan do u need...All i get when loading for a minute .. is a msg,... Network Unawailable, Application requires a data connection. Contact your carrier or go to googles maps webiste and when i get there ... no BB in the models.. or my country for expamle..
    04-25-09 10:37 AM
  19. lastraid's Avatar
    While it is GPS I believe it still uses data. THerefore you need a data plan. I think your respose with message you are getting sums up the problem.

    I also believe that google maps uses tower trianglation to locate you. This is why you need the data
    04-25-09 11:51 AM
  20. anarde's Avatar
    I have a BB curve 8330. I have a full unlimited data plan through us cellular. I've called and talked to at least 5 uscc reps and they've all said gps is automatically unlocked. However I have the exact same problem.. I open any map service and they all tell me I have no sattelite reception even though I've been in absolute perfect position for satellite signal while doing this. I'm beginning to think its somthing wrong with some of the phones.. If anyone has any tips please help me. By the way, already downloaded the telmap thing and it just tells me there's no service in my area.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-25-09 12:03 PM
  21. lastraid's Avatar
    Are you trying this inside or outside. Gaining a GPS signal inside can be challenging, as the signal does not penetrate very well.
    04-25-09 12:06 PM
  22. anarde's Avatar
    I was literally standing with no buildings withing about a half mile radius. I was walking by a river and its the clearest spot in my already small city. So I was outside on a hot sunny day with few clouds in site. I've also tried it multiple times in a car while driving on like highways and nothing then either. I've literally taken every tip I've found and tried it to no prevail.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-25-09 12:31 PM
  23. lastraid's Avatar
    Silly question: did you turn GPS services from 911 only to location on?

    options>advanced options>GPS and change the option there.

    Sorry have to ask
    04-25-09 12:37 PM
  24. azmansell's Avatar
    Hi guys, my gps plays up from time to time and here's how I fix it ... First I do a battery pull and let it restart. Then I go into settings > status and type the word test (you won't see the word but a menu will pop up) click the menu key and hit start.. Then select the gps option and let it run a test within a few seconds or mins (provided you are outside) it should come up with coordinates and say test finished. Go back to settings, click advanced then gps and then when in the menu click the menu key and press refresh gps... It shoulkd come up with your coordinates.

    Now you should be able to use your gps program

    Hope that helps

    Posted from my CrackBerry at wapforums.crackberry.com
    04-25-09 04:08 PM
  25. anarde's Avatar
    That's a new tip so Ill definently try that but there is no "refresh" option for CDMA 8330s. so I won't be able to do THAT step. I'll post with my results when I try it. Thanks

    Posted from my CrackBerry at wapforums.crackberry.com
    04-25-09 06:03 PM
53 123