1. ekred's Avatar
    Hello everybody!

    I own a 8830WE since around 8 months. I'm always on the road so I find the GPS capabilities of the device coupled with the Blackberry Maps software quite handy. What I usually do is that I find my current location using the GPS and then get the directions to go to some customer's office.

    Everything has been working great for the first 4-5 months but now Blackberry Maps is incapable of getting my location. I can manually enter two addresses and start the GPS navigation and it will (most of the time) follow me but everytime I select the "Where I Am" location, it searches for about 1-2 seconds before popping up a "Unable to acquire satelites. Please try again from a location with an unobstructed view of the sky."

    If I hit "ok" and try again right away, it will restart the "searching for satellites" window for "hours" without ending up on anything. It happened 2 or 3 times that it finally found something but over 95% of the time it doesn't.

    The funny thing is that I tried Google Maps and the GPS function does work in it. The problem is that I don't really like the way GMaps works plus it sucks up over 100k for every map view! With my 4mb plan I can't possibly use it...

    My carrier (Bell Mobility) has been absolutely useless if fixing this issue. I tried a whole bunch of different things and finally ended up doing a complete wipe of my device (using JL_CMDER) and reinstalling everything from scratch. What happened? Same damn thing!!

    Do you guys think it could be a hardware issue? It did slipped out of my hand 2 or 3 times but didn't drop from too high and outside of that I really take great care of it.

    I know there are many different other mapping softwares for the BB but I tried a bunch of them and always want to go back to BBMaps. Any help would be greatly appreciated.

    Thanks! (and sorry for the 100 pages post )
    05-24-08 12:06 PM
  2. jeffh's Avatar
    I use bbmaps with an external gps. I haven't seen this behavior before. Are you running any other s/w in the background that could be keeping bbmaps from getting the data? CoPilot will do that, for one.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-24-08 10:33 PM
  3. johnwill's Avatar
    I am interested in this issue too-specifically, could it be a hardware problem.

    I got my AT&T 8310 last year and GPS worked fine . . . until a couple of months ago. When I do the GPS refresh it still gives me the last fix back in November. Yes, I try it outside in full view where I never had problem before. Google and Blackberry maps same thing: cannot acquire satellites. So, I wonder if others have had an issue with the h/w just becoming defective and if there are any reports of this from users here.

    Is there any way to test whether our internal GPS itself is alive, using another external device?

    05-25-08 12:24 PM
  4. jeffh's Avatar
    Try going into your Host Resource Table and refresh.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-25-08 12:56 PM
  5. johnwill's Avatar
    Thanks for the comeback.

    Do you mean Host Routing Table? I just went in there and do not see a refresh option.

    05-25-08 02:24 PM
  6. jeffh's Avatar
    Yes. Host Routing Table. Menu and Register now. Sorry for the misleading instructions.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-25-08 02:27 PM
  7. johnwill's Avatar

    Juts tried what you say.

    Still no go with the GPS .

    I did get the e-mail saying my handset was registered though.

    Thanks again.

    05-25-08 02:45 PM
  8. jeffh's Avatar
    Re testing your internal GPS using external h/w. I can't test this, because Verizon disabled the internal GPS on my 8830, but it's something for you to think about: connect your bb to a pc usb port and run hyperterminal. See if you can find the com: port the GPS is using. It might be COM4: or COM5: If you can see the GPS with hyperterminal, you'll see the GPS output strings on your PC. I do that with my external bluetooth GPS. I'm just not sure hyperterminal can even see an internal GPS. But if it can, you can see if the GPS is working.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-27-08 09:39 PM
  9. johnwill's Avatar
    Thanks, I can't wait to try. I remember hyper terminal from XP and before. Is it still in Vista though?
    05-27-08 10:38 PM
  10. johnwill's Avatar
    Ok, as i thought no more ht in Vista, but i am gonna try Phone and Modem option in Control panel, I think same thing. We shall see
    05-27-08 10:48 PM
  11. johnwill's Avatar
    JeffH, did not get any string output from BB in my log. Nothing. Good idea though. Maybe this means GPS internal unit IS dead, for whatever reason. Wish I had a known working 8310 to control test against. Maybe I will just bring it in for exchange.

    Thanks again, John
    05-27-08 11:00 PM
  12. jeffh's Avatar
    Yeah, without somebody with a known good internal gps verifying the technique, you can't say anything definitive about your results. Maybe somebody will see this thread and try it.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-28-08 07:39 AM
  13. kajungolfers's Avatar
    I have a 8310 on AT&T with internal GPS. I dont have bb maps but use google maps and a 3rd party FREE program called GPSed gpsed.com/mobile) which used internal GPS. Also use
    MScorecard a golf scorecard program that uses GPS for yardages which you can use as trial for free to test your gps...I think the GPSed would give you a good test and its free.
    05-28-08 08:25 AM
  14. jeffh's Avatar
    Kajungolfers: any chance you could plug your 8310 into an XP or Vista PC and try the h/w test I suggested above? Anything you find would help answer the question, or rule out the diagnostic. Thanks.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-28-08 08:30 AM
  15. kajungolfers's Avatar
    tried using HyperTerm using com11 and com12 (these showed up in device manager as RIM virtual serial ports) using different baud/parity/stop bits etc...nothing got a response from the BB. would probably have to have some kind of app running on the blackberry to redirect the GPS information to the com port. without that i'm sure the BB by default does NOT send this info to virtual com port
    05-28-08 09:06 AM
  16. jeffh's Avatar
    Kajungolfers: thanks, you're most likely correct. I thought that might be the case. I was able to use hyperterminal to troubleshoot my external gps because bluetooth does map to a serial port. Was worth a try, though. I don't golf, but I'm interested in range-finding. I may look into your recommended product.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-28-08 09:40 AM
  17. johnwill's Avatar
    Finally got a great guy from NH AT&T who helped me. Within minutes he sent me an RMA #, and the turd from the Waltham Device Support center called me and I got a new unit today.

    And yes, the GPs works fine on this one and yes I have no Telenav subscription.

    Take that AT&T useless tech support and thanks to all the posters above for your advice, I appreciate it.

    06-06-08 08:15 PM