1. Bood08's Avatar
    Alright so, recently I just got a Storm 9550 off ebay from the states, of course a verizon phone. Other than some battery issues, the only other real issue is GPS. Before I was running on the Storm One European version (I think its the 9500??) and I had no problems with the GPS. The thing is, I live in Germany, and with my first phone, (The 9500) I bought it from here so it was a Vodafone phone. And now that I'm using a Verizon phone, with a German Vodafone plan, maybe something is different, and it wont allow me to use GPS. I have not touched my phone data plan, everything is the same.

    Maybe there is a way I can be sure of it not working, the only basis I have for this is that Google Maps always says "GPS Location not found" and also the Map Application does the same thing. (I'm running .670 bye the way.)
    04-19-10 03:10 AM
  2. dilipc's Avatar
    I use an unlocked Verizon 9550 Storm bought off eBay here in India. I have no problems with GPS (or anything else for that matter). Make sure your settings in Options>Advanced Options>Location Settings are set to enabled.
    04-19-10 04:59 AM
  3. Bood08's Avatar
    Maybe I'm blind, but I cant seem to find Location Settings anywhere in the Advanced Options settings....
    04-19-10 04:34 PM
  4. DRLyman's Avatar
    Maybe I'm blind, but I cant seem to find Location Settings anywhere in the Advanced Options settings....
    Options>Advanced Settings>GPS
    04-19-10 04:36 PM
  5. dkingsf's Avatar
    Also make sure you have the correct time zone set. Sometimes it gets "cornfused"
    04-19-10 05:39 PM
LINK TO POST COPIED TO CLIPBOARD