1. CharlestonBB's Avatar
    Hey everyone. Has a fix for the GPS on OS 5.0 for the 8330 been found yet? I upgraded the day it came out and loved it, but the GPS not working is a big issue for me so I downgraded back to 4.5 until some sort of fix for the GPS comes out.
    01-25-10 03:23 AM
  2. Wuzz Ranger's Avatar
    Well I see you have a 8330 from Verizon. Verizon blocked this feature on there 8330 model. No matter what you try for a GPS unit....Verizon will always be there shutting us down. They are trying to force us to you VZ Navigator. Here is a link to Verizon's forums explaining everything.

    Re: BlackBerry Curve 8330- GPS? - Verizon | Forums and Blogs - Verizon Community
    01-25-10 09:11 AM
  3. robr21's Avatar
    I am with Bell Mobility, who so far have not blocked any GPS, and my GPS is also not working. I wonder if it is just part of the 5.0 version released by Boost. Perhaps when our own carriers release their versions this will be fixed.
    01-25-10 10:33 AM
  4. CharlestonBB's Avatar
    Well I see you have a 8330 from Verizon. Verizon blocked this feature on there 8330 model. No matter what you try for a GPS unit....Verizon will always be there shutting us down. They are trying to force us to you VZ Navigator. Here is a link to Verizon's forums explaining everything.

    Re: BlackBerry Curve 8330- GPS? - Verizon | Forums and Blogs - Verizon Community
    it works fine on 4.5, but when i upgraded to 5.0 it kept saying that it couldnt acquire a satellite signal.
    01-25-10 12:56 PM
  5. Wuzz Ranger's Avatar
    it works fine on 4.5, but when i upgraded to 5.0 it kept saying that it couldnt acquire a satellite signal.
    Are you talking about VZNavigator for Verizon? This is the only GPS software that will work with the Verizon 8330. Third party software will not work with the 8330 from Verizon. Also, since 5.0 is a hybrid/boost, Verizon technical support will not help you so don't call them.

    They won't help you because 5.0 is not official in there eyes.
    01-25-10 03:12 PM
  6. whoopsazz's Avatar
    Actually Verizon unlocked GPS like 6+ months ago? It was with 4.5 i believe. However, it only works on BB Maps, but it still works!
    01-25-10 04:03 PM
  7. dcattran's Avatar
    I've got the same issue on Bell Mobility - previously worked great, now doesn't work. My other comment is that overall, 5.0 is good, but I'm not sure I'd recommend it at this stage on the 8330. You give up a fair amount of memory (not quantified, but I needed to delete a handful of apps to get it to work without (almost) endless wait time) Yes, there are some improvements, but really most of 5.0 is under the hood, enabling (presumably) new applications and functions, that, due to the restricted memory, you probably won't be able to install anyway...

    I'm stil running 5.0, since the weekend, and haven't noticed any other issues (than the GPS and reduced available memory) I'd love to see a stickied post about 0S 5.0 on 8330 in this forum, now that there's an official release posted.
    01-25-10 05:10 PM
  8. dcattran's Avatar
    Okay, I went on the Boost mobile website, and while they have other phones that list GPS enablement, the 8330 isn't one of them so I imagine they've had RIM disable the GPS in their build for them. (or something) I wonder why, but *>shrugs<* I guess you take your chances installing a different carrier's OS.
    01-25-10 08:10 PM
  9. plunkingtom's Avatar
    sPRINT NAV WORKS FINE WITH BOOSTS 5.0. I think it is a carrier lock.
    01-25-10 08:15 PM
  10. xliderider's Avatar
    It's probably that Verizon's service books don't support everything in the 5.0 OS, like GPS. As far as Verizon is concerned, it isn't a problem, because their official OS for the 8330 is 4.5.0.175
    01-25-10 08:36 PM
  11. michaelskis's Avatar
    I have an alltel / VzW and the 5.0 update worked great. I did run the TEST for the GPS before I opened BBMaps.

    I think it runs better now than it did before.
    01-25-10 10:16 PM
  12. docsmody's Avatar
    Works great on Sprint.
    01-25-10 11:29 PM
  13. Newfee_bullett's Avatar
    Hey guys this thread seems to have fallen off track from it's topic so to bring it back on track is there a fix or talk of a fix for the gps with os 5.0. I'm using a tour on the MTS network it is not a carrier block as I run 4.5 on my secondary blackberry also a tour and it still works perfectly. The app I use the most for its gps services is poynt and as earlier stated works perfect on 4.5 but not 5.0. UNLESS I'm in a major center. 5.0 seems to work fine will in a major center but not outside where as 4.5 is unrestricted regardless of where I am

    Thanks
    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    02-06-10 08:55 PM
  14. goodB0Y's Avatar
    Hey guys this thread seems to have fallen off track from it's topic so to bring it back on track is there a fix or talk of a fix for the gps with os 5.0. I'm using a tour on the MTS network it is not a carrier block as I run 4.5 on my secondary blackberry also a tour and it still works perfectly. The app I use the most for its gps services is poynt and as earlier stated works perfect on 4.5 but not 5.0. UNLESS I'm in a major center. 5.0 seems to work fine will in a major center but not outside where as 4.5 is unrestricted regardless of where I am

    Thanks
    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    I had the same problem with my 8330 on Virgin Mobile...which uses the Bell network...

    My gps didn't work after installing the boost os and I had to downgrade back to .4.5. I then tried again but wiped my phone and used shrink-os... Afterword my gps works fine.

    I am also now running a hybrid that is much much smaller than the origional boost os... and the gps works fine on it as well.

    I would suggest wiping the phone first and using either shrink-os or one of the hybrid's out there... and also remember to not restore any apps or stuff until the os is loaded and booted up.... trying to load this os along with a backup at the same time can cause troubles as you can run out of memory.

    I don't know if this helps but it might be worth a try...
    02-06-10 09:21 PM
LINK TO POST COPIED TO CLIPBOARD