1. GStyler's Avatar
    Figured I'd post this up for those having the same issues.

    I have an 8230, with Bell in Canada. not sure what version or OS, or whatever silly stats you might need to see if yours is the same as mine. I was getting very inaccurate GPS location with google maps. I never tried BB maps, or Bells version whatever that is.... I was getting my location to 5000m... 1200 at best.

    Upon further investigation, I guess Bell, and other companies dont fully enable the GPS features, so they can charge you 10 bucks a month for thier mapping service.

    there was a complicated fix posted up that I could not get to work (couldn;t get the correct memory location and length in one of the steps) that involved hacking your BB and Hex editors. here is that fix I was trying....maybe someone else can get it going and post up their settings.

    htttp://forums.crackberry.com/f41/real-fix-broken-gps-guide-v1-0-a-192999/

    while still searching for a fix for that, I found another post that said they simply downloaded a Garmin maps program, and installed it. This tricked the BB and enabled the locked GPS features. You can download a free trial of the Garmin program, and then just leave it on your BB once the 3 day trial has expired. I then had to uninstall then reinstall Google maps, and im getting a 10m lock. I just did this fix, and am still in my trial period. So no long term testing on this fix yet. some people said they unistalled the Garmin program once done. Im not gonna push my luck. Garmin mobile 5.0.4 program here:

    htttp://handheld.softpedia.com/get/GPS/Garmin-Mobile-for-BlackBerry-69091.shtml

    download the .zip and extract it. I then transfered the program to my BB with blackberry Desktop manager (available from BB). install, fire up garmin mobile once. just skip past the registration stuff. again, I had to reinstall google to get it to take.

    not sure if that makes any sense. dont really care. I found all of this myself searching these message boards, so nothing here is new. Just that nothing I could find has mentioned this fix working on this particular model.

    Enjoy.

    I guess I need more than 10 posts to put up links. You'll have to copy and paste them links Folks. and I put an extra T in hTTP.
    Last edited by GStyler; 04-16-10 at 09:57 PM. Reason: Sensitivity Training
    04-11-10 08:38 PM
  2. renegademoose's Avatar
    I tried it and it didn't work for me. I can't acquire any satellites. I'm on AllTel with version 4.6 of the OS. I also tried the other fix that you attempted before. I would really like to have GPS but it seems like I'm destined to not be able to get it to work.
    04-12-10 11:16 AM
  3. hommependu's Avatar
    I'm also in Canada and I found that my GPS was off by several blocks when it tried to predict my location. I attempted your fix and it really seems to work! It now knows almost exactly my location! Not sure about my provider blocking GPS features as I have no option to buy into anything GPS related, but I'm with MTS which I believe is a subsidiary of Bell.
    04-13-10 10:15 PM
  4. fedge's Avatar
    Gstlyer im sure people appreciate the post but please edit it and take the profanity out.. atleast put a **** there.
    04-13-10 10:20 PM
  5. bassmig's Avatar
    Seems to be working for now...I'll chime back in 3 days once I've uninstalled it.
    04-15-10 08:38 PM
  6. GStyler's Avatar
    I had originaly posted this in the 8230 forum for a reason, as there is no information there about fixes. For most other BB's people seem to be having success with that more complicated fix, but no one seems to have gotten it working for the 8230. This is a working alternative to that fix that does work for the 8230. Moving it here seems kind of silly.

    Its been a couple days and my 3 day trial for the Garmin program has ended. Everything is still working fine.

    I'm just goning to leave it installed, but not use it. We'll see how bassmig makes out after uninstalling.
    04-16-10 10:08 PM
  7. bassmig's Avatar
    I've uninstalled the app and my GPS seems to still be working...well as functional as the GPS in these devices are.

    PS. I agree that this SHOULD be in the 8230 section. I tried to find threads for BT when mine had an issue and I wasn't able to find anything useful since it was all info about other devices.
    Last edited by bassmig; 04-19-10 at 06:02 PM.
    04-19-10 04:17 PM
LINK TO POST COPIED TO CLIPBOARD