1. ancelot's Avatar
    Hello guys,

    My problem is about GPS. I'll trhow some details on my phone for a better understanding of the situation:

    -Originally an AT&T phone, but it's unlocked for worldwide use.
    -Living in UAE with Etisalat. Not relevant, but to avoid possible questions on this.
    -Full international data + roaming package.
    -OS up to date (not from the carrier, but the latest version)
    -I work for an Airline, so I use the full worldwide and get to try different networks/locations.
    -Cannot return since I bought it in a shop, so no exchange policies, nothing. I'll have to hope it's not a hardware issue and can get solved somehow.
    -Location is ON /Location data is disabled / Location aiding is disabled. Why? Because I want my phone to work on GPS, not A-GPS. I completely hate A-GPS.

    So here's the story:

    I bought the phone of a local store in New York. The phone works perfectly, had a few issues with the SOS + no voice service but after the update to the latest OS no more problems.

    The GPS is the big problem here, I takes a lot of time to get a location. That is when it works. I was in Houston yesteday and the GPS was not working. After manually changing networks, turning the GPS off, doing a battery pull, GPS back on the whole thing started to get fixes.

    I use an APP called GPS tool and it was showing perfect fixes, half a second delay. Also it was showing it was getting complete fixes on autonomous GPS. Now it only shows assited and partial fix.

    I go to the device status and type TEST and start the GPS fix, but always gets timed out (even after I was able to get my location).


    A week ago I was in Thailand, same story, taking forever to get the location... but after a few hours It worked. Same story.

    Now, I tried a friend's phone (the bold) and his GPS took him about 15/20 seconds to get a fix.


    Just got home back into Dubai and I can't make it work.

    If the GPS was working fine yesterday, means that the hardware works... but what the ****, I go to a different country and the device stops working!

    I've even tried using the GPS as standalone device (turned mobile network off) but no luck.


    Please CB experts, I would love some enlightening here.
    11-22-10 11:54 AM
  2. Tophaholic#CB's Avatar
    What navigation/map app are you using. I have an instant lock using BB maps and AT&T maps.
    11-22-10 02:24 PM
  3. shansmi's Avatar
    Have you used the stop/start GPS function with GPS Tool?

    Posted from my CrackBerry at wapforums.crackberry.com
    ancelot likes this.
    11-22-10 05:31 PM
  4. ancelot's Avatar
    Ok people, got the GPS working.

    I was trying to use the stop/start GPS function with GPS Tool, but still was showing "assisted GPS" which was a little bit weird, because it was supposed to be autonomous since I configured it from before. I double checked and apparently after you either close the app (not likely) or just do a battery pull, the assisted GPS goes back to ON by default. Or it could just be that I was playing around with the "Location settings" on the blackberry's options.

    Now, I don't know if the GPS tool was interfering with the satellite fix or just the opposite and helped me getting the autonomous GPS working (would be interesting to find out).


    Anyways, I am not yet able to get a very accurate lock, 4 satellites and accuracy of 60/70 meters. Not bad, but still wanting some more. It might be to the fact I'm indoors, even though I am in my room which has a massive window with a view of the outside and the sky. Better than nothing though!

    I'll jump on my car and check it out on outside and post back if there's any significant changes.
    11-22-10 10:53 PM
  5. shansmi's Avatar
    Glad things are working.
    11-22-10 10:58 PM
  6. ancelot's Avatar
    Bump.

    Same story again. I am back in Houston and GPS worked fine for the first hour after the phone was on. Then the OS gps was throwing 2500 meters accuracy and 4 satellites. After that, it's dead. When trying to refresh locations I get rarely get "location update failed" but most of the time it just won't do anything. It goes on "calculating current location" but then the message disappears and that's it, no update. Google maps shows 1000-600 meters accuracy (even though I have location aiding off in my settings). When I turn off the mobile network, google maps won't show any location (expectable).

    This is very confusing. How is it possible that the GPS cannot be directed? I feel like for some reason the OS shuts off the gps and will randomly turn it on. A faulty chip wouldn't work at all, so I think that's not the case here. I was back home in Dubai and the phone was fine! Been in Moscow last week, no problems. Sydney, nothing weird.

    GPS tool is stuck on a partial fix with 12 satellites (always 12) and no average signal. This is a clear indicator the GPS is not turned on.
    Tried several battery pulls with no success. Will try reloading the OS but doubt it will help.

    Any ideas? I would really hate to be stuck with a phone with faulty GPS, since I use it a lot.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-21-10 10:28 PM
  7. jeffh's Avatar
    If you fly several hundred miles with the GPS receiver off, the processor may have difficulty solving the equations for position when you turn in on in the new location. I occasionally (but not always) have this problem when I fly from Florida to Alabama. You are traveling much greater distances, which might exacerbate the problem. Turning off Location Assisting is making matters worse in this case, because you are depriving your phone of the Ground Signal that could help it find the correct location faster.

    I would not expect reloading the OS to have any effect at all on the GPS performance.
    12-22-10 12:00 AM
  8. ancelot's Avatar
    JeffH thanks for the answer,

    I understand your point and it makes a lot of sense till a certain level. The GPS worked for a few times as soon as I landed then it has been unresponsive ever since. Google maps works on A-GPS but that's a far as it goes,GPS remains unavailable.

    You said you have this problem, are you able to get a location at some point or only when you go back to Florida?

    Posted from my CrackBerry at wapforums.crackberry.com
    12-22-10 12:18 AM
  9. jeffh's Avatar
    My results have not been consistent. Sometimes the GPS locks on to my new location as soon as I land and turn on the phone. At other times the GPS has remained inoperative until I did a battery pull reboot. In those instances, the GPS didn't always begin working immediately, but it would always eventually start working. Typically if it doesn't start working right away, I reboot. If it still doesn't work, I just ignore it, so I don't know how long it takes to finally recover. It is frustrating, but since I don't need the GPS for nav at either airport, it isn't critical. It hasn't yet happened in a location where I had to have the GPS immediately available, but there's no guarantee it won't.

    I always have Location Aiding enabled.
    12-22-10 12:28 AM
  10. ancelot's Avatar
    Probably I will go back to the UAE and get it working in less than a minute. But this is still a concern since the GPS should be able to lock after a few tries, which is not the case here. Been trying for more than 24 hours and the GPS is just ignoring me!

    Thanks anyways.
    12-22-10 12:53 AM
  11. jeffh's Avatar
    What model phone are you using?

    Posted from my CrackBerry at wapforums.crackberry.com
    12-22-10 08:27 AM
  12. Barfaroo's Avatar
    Jeff,
    You may remember I had a lot of trouble with my Blackberry 8330 getting a gps signal. I switched to an android a couple of months ago (HTC Desire) and have connected with no problems at all. It sure beats the **** out of the 8330.
    12-22-10 10:14 AM
  13. ancelot's Avatar
    I'm on a Torch originally locked to AT&T but on a different carrier (etisalat)

    Posted from my CrackBerry at wapforums.crackberry.com
    12-22-10 11:20 AM
  14. jeffh's Avatar
    I recall Barfaroo's problems very well. That's one reason I asked what device the OP is using. The carrier and device makes a difference. What the OP is experiencing may partly be a function of how the Torch operates with a US carrier if it is normally used with an etisalat SIM. What SIM do you use in the US? I'm guessing about the SIM, since I'm a CDMA user. It may take another user with the same setup to definitely diagnose the problem.
    12-22-10 11:54 AM
  15. ancelot's Avatar
    Just changed to a Vodafone UK SIM card I had hand but same outcome.
    Here in the US I'm using the Etisalat SIM as I do everywhere I go.
    But still there's something that's is not clear to me. How the carrier or network can justify the fact I cannot get a lock using the satellite based GPS? Shouldn't the GPS work regardless of SIM/Networks/Carrier?

    Posted from my CrackBerry at wapforums.crackberry.com
    12-22-10 01:29 PM
  16. jeffh's Avatar
    ...Shouldn't the GPS work regardless of SIM/Networks/Carrier?...
    Not necessarily. For example, the 8830 (a previous generation world phone) could be unlocked to be used on GSM frequencies in Europe and Asia, but the GPS only worked in conjunction with a CDMA carrier. I'd be surprised if the Torch had the same restriction, but a similar dependency might explain your issue. It may take another Torch user with a similar configuration to confirm it.
    12-22-10 01:36 PM
  17. ancelot's Avatar
    Interesting...

    Being bought here in the US, it wouldn't surprise me, and in a way explains the weird behaviour but not any less frustrating though.

    Any ideas on how to check that without needing another Torch?

    Just to clarify Jeff, are you refering to standalone GPS? Because you seem to emphasize on carriers and networks, whereas I'm refering to the standalone GPS module
    Last edited by ancelot; 12-22-10 at 01:57 PM.
    12-22-10 01:54 PM
  18. jeffh's Avatar
    You mentioned in your initial post that the internal self-test of the GPS sometimes (or is it always?) fails. That may be sufficient independent confirmation that the Torch GPS won't work in autonomous mode with your particular SIM/Carrier environment. Even if you don't want to use Assisted GPS mode all the time, it may be worth it to use it when that's the only way to get your GPS to work at all.
    12-22-10 03:00 PM
  19. ancelot's Avatar
    Even when It was working with less than 5 meters of accuracy the self test has never worke, always got a time out. As per the blackberry OS, my GPS never locks, always times out. Yet, I was getting a fix, even from the "refres" option within the options menu.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-22-10 03:09 PM
  20. jeffh's Avatar
    Interesting. CDMA phones (I have the Tour) don't have a Refresh GPS command, so I can't try that. The internal self-test always passes. That yours does not clearly indicates some problem. If you are the original owner, you may have grounds for a warranty claim. I don't know if unlocking affects the warranty or not, but the warranty is through RIM, not the store where you bought the phone, so the shop won't matter as long as you are the original owner.
    12-22-10 03:22 PM
  21. ancelot's Avatar
    Unfortunately I bought it from one of those electronic shops in NY already unlocked over the counter (I bought it the first week it came out and was the only way of getting one unlocked), so most likely I'm not elegible, unless it works like Apple's worldwide warranty.

    I am on my way to the airport and the GPS is fully functional again. But for the past 2 days was unoperative. Who knows.

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by ancelot; 12-22-10 at 05:04 PM.
    12-22-10 05:02 PM
  22. rob w's Avatar
    I've got a 9780 and seen the same sort of thing especially after travelling. For example the next day after a flight I cant seem to power the GPS up and I use the GPS Tool. This seems to last for anything from an hour to a few days -very strange.
    12-27-10 12:45 PM
LINK TO POST COPIED TO CLIPBOARD