1. joestrummer79's Avatar
    I'm using a Linksys WRT54G at home and have my wifi all setup and running smooth. One quick question is that whenever I use Google Maps and I'm hooked to my home network, it says my location is at my old address which is in a different part of town. It's not a big deal, but it's frustrating when I'm trying to find things near where I live. Any ideas on why my router is programmed for my old address and how to update that?

    Thanks, y'all!
    05-22-09 11:48 PM
  2. crackberry_jones's Avatar
    That doesn't make any sense. I mean; the GPS radio on the phone should be handing your start point to Google Maps. I stopped using GM because it shows my "location" as wandering around the city (even after several minutes) under OS and I figure if it can't find a stationary target, it's useless to me if I actually need it (such as in a car). So I went back to BB Maps.

    How long ago did you move to the new place?
    05-23-09 01:14 AM
  3. joestrummer79's Avatar
    Yeah, I noticed that GM was doing that to, but then I switched my GPS on and it works okay. Before, I'd be driving and looking at the map and it would float all over the place (I have .239 as well). Try turning your GPS on and see how it works.

    As far as when I'm home, if I have my wifi turned off, the EDGE network points to my correct location. If I'm connected through UMA on my home router, it says I'm exactly at my old address which I moved from back in November.

    Very strange, say I...
    05-23-09 02:03 PM
  4. crackberry_jones's Avatar
    I wouldn't be complaining about GM's performance if I hadn't turned the GPS on! GM was "broken" as described (apparently stuck on "coarse" location-by-cell-tower and perpetually "searching for satellites"). I was connected to UMA at the time. It just wouldn't "lock on" to the handset. So I launched BB Maps and it had a lock on 5-6 satellites in about a minute. That GM would think you're somewhere you haven't been for months is quite a strange issue. I have to wonder if it's using some kind of "cookie" from when you were at the old place...

    Posted from my CrackBerry at wapforums.crackberry.com
    05-24-09 08:25 AM
  5. TheScionicMan's Avatar
    It almost sounds like its looking at E911 info, like you have to give with VOIP. But maybe not if a reinstall fixed it...
    05-26-09 03:31 AM
  6. crackberry_jones's Avatar
    @TSM: That nearly crossed my mind, too. But I figured Joe's ISP would have the correct address on-file... That's a great idea.

    So, Joe, what do you know?

    PS- I still think that Google Maps is worthless (though not as bad as MapQuest) except for the Satellite and Street views. It doesn't integrate fully with the handset OS (can't set it as default map app, for instance) and it can't find a properly formatted single-line address (999 City Rd. City, ST 99999)... In short, Google Maps is nearly useless (but pretty).

    Posted from my CrackBerry at wapforums.crackberry.com
    05-27-09 06:13 AM
  7. joestrummer79's Avatar
    GM works fine for me normally. Haven't tried the reinstall yet, but have no issues on a normal basis. It's only when I'm connected to my router through UMA that it says I'm at my old address. If I switch off my WiFi and use the EDGE network at home, it shows my correct location, which leads me to believe that it's something in my router...
    CJ: As far as what ur experiencing, I have no clue why GM wouldn't do what BB maps does...
    TSM: what's E911 info and VOIP?

    Posted from my CrackBerry at wapforums.crackberry.com
    05-27-09 11:30 AM
  8. crackberry_jones's Avatar
    E911 is information (street address, name, etc.) that your ISP sends to the police when you call 911 via Voice Over Internet Protocol (VOIP).

    UMA calling, Vonage, telephone service through your cable/satellite Internet provider, etc. are all examples of VOIP. Maybe your ISP never bothered to change that information when you moved house. That's starting to look like what's going on with your WiFi GPS location problem.

    As far as what happened with me; I'm guessing that GM didn't play well with the firmware upgrade. I'd installed under *.114 and upgraded to *.239 with apploader (rather than Desktop Manager). All I know is that uninstalling GM, restarting the handset, a battery pull for good measure, and reinstalling GM seemed to fix it for me.

    All of this reminds me that I need to go around to various sites to update my phone number. Good luck, Joe!

    Posted from my CrackBerry at wapforums.crackberry.com
    05-28-09 09:11 AM