1. _GoLeafsGo_'s Avatar
    Hey all,

    I need some help with this issue or after 6 years of loyalty to BlackBerry this thing will be gone by dinner time.

    I have a BB9700 that for some reason keeps duplicating my contacts on my Berry, when i go to Contacts>Options>General Options Allow duplicate names is turned off, and GMail is set to wireless sync. But like i said i went from having 450 contacts to 1764 and counting.

    When i go to the laptop and log onto GMail my contacts have also be duplicated over and over and over again. i go to merge all the contacts in my contact list and they just keep coming back.

    This is beyond frustrating please help prevent me from tossing my berry and moving to something different !!
    09-15-10 09:37 AM
  2. elvin1983's Avatar
    This has happened to you, me, and just about everyone else who's ever done a Gmail contacts sync on their BB, it is quite frustrating, however, there is no real solution to this problem. I tweeted to @blackberryhelp on this a while back, and the response that I got is that you should make sure all the contacts are in your Gmail contacts list the way that you want them, then clear your entire BB address book, and then do the sync, that should make it work properly. I didn't find this to be a reasonable solution, so I never did it. If you want to give it a shot, I would make sure to do a backup of your contacts list off of your BB before clearing out the address book.

    Best of luck!
    09-15-10 09:45 AM
  3. jinxednuance's Avatar
    I had this problem only once when I initially enabled wireless sync with Gmail and Blackberry. Yes, I did get plenty of duplicates but Gmail's merge feature was smart enough to merge most of my contacts in a few minutes.

    Since then I never had a duplication.

    Not sure why does it keep coming back to you out of nowhere... Sorry.
    09-15-10 02:05 PM
  4. syb0rg's Avatar
    to easily and effectively fix the problem, you need to go to Manage E-Mail > then to your google account > sync options and make sure "contacts" is turned off....

    if you wish to sync your contacts with your Google account use google sync. (Google Sync for your phone)
    Last edited by mjneid; 09-15-10 at 02:15 PM.
    09-15-10 02:11 PM
  5. angelbleu's Avatar
    I second mjneid's suggestion.

    Once I stopped using BB's native Google contact sync and started using Google Sync, I've never encountered any more duplications.
    09-15-10 11:36 PM
LINK TO POST COPIED TO CLIPBOARD