12-03-10 02:38 PM
61 123
tools
  1. Brigadier's Avatar
    Tried to edit title, but forum software won't permit it.


    OK. My Torch wifi had issues at home. It was very, very, very slooooooooww. At work, it was fast. At Starbucks on AT&T Wifi it was fast. At the Dr's office waiting room it was very fast[open network]. But at home on my NetGear 802.11b/g/n WNR3500, uh uh. Talk about frustrating.
    I've been doing everything I could think of to fix it. Well, I finally found a fix. I just happened to hit the right Google search and came up with this[sorry, lost link]

    1. Disable the router's 'N' speed. Switch it to b/g only[max 54Mbps].
    2. Manually choose channel 11.

    BINGO!!!! Now it works fine!! And works very well.

    Well, unfortunately, RIM is guilty of false advertising here as, at least with NetGear routers, the Torch is NOT 'N' compatible. WTF RIM????

    So now my laptop Wifi at home suffers a speed penatly cuz of my Torch. Nice.
    Last edited by Brigadier; 12-02-10 at 07:42 PM.
    11-30-10 11:10 AM
  2. pbflash's Avatar
    My Torch works fine on N with my Belkin router. Did you try restarting your router before disabling the N signal?
    11-30-10 11:14 AM
  3. homer1475's Avatar
    I use Only N band at my house. My torch connects to my router just fine.

    With this being said let me explain. I have a dual band router(Linksys wrt610n), one band is for my pc's(40mhz only), the torch will not connect on that band. My other band is for other things like my printer and torch(20mhz only). I connect and transmit data without any issue on the 20mhz band.

    Could be the mhz that your netgear router transmits on?

    I believe I looked this up when i was having issues and it said the torch connects on N band at 20mhz. Don't quote me on that as I'm quoting from memory.
    11-30-10 11:17 AM
  4. Fubaz's Avatar
    I am in agreeance with the OP, after another forum member recommended disabling N, I am able to enjoy WiFi at home with more ease using b/g mixed(liksys router).

    At my shop I have a Belkin and it has N enabled with no issue.

    It must be certain routers that give this issue.
    11-30-10 11:17 AM
  5. homer1475's Avatar
    Routers or the mhz at which they transmit the signal on. Someone with a little more time on their hands could probably research this. I for one am way to lazy today to look it up since mine works perfect.
    11-30-10 11:20 AM
  6. aznlgcy's Avatar
    I only use N at home. I think it may only like certain brand of routers

    Posted from my CrackBerry at wapforums.crackberry.com
    11-30-10 11:20 AM
  7. pbflash's Avatar
    My Belkin router has the option for 20 or 20/40. Tried it on both settings and it works. It doesn't have the option for only 40 so I can't test that.
    11-30-10 11:24 AM
  8. Dragondima's Avatar
    Sorry, but the Torch is in fact wireless N certified. What router do you have, and what's it's model? I'm willing to bet it's an older wireless N router. I personally have a fairly new DLink Wireless N router, and have never experienced any issues. Routers also have firmware, i'd suggest you taking a look and seeing if yours has an updates. Best of luck!
    11-30-10 11:31 AM
  9. 5picker's Avatar
    I'm using Trendnet routers on N at home and at work and they work perfect with my 9800 so the Torch is N compatible. I'm guessing it's a problem with the OP's particular brand. Sucks none the less.
    11-30-10 11:32 AM
  10. Brigadier's Avatar
    Sorry, but the Torch is in fact wireless N certified. What router do you have, and what's it's model? I'm willing to bet it's an older wireless N router. I personally have a fairly new DLink Wireless N router, and have never experienced any issues. Routers also have firmware, i'd suggest you taking a look and seeing if yours has an updates. Best of luck!
    Um, read the OP.

    But at home on my NetGear 802.11b/g/n WNR3500, uh uh.
    And yes, I have checked for updates - none available for my router. It is less than a year old, so it is not that antiquated.

    Maybe it is my router, but I did alot of Google searches, and it became quite clear that Blackberry's and NetGear routers do not like each other very much.
    11-30-10 11:47 AM
  11. vistate1's Avatar
    FYI the torch does not work on 802.11N (5GHZ)

    it only works on 2.4 GHZ. had that problem initially with my set up.

    but i just downgraded to 2.4
    11-30-10 11:48 AM
  12. Aussie Joe's Avatar
    It works on an Apple Airport Extreme.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-30-10 11:56 AM
  13. Brigadier's Avatar
    Found the link. Note, the advice in this blog came from NetGear!!!!

    I know it was for an 8900, but so far, it is the ONLY thing that worked for my 9800.

    Troubleshooting Blackberry and Netgear, Curve 8900 Wi-Fi/UMA Connection with NETGEAR Wireless Router

    My next step was to call Netgear. I reached Ryan, agent #3228 in the Philippines after a few menu choices. Ryan took me through the following configuration changes: switch to Channel 11, set Mode to b and g, and turn off WEP. Bingo, the Blackberry connected and rolled right over to UMA mode.
    My next step, before finding this fix, was to buy a different brand router. I may still do that down the road.

    http://forums.crackberry.com/f52/do-...mething-91295/
    11-30-10 12:30 PM
  14. pbflash's Avatar
    Before buying a new router I would make sure you are running the most current firmware for the router. Not sure if you have the 3500v1 or v2. Here is a link to a page where you can select the router you have and then get the current firmware. WNR3500 Model. Once you have the firmware installed I would try using N again and I would also use WPA instead of WEP. I wouldn't totally disable the security as you're leaving your network open for anyone to connect to it.
    Brigadier likes this.
    11-30-10 12:42 PM
  15. Brigadier's Avatar
    Before buying a new router I would make sure you are running the most current firmware for the router. Not sure if you have the 3500v1 or v2. Here is a link to a page where you can select the router you have and then get the current firmware. WNR3500 Model. Once you have the firmware installed I would try using N again and I would also use WPA instead of WEP. I wouldn't totally disable the security as you're leaving your network open for anyone to connect to it.
    Everytime I open the router settings, it checks for updates, and comes back with nothing, so I assume there are no updates for it.

    I do not use security. It degrades over time, and then the router becomes useless. I use open, hidden networks. Works wonderfully.
    11-30-10 12:48 PM
  16. 5picker's Avatar
    FYI the torch does not work on 802.11N (5GHZ)
    it only works on 2.4 GHZ. had that problem initially with my set up.
    but i just downgraded to 2.4
    That almost reads like you are saying a router operating at 2.412 ~ 2.484 GHz isn't N. Whether it uses 2.4 or 5 GHz spectrum, it still supports the 802.11N client. Routers operating in the 5 GHz spectrum are often referred to as 802.11Na.
    11-30-10 12:55 PM
  17. pbflash's Avatar
    Everytime I open the router settings, it checks for updates, and comes back with nothing, so I assume there are no updates for it.

    I do not use security. It degrades over time, and then the router becomes useless. I use open, hidden networks. Works wonderfully.
    If it automatically checks for updates then you probably have the most current firmware.

    I have never heard of the routers security degrading the router. You were using WEP before so why not try WPA? Did you try using N with WEP turned off. You made both changes at the same time so for all you know, it was WEP that was causing the problem.
    11-30-10 12:59 PM
  18. joe.kent's Avatar
    Everytime I open the router settings, it checks for updates, and comes back with nothing, so I assume there are no updates for it.

    I do not use security. It degrades over time, and then the router becomes useless. I use open, hidden networks. Works wonderfully.
    This is not a good idea... Simply hiding the SSID from broadcasting isn't a hidden network, there are programs that will allow anyone driving by your house to see them, even without the SSID, and being open, somone could easily see everything going on inside your network. Check out netstumbler or Vistumber if you have Win7... you'd be amazed what you can find out about your surroundings.

    Also, if you want to check for updates, visit the product website and search there... don't rely on the device to do it for you.
    11-30-10 01:03 PM
  19. 5picker's Avatar
    I agree with pbflash... I have NEVER heard of a router degrading over time because of security enabled. I have a secure router running in my garage that has not been rebooted in likely over 3 years with no loss of data transfer. Most times, in my experience, routers tend to loose their mind because of outdated firmware.
    11-30-10 01:06 PM
  20. homer1475's Avatar
    Anyone in this day and age that still uses an open network for home computing is simply not very smart.

    I seem to remember a few weeks back there was an article on the news about a guy getting charged for kiddie porn even though he didn't do it. It was a simple matter of someone using his open wifi.

    I use wpa2-personal, and as added security, lock it down to my device specific mac addresses.
    11-30-10 01:08 PM
  21. joe.kent's Avatar
    Anyone in this day and age that still uses an open network for home computing is simply not very smart.

    I seem to remember a few weeks back there was an article on the news about a guy getting charged for kiddie porn even though he didn't do it. It was a simple matter of someone using his open wifi.

    I use wpa2-personal, and as added security, lock it down to my device specific mac addresses.
    Very true homer... If your router assigns the IP address.. you are liable.
    11-30-10 02:42 PM
  22. Brigadier's Avatar
    I agree with pbflash... I have NEVER heard of a router degrading over time because of security enabled. I have a secure router running in my garage that has not been rebooted in likely over 3 years with no loss of data transfer. Most times, in my experience, routers tend to loose their mind because of outdated firmware.
    I used to run security, and over time I had trouble connecting to the wifi. My commputer and phone just would not connect, period. We had the same issue with the wifi at the office. Our IT guy kept rebooting/restarting/restoring the router and it kept happening. Went to an open hidden network without Broadcasting SSID, and it has never, ever been a problem again. So he suggested I try it at home - hidden open network. Worked great, never had a connection issue again, until I bought a Blackberry.
    11-30-10 02:53 PM
  23. pbflash's Avatar
    You say you were running on open network but in a previous post you say that the Netgear tech had you disable WEP. Which one is it? Have you tried using WPA? WEP is outdated and may not work with some devices. I have never had a problem with any device using WPA.

    As mentioned in previous posts, running an open hidden network without Broadcasting SSID is not very secure and you're leaving your network open for anyone.
    11-30-10 03:06 PM
  24. Brigadier's Avatar
    You say you were running on open network but in a previous post you say that the Netgear tech had you disable WEP. Which one is it? Have you tried using WPA? WEP is outdated and may not work with some devices. I have never had a problem with any device using WPA.

    As mentioned in previous posts, running an open hidden network without Broadcasting SSID is not very secure and you're leaving your network open for anyone.
    No, the blog I found said THEY were running WEP. I was running an open network and still couldn't connect the Damn Torch to it in 'N' mode!!! I just followed their advice about turning off 'N' and using channel 11. That was the difference.
    11-30-10 03:09 PM
  25. laollis's Avatar
    My router is "N", and everything works perfectly.
    11-30-10 03:43 PM
61 123
LINK TO POST COPIED TO CLIPBOARD