1. jeff.kitching's Avatar
    Hi, Is there any way I can stop unwanted SMS messages arriving at my phone and just accept those in my contacts list, your help would be appreciated. Thanks.
    03-28-12 08:54 AM
  2. wazzugrad's Avatar
    in the SMS folder, open the menu, and find options. If you scroll down towards the bottom there is a message filtering option. I have never used this, but it may be what you are looking for.
    03-28-12 11:26 AM
  3. jeff.kitching's Avatar
    Will try that! Thanks very much.
    03-28-12 11:58 AM
  4. sam_b77's Avatar
    That won't work.

    Go to settings>security>firewall.
    Enable firewall and choose the option to receive SMS only from your phonebook. You can also enable certain generic numbers. Works like a charm stops spam in its tracks.
    03-28-12 12:40 PM
  5. ronnel.gacutana's Avatar
    That won't work.

    Go to settings>security>firewall.
    Enable firewall and choose the option to receive SMS only from your phonebook. You can also enable certain generic numbers. Works like a charm stops spam in its tracks.
    This one is correct but also consider the carrier you have because it may not work to some carriers, especially those who charges you for receiving SMS.
    03-29-12 03:17 AM
  6. sam_b77's Avatar
    The firewall works for all carriers because the blocking is done by the device not the network. As a matter of fact your BB will also show you the number of messages blocked.

    The message filtering option in SMS options is carrier dependant.
    03-29-12 04:04 AM
LINK TO POST COPIED TO CLIPBOARD