1. pasta1234's Avatar
    My Unlocked ATT BB9700 wont fix to any GPS Signal for some reason and i noticed this as i was attempting to use Google maps earlier today. I have tried the following with no results...

    1. Battery Pull.
    2. Clicking Refresh in Settings results in all zeros.
    3. Running GPS Self Test Times out.
    4. Wiped OS with BBSAK and reloaded latest OS ?

    I even tried re-fixing outside with clear sky view ? ?

    Any ideas ?

    Thanks
    Pete
    12-31-10 04:28 AM
  2. Branta's Avatar
    First fix from a cold start may take up to 40 minutes if the device has to download new almanack and ephemeris data. Give it time, that's a fact of GPS life.

    If that doesn't work you may have a hardware failure or local interference blocking the signal.
    12-31-10 04:46 AM
  3. pasta1234's Avatar
    Happy New Year !!

    I left the phone outside with Google maps open for more than an hour and it still couldn't not initiate a GPS fix. Refreshing the GPS in device options just results in all zeros !!

    A few weeks ago i did open the device to replace the bezel and loudspeaker and everything worked fine after wards.

    Any ideas, possible a loose component or connection ?

    Thx
    01-01-11 02:31 PM
  4. Rootbrian's Avatar
    Happy New Year !!

    I left the phone outside with Google maps open for more than an hour and it still couldn't not initiate a GPS fix. Refreshing the GPS in device options just results in all zeros !!

    A few weeks ago i did open the device to replace the bezel and loudspeaker and everything worked fine after wards.

    Any ideas, possible a loose component or connection ?

    Thx
    Try this: options > status, type in TEST and check the GPS tests, proceed. Post back results, do this outside.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-01-11 07:21 PM
  5. pasta1234's Avatar
    Result of the test is..

    "Timed out while waiting for GPS location"

    Ideas or suggestions ?

    Pete
    01-01-11 08:59 PM
  6. Rootbrian's Avatar
    Result of the test is..

    "Timed out while waiting for GPS location"

    Ideas or suggestions ?

    Pete
    That shows it's a hardware fault. You'll need to request a warranty replacement. A repair won't cut it.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-02-11 06:01 AM
  7. Branta's Avatar
    That shows it's a hardware fault. You'll need to request a warranty replacement. A repair won't cut it.
    Agree, the hardware test says the GPS is dead. Unfortunately no warranty, the OP admits opening the phone... warranty is void even if it is still in the time period.
    01-02-11 07:21 AM
  8. Rootbrian's Avatar
    Agree, the hardware test says the GPS is dead. Unfortunately no warranty, the OP admits opening the phone... warranty is void even if it is still in the time period.
    They'll have to buy a new 9700, or just stick with a 9300. Both are relatively the same in specs except camera has no flash, 1 step down in resolution from the 9700's 480x360 to 320x240. Not noticeable for most anyways. Cost is cheaper imho if the OP doesn't care about it. I would move to a curve if this voided 9700 ceased to work at all.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-02-11 04:17 PM
  9. pasta1234's Avatar
    Well folks an update...I fixed it. Thought i would share in case anyone else having a similar issue.

    On the back plate there is a sticker that spans the back and curves on the inside under the board with a very tiny gold contact. After examining it, i realized it had moved a bit and wasn't making contact with the board. I put it back in position and gps is working, apparently the tape is an antenna

    Thanks
    Pete
    01-19-11 04:05 PM
LINK TO POST COPIED TO CLIPBOARD