1. bsliv's Avatar
    Help,

    I run a web server at home and my new 8530 keeps getting an error 504. A friend's BB also gets the 504. Another friend's LG works just fine, as do desktops.

    I setup a nearly identical server and the BB works just fine. The only difference is that on my home server, port 80 is blocked by my isp. So I run the server on port 82, and have dyndns and my router working to have it seem like port 80. And this seems to be part of my problem.

    From the options menu, service book, I deleted wap.browser something or other. and that allowed a 'Details' button after the 504 error.

    The details say, "while trying to retrievie the url: my domain name
    The following error was encountered:
    Connection to 68.224.xxx.xxx Failed."

    Of course it failed. 68.224.xxx.xxx is my ip addy with port 80 blocked.

    So I try to go to 68.224.xxx.xxx:82 directly and it gives the same error. Its as if the browser is dropping the port number.

    Since other pc's and even an LG cell phone can access the server and the only device that can't is two Blackberrys, I believe the problem lies with the Blackberry. But the Blackberry connects fine to a nearly identical server running on port 80 without dyndns.

    What can I do to have my Blackberry connect to my home server? My service is Metro PCS.
    Last edited by bsliv; 12-02-10 at 09:44 PM. Reason: more info
    12-02-10 09:06 PM
LINK TO POST COPIED TO CLIPBOARD