1. tneihouse's Avatar
    I am a newer BB user and I tried to send about 5 emails last night from my BB and the messages are still pending to send 8 hours later. I checked standard messaging and it worked. I even tries BB messenger and those messages are pending as well. Does anyone have an idea on what could be happening with my phone. Oh in case it matters I have the 8530 Curve on the Sprint network. Thank you in advance.
    06-14-10 06:13 AM
  2. fkornre's Avatar
    I had an issue like this yesterday with some MMS messages i was sending and this was using Verizon. I waited about 15 mins and they just sat so i did a battery pull and everything worked fine once it rebooted.
    06-14-10 08:08 AM
  3. jabbs1's Avatar
    Sounds like your data services are turned off. Did u purchase a data plan with your Curve?
    06-14-10 09:40 AM
  4. pkcable's Avatar
    If a battery pull does not fix it, try an HRT reset, and send service books. For the HRT reset, go to Options, Advanced, Host Routing, press the BB button, and select Register Now. Then for the Service Books, go to the Setup Folder (or it may be on your homscreen) and open Email Setup, then sign on with your user name and password (if you don't know them, then you can't try this step, without calling your carrier), press the BB button, and select Service Books, then Send Service Books.
    06-14-10 10:29 AM
  5. ST79's Avatar
    Do you have a BB data plan? If yes, do what pkcable suggested...and if NOT, you need to have one for push email and bbm to work...

    Posted from my CrackBerry at wapforums.crackberry.com
    06-14-10 02:56 PM
  6. Lovato's Avatar
    Make sure you have a Blackberry data plan. If you do, then check that data services is turned on. If it is off and it doesn't allow you to turn it on, pull the battery and put it back in. When the phone reboots, you should be good.
    06-14-10 03:50 PM
  7. tneihouse's Avatar
    Thanks for the help. Pulling the battery worked. Yes, I do have a data plan. It worked until 2 days ago and just locked up. It is working now.
    06-15-10 06:26 AM
LINK TO POST COPIED TO CLIPBOARD