1. kyriefurro's Avatar
    So this weekend a friend and I had a rather lengthy e-mail conversation - several messages sent back and forth over the course of a couple of days. Most of my participation took place on my Curve.

    After several emails, my friend asked if I could add some line breaks to my e-mails. Out of curiosity, I pulled up the whole exchange on my PC and saw why I was giving her fits. Each paragraph was coming across as one single, very long line. She had to keep scrolling right and left to read my messages.

    So, does anyone know of a way (software or setting) to force my BB to insert line breaks at, say, 60 characters or so?

    FWIW, I'm using the standard BB email app, with an MSN/Hotmail email account.
    07-16-08 11:49 AM
  2. jeffh's Avatar
    I can't exactly duplicate your setup, because I'm using outlook on my pc, not hotmail. That said, I think the problem is on your friend's machine. If I type an email on my bb, the line breaks at the end of the bb screen. If I send that email to myself and view it in Outlook, the line breaks wherever the outlook message pane ends. I can't find any way to force scrolling left and right on the PC.
    07-16-08 09:50 PM
  3. kyriefurro's Avatar
    It turned out to be a combination of both. The native blackberry email client doesn't insert line breaks. Outlook will insert it's own breaks, but my friend was using a web based client which didn't do that.

    I installed the Empower html email app yesterday, and that solved the problem.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-17-08 03:43 PM
  4. Sylin's Avatar
    I'm having this same problem with my new Curve 8330.

    Any e-mails I send from the device seem to be devoid of line breaks (carriage returns). If I use the Return key on the BB to start a new paragraph or line in an e-mail, when the recipient gets it (even when I get it BCC'd back to myself on my BB), those breaks are gone.

    What I find odd is this phenomenon also occurs with the signatures I've set up via the BIS web site. My entire sig, which should look like this:

    Name
    Company
    Phone #
    E-Mail Address

    ...instead shows up like this:

    NameCompanyPhone #E-Mail Address

    Aside from this looking terribly unprofessional, it makes a lot of messages a pain for my recipients to read, and this is occurring regardless of browser/email client type (Outlook, Entourage, Gmail, etc.). So I'm guessing it's my BB setup.

    Any tips on how to fix this?
    11-04-08 02:08 PM
  5. jeffh's Avatar
    I have searched the forums, and can't find this problem discussed anywhere else. I don't have an 8330, but I've looked at every setting on my 8830, and I can't find anything that would cause the result you're describing. And of course I can't replicate it.

    I'm using the BBClarity Font family, Size 7 Plain with Font Smoothing turned on. If you use this font, does it correct your problem? If it does, what font were you using?

    Can you go to a Sprint store and try to reproduce the problem with a different phone?

    If your phone is less than 30 days old, Sprint will give you a new one. I would try another phone.

    Fonts are loaded with the OS. If getting a new phone is not an option, then I'd make a backup, then reload my OS. Or load a newer OS if one has been officially released.

    Let us know if any of this helps.
    11-04-08 04:43 PM
  6. kosmo33's Avatar
    I'm having this same problem with my new Curve 8330.

    Any e-mails I send from the device seem to be devoid of line breaks (carriage returns). If I use the Return key on the BB to start a new paragraph or line in an e-mail, when the recipient gets it (even when I get it BCC'd back to myself on my BB), those breaks are gone.

    What I find odd is this phenomenon also occurs with the signatures I've set up via the BIS web site. My entire sig, which should look like this:

    Name
    Company
    Phone #
    E-Mail Address

    ...instead shows up like this:

    NameCompanyPhone #E-Mail Address

    Aside from this looking terribly unprofessional, it makes a lot of messages a pain for my recipients to read, and this is occurring regardless of browser/email client type (Outlook, Entourage, Gmail, etc.). So I'm guessing it's my BB setup.

    Any tips on how to fix this?
    I am having the same issue and it is killing me! I just sent a rather harshly worded legal email to someone and it seems as though it went out without any line breaks at all! Anyone have a solution?
    01-19-09 05:05 PM
  7. villager#CB's Avatar
    Yeah i have this problem too.

    This is a question on a lot of other forums it seems no one has an answer.

    I have had blackberrys for the last three years just swapped to a bold and never had this issue before.

    It just happens when i reply to emails, so sort of composing a new email every time i dont know what to do!! Please help

    Otherwise you would be reading this:

    Yeah i have this problem too.This is a question on a lot of other forums it seems no one has an answer.I have had blackberrys for the last three years just swapped to a bold and never had this issue before. It just happens when i reply to emails, so sort of composing a new email every time i dont know what to do!! Please help
    01-26-09 02:29 PM
  8. DPegger's Avatar
    ... at least for my signature:

    The answer was to add an extra line feed at the end of each line using the 'return' (down/left arrow) key.

    After I saved the signature with the extra line feed, I actually received an extra line feed (double spacing) for each line of the signature.

    Deleting the extra line feed finally accomplished the goal of a multiline signature:
    Name
    Company
    Address
    Phone
    01-29-09 09:04 PM
  9. BLP_BB's Avatar
    I have this same problem on my Verizon Tour 9630. Has anyone solved this problem without installing third party software?
    10-29-09 09:34 AM
  10. BLP_BB's Avatar
    Hey,

    This missing line break problem doesn't crop up often for me because I don't usually send emails from my BB. However, today I did and again the line breaks were all missing when i replied to an email. Boo.

    Well, I tried the Gmail for BB app and it seems to preserve the line breaks. It's hard to believe that RIM can't make an email client that can handle this problem - but it's true
    02-09-10 02:21 PM
  11. jeffh's Avatar
    The vast majority of BlackBerry users don't have this problem. That doesn't help you any, but it's the reason RIM isn't fixing it. It's not clear where the problem lies.
    02-09-10 02:29 PM
  12. DenverRalphy's Avatar
    Well, I tried the Gmail for BB app and it seems to preserve the line breaks. It's hard to believe that RIM can't make an email client that can handle this problem - but it's true
    Has nothing to do with RIM, nor really the BlackBerry.

    This thread (albeit it's a bit old now) is mistakenly referring to a line break problem, when in actuality it's an issue with Word Wrapping long lines of text. Which is a function of the client reading the mail and not the sending client. This usually happens when one line of text is one continuous array that wasn't intended to be broken up (the culprit is most often a really long URL somewhere in the body of the email, or an image in the body with a rather wide dimension) and forces the width of the reading area to expand off the edge of the application. As a result, any other paragraphs will appear to string out into long lines as well, when actually it is because the rather wide reading area hasn't triggered a wordwrap.

    [edit]There needs to be whitespace (usually a space or a tab) for the wordwrap to trigger at the margins. If the client isn't recognizing any whitespace to wrap back to, then the client you're using to read the mail needs to be looked at. If it is indeed a long URL (and yeah they can get really really long these days), then consider a URL shortener like bit.ly or goo.gl. But most email clients these days already know to wrap urls without any whitespace.
    Last edited by rmjones101; 02-09-10 at 03:32 PM.
    02-09-10 03:19 PM
  13. noaim's Avatar
    wow this is the first I have heard of this problem on blackberrys and on these forums we see a ton of problems im curious as to what is causing it
    02-09-10 03:20 PM
  14. Radius's Avatar
    Enable word wrapping in your email viewer. It's like that Notepad app in Windows, if it's not enabled then long lines go off the screen.
    02-09-10 03:30 PM
  15. jeffh's Avatar
    I think you guys are missing the problem. It's not that line wrap or word wrap isn't working. The problem is line breaks being taken out, so that what should be 4 lines is one long line run together.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-09-10 03:38 PM
  16. DenverRalphy's Avatar
    I think you guys are missing the problem. It's not that line wrap or word wrap isn't working. The problem is line breaks being taken out, so that what should be 4 lines is one long line run together.
    Oh I dunno... here's an excerpt from the original post....

    Out of curiosity, I pulled up the whole exchange on my PC and saw why I was giving her fits. Each paragraph was coming across as one single, very long line. She had to keep scrolling right and left to read my messages.
    The Line-Breaks were indeed recognized as each paragraph was on it's own line.
    02-09-10 03:43 PM
  17. jeffh's Avatar
    Good point. I was looking at this subsequent post:

    My entire sig, which should look like this:

    Name
    Company
    Phone #
    E-Mail Address

    ...instead shows up like this:

    NameCompanyPhone #E-Mail Address

    Aside from this looking terribly unprofessional, it makes a lot of messages a pain for my recipients to read, and this is
    Posted from my CrackBerry at wapforums.crackberry.com
    02-09-10 03:49 PM
  18. DebraG's Avatar
    Argh! Has anyone solved the missing line break in the signature problem? My professional signature looks fine when it's sent to another BB, but runs as a long single line when sent to a PC. I originally set it up on the BIS page.
    02-19-10 06:01 PM
  19. BLP_BB's Avatar
    Hi Everyone,

    Jeff is exactly right, the problem is that intended line breaks (when the return key is typed on the Blackberry) are cut out of the message or ignored by the receiving client.

    A quick experiment:
    This is what I sent from my Blackberry in reply to an existing email (with the recipient changed to my address):
    "Testing line breaks
    Testing lines

    Test


    Test"

    Then my email client, Microsoft Entourage 2008 for Mac, received:
    "Testing line breaksTesting linesTestTest"

    but when I logged into my Gmail account via web browser, the message read:
    "Testing line breaks
    Testing lines

    Test


    Test"

    ---

    So I guess it's an incompatibility between Blackberry and Microsoft Entourage 2004 or 2008 for Mac. The good news is that my email recipients may not even see the problem, though I do when the sent message is delivered to my computer email client.

    Of course, many people use Microsoft Entourage for Mac, so it's still a problem... I'm just not sure whose it is.


    Cheers and good luck,
    Brian



    PS. I think this thread covers two separate problems. The original post by kyriefurro does discuss the paragraph line wrap problem, whereas the posts by Sylin and myself discuss a line break character recognition problem.
    Last edited by BLP_BB; 04-19-10 at 11:11 AM.
    04-19-10 10:47 AM
  20. SoxFan's Avatar
    I have this same problem. What should be an email signature of 5 short lines ends up being a run-on signature when sent from my Blackberry.
    03-31-12 08:37 AM
  21. SoxFan's Avatar
    Actually, to be more specific, it only happens with some of the lines:

    Name (this works fine and breaks here)
    Partner, Our Team * Experts Specializing in Blah Blah Blah at Bill Smythe and Company (this is a run on signature and should actually be broken into 3 sep lines)
    xxx.xxx.xxxx (cell) (this works fine and breaks here)
    abcdefghijklmnop.com (this works fine and breaks here)

    It should look like this (as it does when an email is sent from my Outlook account, just not from my Blackberry):

    Name
    Partner, Our Team * Experts Specializing in Blah Blah Blah
    Bill Smythe and Company
    xxx.xxx.xxxx (cell)
    abcdefghijklmnop.com
    03-31-12 08:43 AM
LINK TO POST COPIED TO CLIPBOARD