1. aqoona's Avatar

    I've installed the new leaked OS for my Bold 9000 and it works great!

    But I've encountered some network problems with all google applications including: Google Maps, Google Mail, Google App.. etc.

    Ex. When I run Google Maps 3.2 it tries to establish a connection then the following message shown: "Network Unavailable:This application requires a data connection, and some BlackBerry devices require reconfiguaration to workd properly. Please visit google.com/gmm on your computer for more info."

    I tried to edit the permission for the program and set all connection options to "Allow" but that doesn't work for me. Although, I don't face any connections problems with any other applications I run except for Google.

    Please HELP ME
    10-24-09 09:17 AM
  2. janaincberry's Avatar
    exactly the same problem on a curve 8900 here
    it worked fine before but now, none of the google apps are working - mobile app, mail app and gmaps !!!
    says the same error but im able to browe and use other data driven apps like facebook 1.7, twitterberry etc.,
    10-24-09 10:25 AM
  3. DataCentre's Avatar
    Did you try a battery pull?
    10-24-09 11:31 AM
  4. In4am0sPuN's Avatar
    Mine works fine :-).. everything actually works fine
    10-24-09 11:41 AM
  5. electro_sound's Avatar
    mine 3.2 stopped to work since now, and with the same error message: "Network Unavailable:This application requires a data connection, and some BlackBerry devices require reconfiguaration to workd properly. Please visit google.com/gmm on your computer for more info.".

    it worked like a charm since yesterday, so i guees it could be a temporary problem of google??

    10-25-09 06:07 AM
  6. v_prabu's Avatar
    I have installed .314 last Saturday. None of the Google Apps work now. Maps, Sync, Mail fail. Maps throws a differet error:

    Network error. Your enterprise Blackberry server does not allow connections to the Google Maps service. See the Google Maps FAQ for more information: Maps - Mobile Help

    I checked with my company's IT folks and they said it is working on other corporate mobiles without any issues and they do not enforce any corporate policy for this. Only enforcement that they do is the password policy.

    Thankfully, Yahoo, GTalk, MSN seem to work fine.

    MobiHand Appstore is not working.
    uberTwitter says, "Twitter service is overloaded"
    MobiReader says: Network error.

    I am able to browse through fine.

    Does this have something to do with my BB configuration? Do these app work through MDS connection?

    I tried battery pull, sim pull, host routing table->Register Now and all that.

    I give up :-)
    11-03-09 12:37 AM
  7. lamonster's Avatar
    Okay, I got this same error people are mentioning above. The circumstances were that I had an unlocked T-Mobile Blackberry 8900 from the US, and now using it in Austria with a prepaid SIM card through Orange. Even though I was paying for a data plan with the new SIM card, it would not let me use any Google Applications (Maps, GMail, etc.).
    Finally, I realized it has to do with the Mobile Network settings, specifically, the APN.
    Now, every network and phone is different, so I can't tell you exactly what your settings should be, but do some googling for "APN settings" for your phone and your carrier where ever you are in the world, then match them with the settings currently in your phone. Or call your provider and ask them to check the APN settings for you.
    As soon as I entered the proper APN settings, which I found by googling "APN settings blackberry austria" and finding the result at pinstack-dot-com, everything worked immediately. Now I have Google Maps with GPS fully working here in Vienna and I can get around using public transportation SO much easier. Plus it's pre-paid for 10 EUR per month for 1GB of data usage, so I'm waiting to see how much use I can get for that much data.
    I'm feeling super smart for getting this figured out. What a pain in the a$$
    11-10-09 04:22 AM
  8. electro_sound's Avatar
    so google maps is not using APN blackberry anymore?

    11-10-09 05:56 AM
  9. jesperws's Avatar
    I had the same problem om my 8900. It seems I fixed it through switching from Internet Browser to Blackberry Browser and logging in with company credentials when prompted. Afterwards, switching to Google Maps was not a problem?!
    11-23-09 06:23 AM