1. defcon3's Avatar
    Hello to the awesome community!

    Whenever I set my MANAGE CONNECTIONS > MOBILE NETWORK CONNECTIONS > DATA SERVICES to OFF, I get *zero* data transfer, even when I am in WiFi coverage. My data plan charges 4 euro per MB and I wish (for the time being) to use WiFi for data transfer exclusively. I have WiFi at home, at the office, on the train, so paying for BIS is not on the menu for me yet.

    Even when I set my Browser to HOTSPOT, I get nothing when DATA SERVICES is switched to OFF. When I have it to ON, I get traffic over GPRS despite WiFi access.

    What I would like to achieve is:
    * data is transferred exclusively over WiFi
    * Google Apps (gmail, gmaps) use the WiFi instead of GPRS for updating/acquiring data

    How can this be done?

    Much obliged
    03-25-09 04:31 AM
  2. weirdkid#CB's Avatar
    Manage Connection>Mobile Network Options> Change Data Services to ON and connection preference: Wi-Fi Preferred.
    That's what I have set and I only use Wi-Fi, don't have a data plan either.
    03-25-09 04:54 AM
  3. dslrjunky's Avatar
    i guess op's concern is about the data services being defaulted to "ON"

    and for that I have no answer...
    03-25-09 05:13 AM
  4. Pete6's Avatar
    Try also setting your browser to Hotspot Browser in Options, Browser Configuration.

    This works for me. I can turn off the entire Mobile Network in Manage Connections and still browse just fine.
    03-25-09 05:14 AM
  5. defcon3's Avatar
    Thank you for the quick posts. Indeed, I wish to have DATA SERVICES set to OFF WHEN ROAMING and routed through WiFi but... in my menus I *do not* have an option to select a preferred channel.

    I am running the .168 from this forum but (perhaps my provider) has blocked the ability to select this.

    Is there any way to "unlock" the menu "Connection Preference" to appear in my options? This I assume is the key to all my troubles

    EDIT:
    Try also setting your browser to Hotspot Browser in Options, Browser Configuration.

    This works for me. I can turn off the entire Mobile Network in Manage Connections and still browse just fine.
    I just did that but I get an error UNABLE TO CONNECT TO THE INTERNET, PLEASE TRY AGAIN LATER. IF THE PROBLEM PERSISTS PLEASE CONTACT YOUR SERVICE PROVIDER
    Last edited by defcon3; 03-25-09 at 05:22 AM.
    03-25-09 05:19 AM
  6. Pete6's Avatar
    Thank you for the quick posts. Indeed, I wish to have DATA SERVICES set to OFF WHEN ROAMING and routed through WiFi but... in my menus I *do not* have an option to select a preferred channel.

    I am running the .168 from this forum but (perhaps my provider) has blocked the ability to select this.

    Is there any way to "unlock" the menu "Connection Preference" to appear in my options? This I assume is the key to all my troubles

    EDIT:


    I just did that but I get an error UNABLE TO CONNECT TO THE INTERNET, PLEASE TRY AGAIN LATER. IF THE PROBLEM PERSISTS PLEASE CONTACT YOUR SERVICE PROVIDER
    Provided that you are correctly connected to your WiFi (it will say so on-screen and in Manage Connections) then, this should work.

    Check with Orange to see if your data plan allows this access. Orange can disable WiFi browsing via the plan. It may be that extra payment is required to Orange before you can do this.

    Many carriers are enforcing this just to get a bit more cash out of you.
    03-25-09 05:26 AM
  7. defcon3's Avatar
    With GSM network turned OFF and Data Services set to ON, the Browser works but Google Apps does not. Attempting to check my gmail through the BB Browser launches Google Apps and then I end up in a dead end with

    THE PROGRAM REQUIRES A WORKING DATA CONNECTION. PLEASE CHECK YOUR SIGNAL STRENGTH.

    All other websites open just fine. Should I remove Google Mail and Google Apps, and leave *only* Google Maps? Would that do the trick?
    03-25-09 05:55 AM
  8. RLP06's Avatar
    Google apps don't work on wifi, only on mlobile network

    Posted from my CrackBerry at wapforums.crackberry.com
    03-25-09 10:09 AM
  9. providence4ver's Avatar
    hi guys
    Just got my blackberry last sunday...
    My wifi doesnt work when i have data service off.. is this normal?
    Cant even use the browser
    11-26-09 09:11 AM
  10. _MissV_'s Avatar
    Bump...not sure if its a problem if I use this old thread, instead of making a new one.

    But I am have these same issues. I have WiFi fully connected, but the data is still being using via the data plan (AT&T keeps advertising unlimited data over WiFi)

    I tried turning the "Data Services" to off, WiFi still there and fully connected, but unable to access the internet or anything.

    I searched the forum and haven't found anything to fix it or make it make sense. Only thing I can think of is AT&T lies about this.

    And my phone doesn't have some of these options listed in these suggestions. I have the Torch 9810, if that would be of any help.
    12-30-11 08:56 PM
  11. Klotar's Avatar
    Data Services Off means, well, just that. What you want is Data Services On and Mobile Network Off. Or Mobile Network to Wi-Fi Preferred, depending on your OS.
    01-03-12 01:56 PM
LINK TO POST COPIED TO CLIPBOARD