09-01-11 07:57 PM
29 12
tools
  1. BigBadWulf's Avatar
    Edit - Kudos to fookoz for making this solution:
    http://forums.crackberry.com/f35/autotextbackup-616452/
    I also attached a zip of the OTA, found at the bottom of this post.


    I entered into a dialog with RIM, so excited and hopeful for a solution to the custom auto text issue with OS6. Regrettably I must bring you the worst of news.

    As many of you have experience, either upgrading a current BlackBerry to OS6, or upgrading to an OS6 only model, any custom auto text will not transport beyond the initial upgrade/device switch. Any subsequent upgrade results in a failure, and the last good backup from OS5 must be used to selectively restore auto text. This has left us with no reasonable means of editing for the future. The only successful solution, has been to use a BlackBerry with <OS6 on it, make the changes desired, back that up, and pray it will be restoreable. With the latest DM release, no older backup was useful at all, so instead of fixing the problem, RIM only made it worse.

    I began my communication with RIM on April 18th. They seemed sincerely interested in resolving the matter, and had me provide them my databases for their technical team to evaluate. I was perplexed they didn't appear to know the problem existed, but as I said, was excited to have a role in the solution.

    Well, the days past, and about a week ago, a friend upgraded his OS on his 9670 OTA, as always. He informed me he lost auto text. I had forgotten he rebuilt his auto text database from scratch at the time, but sent his information along to RIM. I received no responses to email inquiries of the case progress, until today, when I received the following email:

    Hello Ed,

    Thank you for contacting BlackBerry Technical Support. It has been a pleasure to work on this issue with you.

    Thanks again for taking the time and effort to assist us with investigating the matter. Your logs were submitted for review, the following was determined based on that investigation,

    "The database structure has changed which is why some clients are not able to restore this. Unfortunately these clients will have to re-enter the Auto-Text's manually on the device, and going forward making new backups will work without issue. In summary, this behavior is by design, based on new table formatting for auto text in BlackBerry 6."

    At the moment this is the work around we're providing our client's in relation to this issue.

    We will be closing this incident at this time.

    Thanks again for contacting BlackBerry Technical Support. Have a great day, Ed.

    Sincerely,

    Xxxx
    BlackBerry Customer Support
    Research In Motion Limited
    Now, #1 the first italicized portion (I did that) is untrue, and my friend will detail that in a follow-up post. #2, the portion in red clearly states they intentionally did this, and so had to have been aware. This is a database, that for me I've used since OS4.2, and ported with zero issues till OS6. Furthermore, the fact that my OS5 backup functions just fine once restored on OS6, leads me to believe the structure is inherently similar. Now they have produced two knowledge base articles, to inform their customers of the solution:

    KB25606-Auto Text entries added to the Auto Text database in BlackBerry 6 are removed after returning to BlackBerry Device Software 5.0

    This one I won't even bother covering, it's so useless and irrelevant.

    KB25616-Auto text entries are lost when the BlackBerry smartphone is wirelessly upgraded to BlackBerry 6

    Auto text entries are lost when the BlackBerry smartphone is wirelessly upgraded to BlackBerry 6
    No, really?!? It's lost no matter how the heck you do it RIM, and you know it!

    This is a previously reported issue that has been escalated internally to our development team. No resolution time frame is currently available.
    You told me case closed, even when I spent an hour imploring you to continue to attempt a resolution.

    To workaround this issue, perform one of the following:

    Re-enter the missing auto text entries when the wireless update is complete.
    Back up the auto text enxtries prior to performing a wireless update of the BlackBerry smartphone, and then restore them after the update is completed. For information on restoring data to the BlackBerry smartphone, see KB10339.
    Even if this worked, which it doesn't, that's no solution for a customer on the road 24/7 now is it?

    Note: this issue does not occur for BlackBerry smartphones that are upgraded using the BlackBerry Desktop Software or Web Software Loading.
    The *place where Satan convinced RIM to rename and bungle autotext* it doesn't!

    So I asked them, just what confidence does this bring, to their customers, that OS6.1 and OS7 will not "restructure" other databases, such as addressbook, custom dictionary or browser bookmarks, making them obsolete in the future. They have no answer as of yet, and while I still love the product, it gives me great pause whether to continue with them on my next upgrade. I was looking forward to the next gen of BlackBerry, especially the Bold Touch. Now, I sincerely doubt I will get one, until such time as this issue has been resolved properly.

    My CrackBerry brethren, I'm still a fan of the product, and have a deep love for CrackBerry.com, but I'm no fan of RIM right now, that's for sure. I've always kidded, that they make the best business smartphone out there, and have no clue how to conduct business. They've certainly proved me right in spades today.


    Edit - If you can't access any of your previous backups, due to the DM version on your PC, use any of the following links to download DM version 6.0.1.18 (bundle 21). Be sure to uninstall the current version first, but leave your settings intact. It will empty all currently installed OS on your PC, so keep that in mind.

    BlackBerry Desktop Software 6.0.1.18.exe - 4shared.com - online file sharing and storage - download

    Deposit Files

    https://rapidshare.com/#!download|58...D38AEEBCD458C0

    zSHARE - BlackBerry Desktop Software 6.0.1.18_Wolf.exe - Free File Hosting Service | Audio and Video Sharing | Image Uploading | Web storage

    MEGAUPLOAD - The leading online storage and file delivery service

    All links courtesy the one and only Mr. Wizard, aka willyboy6
    05-02-11 08:07 PM
  2. Elite1's Avatar
    As I told you earlier offline, thanks a bunch for putting the time into finding a solution. Fortunately we don't all have the issue, but for those of us that do, it is insanely frustrating.

    To anyone considering a reply, please don't bother posting "well, it doesn't happen to me!" We know it doesn't happen to everyone, or hasn't yet anyway.

    I only started having the issue on my last 3 OS upgrades. None before that. Other, right from the get-go.
    BigBadWulf likes this.
    05-02-11 08:22 PM
  3. jeffh's Avatar
    Thanks for all your research, Ed. I had heard Autotext was broken in OS6; that's one reason I haven't upgraded. But I had also been told that it worked just fine. Your findings explain that inconsistency. I suspect I'll stay with OS 5 until I'm refreshed to a BlackBerry that doesn't have it.
    05-02-11 09:41 PM
  4. Elite1's Avatar
    Thanks for all your research, Ed. I had heard Autotext was broken in OS6; that's one reason I haven't upgraded. But I had also been told that it worked just fine. Your findings explain that inconsistency. I suspect I'll stay with OS 5 until I'm refreshed to a BlackBerry that doesn't have it.
    Hi Jeff, just wanted to clarify a few things. Sorry in advance for wasting your time if you already knew, but others might gain still.

    As per RIM's reply, and as I had already discovered, the database is renamed from Auto Text to Word Substitution. (Because that's catchier )
    But it's not only renamed, it's also re-organized despite appearing the same to the user. I believe this is the real problem.

    If I check a previous DM Backup, my Auto Text is listed as how many custom Auto Text entries I had made, in my case 235.
    In new Backups, it shows no Auto Text entries and shows you have anywhere from 3 to 5 databases under the new item, Word Substitution. In my case it's 5, and OS upgrades and Restores show an error with 4/5 databases restored.

    As I mentioned in my last post, this didn't start right away. I've had 7 OS's on my Torch, which means 1 initial Restore and 6 upgrades. The first few were fine, then the last 3 gave me the error.
    Through a process of trial & error, I've discovered that I can restore the Auto Text from a Jan 30th Backup, which will replace the Word Sub.
    Better than nothing, but I lose all new entries & edits since then. For me that happens to include all my custom Auto Text for vBulletin BB code tags. Cumbersome to re-enter.

    I didn't restore this time, having decided to break the cycle and re-enter everything into my shiny new Word Sub "databases." So we'll see what happens the next time a new OS is available.
    jeffh and diegonei like this.
    05-03-11 06:54 AM
  5. moiselles's Avatar
    Thanks for all your research, Ed. I had heard Autotext was broken in OS6; that's one reason I haven't upgraded. But I had also been told that it worked just fine. Your findings explain that inconsistency. I suspect I'll stay with OS 5 until I'm refreshed to a BlackBerry that doesn't have it.
    Auto Text is called Word Substitution on OS6 and it works just fine.
    05-03-11 07:08 AM
  6. jeffh's Avatar
    ...I didn't restore this time, having decided to break the cycle and re-enter everything into my shiny new Word Sub "databases." So we'll see what happens the next time a new OS is available.
    Thanks for the work you put into this, elite1. I look forward to seeing your results from the next OS update. If recreating the custom entries once in the new OS solves the problem for the future, that won't be too bad.
    05-03-11 08:48 AM
  7. roninksb's Avatar
    I have a Torch. I just upgraded my phone to the most recent AT&T official release. My 1153 entry autotext db is gone and I can not restore from my most recent backup as it says the db is now "read only" and can not be restored. If I can not restore this db I am going to be pissed! I am already pissed that I have had to waste an extraordinary amount of time trying to resolve this issue.

    I have read all of the above, why no warning? Why no way of transferring the data to the new db structure. This is unbelievable. I don't even have away of retrieving the entries from the db so that I can begin the long, difficult task of re-entering.

    Words can not describe how upset I am about this.
    05-03-11 10:37 AM
  8. Elite1's Avatar
    Auto Text is called Word Substitution on OS6 and it works just fine.
    Hi stranger,
    Word Substitution does work fine in OS6. The issue is that some people after changing OS are losing all of the custom auto text entries they had previously created and added to the stock list.
    05-03-11 06:00 PM
  9. Elite1's Avatar
    Thanks for the work you put into this, elite1. I look forward to seeing your results from the next OS update. If recreating the custom entries once in the new OS solves the problem for the future, that won't be too bad.
    Did you make this happen?
    Vodafone DE released the never-leaked 6.0.0.546 for the Torch, just earlier today. Many thanks!

    Seriously, it was great timing though! Fortunately this new OS build appeared very quickly. I haven't even re-entered the majority of my custom entries, but all I need is the few I have done to test this out. If it fails, at least I won't have wasted too much (more) time.
    05-03-11 06:07 PM
  10. BergerKing's Avatar
    In my case, I rebuilt 400 of my original 620 after they disappeared into the ether from my Device Switch in .248 to upgrading .407. So, all of my re-adding should've been solid in OS 6.

    Upgraded to 9670/6.0.0.522 immediately after I posted the thread that had indicated that the update had come available.

    Nor Word Sub database any more. That was like being force-fed a crap and Spam sandwich with beach sand. You can't decide which tastes worse and it's rough going down.

    So now I'm preparing a page on my memopad, and alphabetically adding my list to the memo pad, so some copy and pasting action can rebuild my library quickly.

    Frustrating? You bet your PlayBook it is! All the vB code and custom links, the phrases and words I use that aren't standard, the automatic corrections of the words I mis-type the most often.

    But here's an oddity. I replaced some of the stock Word Sub codes, like mth for month instead of mo. Or ilp for I'll instead of il. Those stayed in place. The stock codes would drive me a little nuts because I live in Mo and travel thru Il a lot.

    I just want them to either leave it the way it was or fix it. Because I do have options. There was really no good reason to restructure that which worked just to be 'trendy'.

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by BergerKing; 05-03-11 at 06:37 PM.
    05-03-11 06:35 PM
  11. BigBadWulf's Avatar
    I have a Torch. I just upgraded my phone to the most recent AT&T official release. My 1153 entry autotext db is gone and I can not restore from my most recent backup as it says the db is now "read only" and can not be restored. If I can not restore this db I am going to be pissed! I am already pissed that I have had to waste an extraordinary amount of time trying to resolve this issue.

    I have read all of the above, why no warning? Why no way of transferring the data to the new db structure. This is unbelievable. I don't even have away of retrieving the entries from the db so that I can begin the long, difficult task of re-entering.

    Words can not describe how upset I am about this.
    You probably have the latest DM, as I mentioned in my original post. That will cause all previous backups to be read only, but going back to DM v6.0.1.18 (bundle 21) or before should work for you.

    In my case, I rebuilt 400 of my original 620 after they disappeared into the ether from my Device Switch in .248 to upgrading .407. So, all of my re-adding should've been solid in OS 6.

    Upgraded to 9670/6.0.0.522 immediately after I posted the thread that had indicated that the update had come available.

    Nor Word Sub database any more. That was like being force-fed a crap and Spam sandwich with beach sand. You can't decide which tastes worse and it's rough going down.

    So now I'm preparing a page on my memopad, and alphabetically adding my list to the memo pad, so some copy and pasting action can rebuild my library quickly.

    Frustrating? You bet your PlayBook it is! All the vB code and custom links, the phrases and words I use that aren't standard, the automatic corrections of the words I mis-type the most often.

    But here's an oddity. I replaced some of the stock Word Sub codes, like mth for month instead of mo. Or ilp for I'll instead of il. Those stayed in place. The stock codes would drive me a little nuts because I live in Mo and travel thru Il a lot.

    I just want them to either leave it the way it was or fix it. Because I do have options. There was really no good reason to restructure that which worked just to be 'trendy'.

    Posted from my CrackBerry at wapforums.crackberry.com
    This entire thing makes no sense bro. How some of yours could restore, but the rest not is astounding. I'm going to take the bait, and try again. I plan on doing just as you, and copy/pasting it all into memopad first.

    The damned of it is, what I called about, and most people have issue with was not addressed. I'll crerate my own instructions I guess. For my next test, I'll do a backup, wipe my entire database, and do a full restore. Then I'll add a few custom entries, and see if they backup. I'm not going crazy with rebuilding it, till I see some succss, and if I do succeed, I'll make backups and check as I go. Should be a fun filled weekend I have planned.

    Noah, what I have seen since OSicks, is 3 databases for Word Substitute, not the 7 you've been seeing.

    On a side note, did you notice when they released BBM5 to the public, they upgraded it from the last beta, but didn't inform the beta users as usual?*smh*
    05-03-11 08:53 PM
  12. roninksb's Avatar
    You probably have the latest DM, as I mentioned in my original post. That will cause all previous backups to be read only, but going back to DM v6.0.1.18 (bundle 21) or before should work for you.
    That is an excellent idea. Any suggests on where I might download the install file?
    05-03-11 10:24 PM
  13. BigBadWulf's Avatar
    That is an excellent idea. Any suggests on where I might download the install file?
    I'll have it uploaded to my dropbox in a few minutes, and edit my first post.
    roninksb likes this.
    05-03-11 10:38 PM
  14. roninksb's Avatar
    I'll have it uploaded to my dropbox in a few minutes, and edit my first post.
    Thank you, sir.
    05-03-11 11:38 PM
  15. BigBadWulf's Avatar
    Correct DM version to reload the old backup now in the first post, here .
    05-04-11 08:10 AM
  16. BigBadWulf's Avatar
    Auto text experiment progress update.

    Tried deleting just the auto text and Word substitute databases, and my custom were still there. Then tried a full database wipe/restore. Received the same message I do with every OS upgrade. 2/3 word substitute didn't restore, only my custom entries are still installed. Looks like the only way to remove them, in order to rebuild as RIM suggested, is an OS upgrade/downgrade. So far, I've logged at least 8 hours, transferring my customs to a Word doc. Lost my 3 groups in the wipe. I'm sure that's by design too.
    05-08-11 11:10 AM
  17. BigBadWulf's Avatar
    Grrrrrrrrrrrrr!


    Bloody crap load of work, and an entire weekend down the drain. Thank you RIM
    05-16-11 07:02 AM
  18. failure's Avatar
    I lost all of my old OS5 entries and while I was upset at the time, I took the time to slowly re-add all my custom entries and now I'm near where I used to be as far as happiness with my setup.

    The problem is, I still can't back up my "shiny new" database!! Everytime I try to backup my entire BlackBerry, the software gives me an error at the end that says "Word Substitution 0/3" not backed up.

    Today I was excited, as I downloaded and tried a NEW version of Desktop that supports the PlayBook. I thought SURELY this error has been fixed, but no it has not. I'm really upset at the thought of having to re-enter ALL of my entries YET AGAIN, let alone every time I update in the future! Or what happens when I switch phones to the Bold Touch in a few months?

    Ridiculous.
    Last edited by failure; 05-17-11 at 01:03 PM. Reason: subscribing to this thread for future knowledge of a possible fix
    05-17-11 01:01 PM
  19. roninksb's Avatar
    Someone has written an application that allows you to backup your AutoText db on device. I download it today from a different site where the developer left an OTA link and it works like a charm. I did a delete and restore and everything seemed to work great. Hopefully this means I can update the db without fear of losing all the new stuff from the last good backup on my desktop. The developer posted in these forums at this link. http://forums.crackberry.com/f35/autotextbackup-616452/
    BigBadWulf likes this.
    05-19-11 10:22 AM
  20. fookoz's Avatar
    Someone has written an application that allows you to backup your AutoText db on device. I download it today from a different site where the developer left an OTA link and it works like a charm. I did a delete and restore and everything seemed to work great. Hopefully this means I can update the db without fear of losing all the new stuff from the last good backup on my desktop. The developer posted in these forums at this link. http://forums.crackberry.com/f35/autotextbackup-616452/
    thanks for the link

    i write the app because its been so long that RIM hasnt fix the issue on autotext
    already test it on local forum on my place.
    works perfectly
    but i need more2 people to test it
    if people here interested in the app could go to the link that RoninKSB post

    the ota link has been post on page 1 for someone to try it

    remember to leave a review for it
    05-19-11 01:16 PM
  21. BergerKing's Avatar
    BigBadWulf has tested this, as I have, and rest assured, I'm doing a Snoopy dance.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-19-11 09:55 PM
  22. xmen81's Avatar
    Yes, I am also facing this issue. Downloading the app now, thanks a lot for your efforts.
    05-20-11 10:40 AM
  23. mayor's Avatar
    I HATE YOU RIM !!!.... how on earth can you do this to people …. the auto text is one of the FEW REMAINING reasons that i am still with you !..... take a close look at your competitors! ESPECIALLY SAMSUNG with its GALAXY ...i am absolutely LIVID at the moment !! you XXX XXXXX. you waste my whole bloody day !.... i have THANKFULLY gone back to DM bundle 21 (link above) and managed to get some OLD auto texts back ….i am still way behind on NEW ones which have been LOST! …

    I am so frustrated and can not believe that a billion dollar company can not even get a simple data transfer issue resolved ! SXXXX you !

    Sorry everyone, ...i am hopping mad !

    I am going to use the Autotext back up tool and hope to god it works as described by all.
    05-21-11 03:42 PM
  24. BigBadWulf's Avatar
    I hear ya mayor. I think you'll find like I did, that the app works perfectly, even after an upgrade.
    05-23-11 08:17 AM
  25. mayor's Avatar
    Guys

    i am a little confused as i dont understand HOW to re-install from my backup, once i have wiped my handset OR changed to another blackberry .. can we save the backup onto the memory card???

    I have noticed that he word subsititution count does not go up ! and remains the same, even thoughi have manually added more entries...god help !!! i have wasted soooo much time on this !....

    regards

    mayor

    ps i am STILL HOPPING MADDDDDDD !!!!!!!!!!
    05-23-11 01:36 PM
29 12
LINK TO POST COPIED TO CLIPBOARD