1. mjdato's Avatar
    This is the only thing that is slow on my BB Curve Verizon. I can compose, read everything fine. Media plays fine, everything. But when I go to send a SMS text, it sort of hangs. I sometimes will receive a reply before it appears that my phone has even sent the message, it just sits on the menu screen with Send highlighted.

    I have cleared out all available memory that I know to do, I deleted a lot of apps.

    Kind of lost, just started doing this about a month ago.

    Anyone ever have this problem?
    11-21-08 10:36 AM
  2. mjdato's Avatar
    No one has any help on this??
    11-23-08 10:59 AM
  3. benzworm's Avatar
    have you tried a battery pull?
    11-23-08 11:04 AM
  4. JORB's Avatar
    A fresh install of the os would more then likely do the trick if a soft reset won't work.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-23-08 11:18 AM
  5. mjdato's Avatar
    have you tried a battery pull?
    About 900 times, haha
    11-24-08 12:15 AM
  6. benzworm's Avatar
    i say you might need to reinstall your os...
    11-24-08 12:17 AM
  7. steven s.'s Avatar
    whats your free memory at?
    11-24-08 12:19 AM
  8. benzworm's Avatar
    whats your free memory at?

    the op said that there were numerous battery pulls, meaning it was at the highest level it could be...
    11-24-08 12:21 AM
  9. Duvi's Avatar
    How many sms messages do you have on your device?

    Go to messages then hit the menu key and select 'View Folder' and select "SMS Outbox" and clear that out.
    11-24-08 12:59 AM
  10. Soon2BeDraggin's Avatar
    How many sms messages do you have on your device?

    Go to messages then hit the menu key and select 'View Folder' and select "SMS Outbox" and clear that out.
    yeah i had to empty my SMS's out because i had so many in there
    11-24-08 01:25 AM
  11. benzworm's Avatar
    did that speed it up for you?
    11-24-08 01:28 AM
  12. kvaughan's Avatar
    I have the same problem. Only happens after having a long SMS conversation with that person. It goes away after you clear the SMS boxes and I don't have any other fix.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-24-08 05:50 AM
  13. luvitlo's Avatar
    Do you have confirm sent message selected this may be the problem...It could be waiting on confirmation that the message was received?
    11-24-08 07:08 AM
  14. mjdato's Avatar
    I reloaded my OS and its still doing it.

    After about 5-10 messages sent it slows down again. And does it for every message after that. I am literally getting responses to messages before the Send menu even goes away on my screen. It's definitely just my phone as everyone I texzt is on Verizon too.

    I'm sort of lost......
    12-02-08 12:08 PM
  15. mjdato's Avatar
    I reloaded my OS and its still doing it.

    After about 5-10 messages sent it slows down again. And does it for every message after that. I am literally getting responses to messages before the Send menu even goes away on my screen. It's definitely just my phone as everyone I texzt is on Verizon too.

    I'm sort of lost......
    Bump........
    12-03-08 12:17 AM
  16. dmoseder's Avatar
    I have a blackberry curve for sprint. I've had it for about 4 months now and it text alot on it. I have the same problem as you although mine only happens have i recieve and sent alot from the same person. If i delete all texts it will send fast again. If i have a bunch of texts from one person it takes a long time to send only to them, if someone new texts me i can reply and hit send and it doesn't hang at all

    I've done battery pull, i have 27mb free. I haven't tried reinstalling the os but yea. I like to keep alot of texts because i have the space for them, unfortunately i can't because the more i get from someone the longer it hangs on the send button.
    12-07-08 09:42 AM
  17. dhumann05's Avatar
    I have the same problem! Mine isnt always after a long conversation though, sometimes I could have gone hours without sending a single text and I'll get a text and it'll be slow! Sometimes 20 or 30 seconds to open, then reply, then send, and ugh! I have 21mb of memory free and the previous messages set to 5. Its frustrating and it also randomly starts working fast again. Once it started going fast again so I set the previous messages to the max (50) and it had maybe a second lag. But once it slows down again, God knows you dont want to have someone texting you! Its sooo tedious... and I cant figure out what's wrong.
    12-16-08 10:33 PM
  18. kvaughan's Avatar
    Mine isnt always after a long conversation though, sometimes I could have gone hours without sending a single text and I'll get a text and it'll be slow!
    We weren't talking about long in the sense that you may have been talking to one person alot over the period of an hour, rather the history of SMS with that person over a period of time still in your Berry.
    12-17-08 02:14 AM
  19. zarzamora_hermosa's Avatar
    I have had similar experiences and for me it has been the network in my location. I move around a lot, but at certain places I do notice that things take longer to send depending on my location. Sometimes I would notice a clock icon appear when sending a simple SMS to a friend, and a minute later SMSs sent fast. It sometimes took forever. It happens occasionally, but always in the same locations.
    Last edited by zarzamora_hermosa; 12-20-08 at 01:06 AM.
    12-20-08 01:04 AM
  20. ballroomdru's Avatar
    I have the same issue. I use about 3,500 SMS a month and i run into this a lot with my best friend. does RIM know about this?
    01-14-09 01:49 PM
  21. ballroomdru's Avatar
    Here is a new idea i got from another forum. I tried it with my GF and it works.

    "I recently had the same issue. I reloaded my device software and it did not help. I brainstormed and tried a few things. Here is what I found out:

    I deleted all picture messages I received from the individual who's SMS was lagging in my phone. This helped me for about 2 days.

    I then started a new SMS instead of replying to the SMS that was lagging. This has helped me ever since.

    I don't believe in both of our cases that memory has anything to do with the problem. Afterall, I have more memory now then I ever have after deleting all of those pic messages."

    The lesson, don't reply, compose new. That way it doesn't have to string together the thread for you.
    Edit/Delete Message
    01-14-09 03:28 PM
LINK TO POST COPIED TO CLIPBOARD