1. 8900freshy's Avatar
    Location:San Diego
    Device: Cuve 8900 - - T-Mobile (unlimited data)
    Router: NETGEAR RangeMax WPN824v3

    Problem: UMA/WiFi work fine when I do NOT enable any security on my router. The UMA icon appears and WiFi icon illuminates. All is right with the world. I also am able to connect to other unsecure signals when they are available. But, when I choose WPA-PSK [TKIP] as a security option (which I was told BB supports). The UMA icon disappears and the WiFi logo grays out. It still states 'T-Mobile - mynetwork' on the home page though. On the 'Wi-Fi' Connections page, the network I am trying to connect with is listed and there are two icons to the right of it, a black box with a white (horizontal) line through it, and a green triangle/teepee looking shape with 2 sets of green parentheses around it. Occasionally the green teepee becomes a smaller gray teepee with a red x next to it.

    I appreciate that T-Mobile and/or RIM have sufficiently provided me with no info regarding the meanings of these interesting graphics. If anyone has a guide or a key it would be appreciated.

    The connection is great. The password has been correct. I have tried almost everything obvious and imaginable and followed unlimited sets of instructions from existing posts. I have changed channels, powers cycled (everything), tested other devices, turned them off and on and off again. Changed security settings, etc...

    Error consist of W006.1 and W010.
    In diagnostic viwe I'll watch the Status: fo from 'Establishg UMA connection' to 'ISP or T-Mobile Network error.'

    At this point I am hoping that this is completely user error. That said, if it is, bring it on and point out the obvious.

    Thank you to all!
    04-03-09 06:05 PM
  2. dr_pepper's Avatar
    See if there is firmware update for your dlink

    Posted from my CrackBerry at wapforums.crackberry.com
    04-03-09 06:45 PM
  3. 8900freshy's Avatar
    Did this already. I have done all the obvious...
    04-03-09 06:52 PM
  4. dr_pepper's Avatar
    Have you tried on another wap enabled network? just trying to determine if it's your phone or your router. i'd think its the router
    04-03-09 07:42 PM
  5. 8900freshy's Avatar
    I have not yet. If it is the router, what would you think it is?
    04-03-09 07:59 PM
  6. 8900freshy's Avatar
    A miracle.

    I switched from security option WPA-PSK [TKIP] to security option WPA-PSK [TKIP] + WPA2-PSK [AES] and both my Curve 8900 and the gf's Curve 8320 are now on board and working great. If anyone knows what this turn of events means, there are many others that are stuggling with similar challenges.

    I did try this earlier without luck...there could be other elements at play here.

    Thank you.
    Last edited by 8900freshy; 04-03-09 at 08:13 PM.
    04-03-09 08:11 PM
  7. gm85's Avatar
    On the 'Wi-Fi' Connections page, the network I am trying to connect with is listed and there are two icons to the right of it, a black box with a white (horizontal) line through it, and a green triangle/teepee looking shape with 2 sets of green parentheses around it.
    The green triangle indicates that your wifi network is available and the black box (with the white line) indicates your BB is trying to connect to your wifi network and establish a connection to the internet. This white line will change to a green checkmark once it's connected successfully to the Wifi network.

    Under the Wifi diagnostics, does your phone indicate the Security-Type is Pre-Shared Key (PSK), have a checkbox beside association and authentication, as well as have an acquired IP address?

    If it does, what happens if you try to ping your netgear Router?
    (From Wi-Fi connections, press the blackberry key, goto Wi-Fi Tools > Ping, enter your router's IP address under "Ping To", press the Blackberry key and select "Send Ping").

    I noticed you said you've attempted to change passwords, channels, etc. This is a dumb question, but have you attempted to delete your network from the Saved Wi-Fi profiles list and try to set it up again with the password in place?

    Edit: Looks like you've figured it out!
    04-03-09 08:25 PM
  8. dabbill's Avatar
    The problem is you were using the wrong encryption on your phones to connect to the router. So basically your phones were speaking Spanish while your router was speaking English.
    04-03-09 09:08 PM
  9. 8900freshy's Avatar
    I've been on here forever but alwasy find my questioned answered by searching the great and many responses.

    I appreciate the consideration and help from everyone!

    Next step... apparently I should be embarrased to still have .114 OS...
    04-03-09 09:24 PM
  10. Firetester23's Avatar
    I hope this can help you out. I believe the firmware upgrade changed the channel from which it is being broadcasted. If its channel 11 change it back to channel 6 and see if that works. This has to be done to your router!! Good luck!!
    04-03-09 09:56 PM
  11. oldergeek's Avatar
    I regret that I have the exact same problem, but the suggested solutions have not worked. I too have an 8900. I too have a Netgear RangeMax WPN824v3. I too had no problems until recently. I too can end the problem if I turn off encryption. I get the same error codes. Correction on the account above - I am on T-Mobile.

    Suggestions would be appreciated.
    04-09-09 10:48 PM
  12. conker89's Avatar
    I'm sorry if this has been answered, but as much as I try and Im not getting any closer to resolving this UMA issue on my 8900 Curve.

    I have had UMA previously but think I lost it after upgrading the firmware on my WPN824 v2 Netgear Rangemax.

    It's more of a problem as my home has poor signal so UMA makes a big difference.

    I've tried battery pulls, deleting the WIFI connection on the berry and starting again, calling Netgear (no help as could find the serial number on the router), now I have changed the security method as per the post above and still I have no UMA.

    Someone please help!!!
    12-06-09 01:16 PM
  13. conker89's Avatar
    Further to my post yesterday I have since been sent a new phone after instructions over the phone from Orange "bricked" my phone.

    Unfortunately I still have no UMA!? What is going on?!?!
    12-07-09 02:20 PM
  14. fatboy97's Avatar
    Have you checked out the UMA guide in my signature below.
    12-07-09 02:47 PM
  15. msmcgoo's Avatar
    i have searched numerous blogs for an answer to this question. everyone has their own quick fix. i found mine - it was so simple i can see why it would not even be considered.

    when i first got the phone, everything was working great and when i would walk into my house the uma letters/acronym that makes me happy on the upper right hand of the screen would pop up. just like everyone else, it eventually stopped appearing and i was getting the terrible signal in my house that pissed me off beyond belief. i personally don't like running to the window to talk on the phone. here is what i found:

    I followed every instruction, EVERY POSSIBILITY, and then did one simple thing on my 8900 that made it all better.

    5. THAT'S IT.

    that was my fix. i did that after spending a few hours on everything else --- moving the network up to the top of the priority list is what made the difference. i hope this helps
    04-13-10 01:52 AM
  16. elllllllllle's Avatar
    wondering if anyone can help me with my wifi problem abroad!..

    ive turned my roaming off but i think im right in saying wifi is still accessible. i have been given a password and after typing it wrong a first time, it will no longer give me the option to type in the password.

    have tried battery pull, deleting and researching for the network - nothing!

    any help would be greatly appreciated!!
    09-05-11 05:14 PM