1. krnkjl9898's Avatar
    Hello, I am trouble connecting to my router via wifi feature. I tried all the options but nothing is connecting. Signal is there, but connection is not going through to BB. Any suggestions? I have a Belkin router... thanks!
    06-27-10 07:01 AM
  2. runnerboy967's Avatar
    Go into your router settings and make sure that the router is broadcasting the SSID. The SSID is the name of the network and if the router isn't broadcasting the SSID the Blackberry won't be able to automatically scan and find the WiFi network. You would have to enter everything in manually. Just a security feature on the router, but you want to make sure that's turned off. Also make sure the wireless is on and it is broadcasting a "G" signal. If you still having trouble use another device like an iPod or laptop and scan for the WiFi signal on that and see if it detects it.
    06-27-10 09:15 AM
  3. FF22's Avatar
    I had trouble because I use mac filtering. The mac "address" on the box is different than the phone's mac address (I think the box has the "BT" mac address). Found it in Status.
    06-27-10 09:42 AM
  4. mikeplus1's Avatar
    Go into your router settings and make sure that the router is broadcasting the SSID. The SSID is the name of the network and if the router isn't broadcasting the SSID the Blackberry won't be able to automatically scan and find the WiFi network. You would have to enter everything in manually. Just a security feature on the router, but you want to make sure that's turned off. Also make sure the wireless is on and it is broadcasting a "G" signal. If you still having trouble use another device like an iPod or laptop and scan for the WiFi signal on that and see if it detects it.
    I have my router set to "Invisible" or "Hidden" which means it does not broadcast the SSID and I have my Wireless Protection Access on and set to Auto(WPA/WPA2) and Pre-Shared Key required with my Network Lock "Enabled" for maximum security.
    My WiFi Profile on my BB is set as follows:
    Connection Mode: "Automatic";
    Automatically obtain IP address and DNS: "checked";
    Allow inter-access point handover: "unchecked";
    SSID broadcasted: "unchecked"

    Wireless Mobile Network does not have to be turned on, nor even broadcasting a G or 3G signal in order for my WiFi to connect and surf the web, etc on my home or work network routers. It can be turned off, but you will not be able to receive calls of course if it is. I always leave my Mobile Network turned on and set to "Automatic" selection mode and Network Technology set to "1XEV" when not traveling outside USA.

    These settings are left this way all the time and I do not have to enter anything manually after my WiFi Profiles are set with the SSID Name, Band (802.11b/g), Security Type (Pre-Shared Key PSK) and my PSK Key (26 letters/numbers) have been entered and saved. My phone automatically finds and connects to each network based upon my location when I am within range of them. I have my Browser set to "Internet Browser" and not to "Hotspot Browser" for connecting to these wireless networks.
    06-27-10 12:49 PM
  5. FF22's Avatar
    I have my router set to "Invisible" or "Hidden" which means it does not broadcast the SSID and I have my Wireless Protection Access on and set to Auto(WPA/WPA2) and Pre-Shared Key required with my Network Lock "Enabled" for maximum security.
    My WiFi Profile on my BB is set as follows:
    Connection Mode: "Automatic";
    Automatically obtain IP address and DNS: "checked";
    Allow inter-access point handover: "unchecked";
    SSID broadcasted: "unchecked"


    Wireless Mobile Network does not have to be turned on, nor even broadcasting a G or 3G signal in order for my WiFi to connect and surf the web, etc on my home or work network routers. It can be turned off, but you will not be able to receive calls of course if it is. I always leave my Mobile Network turned on and set to "Automatic" selection mode and Network Technology set to "1XEV" when not traveling outside USA.

    These settings are left this way all the time and I do not have to enter anything manually after my WiFi Profiles are set with the SSID Name, Band (802.11b/g), Security Type (Pre-Shared Key PSK) and my PSK Key (26 letters/numbers) have been entered and saved. My phone automatically finds and connects to each network based upon my location when I am within range of them. I have my Browser set to "Internet Browser" and not to "Hotspot Browser" for connecting to these wireless networks.
    I'm very new to wifi having just gotten the Bold. Where are those various settings? When I have connected to my home router, I have had to take actions to do so and then I only see a dash/hyphen and not the Green Checkmark for the connection.

    The manual contains very little helpful information for us wifi newbies.
    06-27-10 02:19 PM
  6. mikeplus1's Avatar
    Got to Options>Wi-Fi>Saved Wi-Fi Profiles>YourWirelessNetwork Name and while it is highlighted, hit the BB Menu button, then highlight and press Edit and it brings up the Wi-Fi Profile page, scroll down to those settings that may need to be changed.
    06-27-10 02:52 PM
  7. FF22's Avatar
    Ah, thanks. Too many places to look for things. I was in Manage Connections.

    Now, if you don't mind another question:

    Was just at a coffee shop, well, espresso, of course, and they had free wifi. I decided to give it a try. NOPE - I came up with one wep-private site. I refreshed and that one was gone and came up with another private site. My friend turned on some T-mobile phone (with his at&t sim card) and he found the coffee shop's wifi. I refreshed 3 more times and it would come up with one or both of those private sites but never did find the coffee shop. I possibly can see those private sites coming and going since they might be a bit remote from where we were.

    Ideas? Is the Bold a bit slow on the uptake? How come it could not find the site where we were sitting?
    06-27-10 07:08 PM
  8. mikeplus1's Avatar
    I just left coffee house (cappuccino) and my Bold found their wifi no problems. Read through all of my settings above.
    And check in here: CrackBerry Wi-Fi Forums

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by mikeplus1; 06-27-10 at 09:37 PM.
    06-27-10 08:49 PM
  9. FF22's Avatar
    I have not been to a coffee house yet today but it did connect me to the wifi at work. And I tested another feature I had heard about - using the phone on a call while continuing to browse - IT WORKED. I opened the browser and it showed I was on the free wifi at work (not a work related wifi) and I cruised to a page. Then I dialed my phone, answered the call and while still on the phone, continued to browse links on the web.

    I may get the hang of this yet.

    Thanks for the help, Mike.
    06-28-10 01:08 PM
  10. mikeplus1's Avatar
    Mine shows connected as soon as I pull into the parking lot at work and when I get in the driveway at home, whether I am talking on the phone or not.
    06-28-10 01:22 PM
  11. HawkBass's Avatar
    Hey guys..question. I have the same problem. The BB detects the Wifi Network, tries to connect and keeps telling me ''Unable to Connect. Reason : W010: Wi-fi Connection failed. And it does this with every network...even if im right next to router in my friend's cafe or at home. Any suggestions? Thanks
    08-19-10 06:05 PM
LINK TO POST COPIED TO CLIPBOARD