1. heckj's Avatar
    I've had this issue with all my blackberry's in the past including my 9700. If I turn off wifi I can stream youtube. If I turn on wifi I can't stream youtube. I get the green word loading and thats it. I figured the new os would fix this in my situation but it still does not work. I'm assuming it has something to do with my router. I have a verizon fios modem attached to a apple airport extreme wireless router. Webpages on the 9700 work fine on wifi. Does anyone know why this could be happening or how to fix it?

    Thanks
    11-19-09 11:20 PM
  2. DaveInVan's Avatar
    Anybody have a solution to this? I have the exact same problem. I'm wondering if it's a carrier problem or some device setting that needs to be changed?
    11-20-09 01:08 AM
  3. Chop's Avatar
    Personally, I can't do ANYTHING when my wifi is active. No Facebooking, no Twitter, no BeeJive... I always wondered what was up with that. Never tried streaming videos, but I would have to assume that wouldn't work as well. Like it was said, it's been like that on every BB I've owned, so I doubt it's a device issue. Could be as simple as me not fully understanding how the wifi is designed to work on these phones, although I think I understand - if it's as simple as it SHOULD be.

    Ehhh... easier to turn it off and just go. (for me)
    11-20-09 01:17 AM
  4. heckj's Avatar
    I think it has to be a wifi router setting. I just don't know which one.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-20-09 01:23 AM
  5. winnersmw's Avatar
    Same with my storm2 except its happening on all routers , I would really like a fix though

    Posted from my CrackBerry at wapforums.crackberry.com
    11-26-09 11:31 PM
  6. Vidge's Avatar
    I had this problem and even worked through it with Blackberry folks (when I had a 8900). The problem ended up being my router. Once I changed my router, the problem went away.

    If you search the forums, you'll find some router settings to try.
    11-26-09 11:42 PM
  7. Igotsoul4u's Avatar
    wifi works fine for me when using xenozu.
    11-27-09 01:59 AM
  8. paddy538's Avatar
    works for me too! when I'm on wifi i just have to make sure I'm using the hotspot browser! then all works!
    11-27-09 09:13 AM
  9. stillhere153#CB's Avatar
    just turned mobile network off... top corner displays UMA... typed in youtube.com

    and was able to get full playback with no loading
    11-27-09 11:43 AM
  10. ernstero's Avatar
    I was having the same problem wifi good for web, not good for youtube, turned wifi off youtube worked. I connected to my router and went into the DMZ settings and added my BB ip address, presto! no more issues with you tube over wifi. Hope it works for you.
    airbrnetravel likes this.
    11-27-09 10:24 PM
  11. lilmama88's Avatar
    i'm having this same issue.....i've tried just about everything but nothing has seemed to solve the problem...

    =/
    11-27-09 10:27 PM
  12. msaririan's Avatar
    I was having the same problem wifi good for web, not good for youtube, turned wifi off youtube worked. I connected to my router and went into the DMZ settings and added my BB ip address, presto! no more issues with you tube over wifi. Hope it works for you.
    ^^^^

    The problem is not the phone, but the router! Your firewall setting is preventing youtube streaming. Either follow instructions above (play with DMZ settings and add BB ip address) OR turn firewall off entirely!
    11-28-09 12:09 AM
  13. joeybuckets's Avatar
    ^^^^

    The problem is not the phone, but the router! Your firewall setting is preventing youtube streaming. Either follow instructions above (play with DMZ settings and add BB ip address) OR turn firewall off entirely!

    how do i find my bb ip address
    11-28-09 09:40 PM
  14. ernstero's Avatar
    how do i find my bb ip address
    go to options/status, there will be your ip at the bottom add it to your dmz settings in your router config page.
    11-29-09 12:04 AM
  15. cazwell220's Avatar
    Great advice guys... I can confirm that not being able to stream youtube over a wifi connection has something to do with the routers firewall.. I did add my bb to DMZ and it resolved the issue, but my question is ... what if I have more than one bb in the house. I can't add more than one ip to the dmz. Does anyone what port is being blocked?

    Thanks for figuring out the issue either way though!

    Mark
    11-29-09 01:31 AM
  16. bdearen's Avatar
    Hmm first off if you have FIOS there is no modem. We at verizon give out routers with fios service

    Posted from my CrackBerry at wapforums.crackberry.com
    11-29-09 01:33 AM
  17. airbrnetravel's Avatar
    Well old thread but if someone come here I just added my bb ip to the dmz and youtube now streams over wifi!

    Go to your router "log" and it should show blackberry and the ip address when you connect.
    06-13-11 05:48 PM
LINK TO POST COPIED TO CLIPBOARD