1. era3z's Avatar
    Have checked the similar threads about WiFi, and didn't find any answer... Wanted to post there, but I don't think people will answer and I use Torch which uses OS 6.0 that no longer need hotspot browser...


    Okay.. the problem is :

    I can't browse via BB browser when I'm on wi-fi.... but others are fine... BBM are good to go, I can twit via twitter for BlackBerry, I can access my FaceBook... there are no problem except the Browser...

    And... if I disable my Mobile Network and only connect to my WiFi, I can't access a thing....


    Anyone have a solution for this? thanks in advance
    12-16-10 09:36 AM
  2. homer1475's Avatar
    means your not connected to wifi. If you turn off your radio and you get nothing, wifi is not connected. have you tried a battery pull?
    Also look in manage connections > service status and see if you have BIS(blackberry internet service) connectivity. If your connected to wifi for data your BIS connection will say WIFI and not AT&T.
    12-16-10 09:38 AM
  3. escobar973's Avatar
    I was always under the impression you needed to be connected to a mobile network in order for wifi to work...

    Posted from my CrackBerry at wapforums.crackberry.com
    12-16-10 09:43 AM
  4. homer1475's Avatar
    I was always under the impression you needed to be connected to a mobile network in order for wifi to work...

    Posted from my CrackBerry at wapforums.crackberry.com
    No you can turn off your radio and still surf the net via wifi if connected. Some apps that use BIS will not work properly, but net surfing can be done.
    12-16-10 09:48 AM
  5. PatrickMJS's Avatar
    I disagree. Access via wifi and/or the mobile network can be turned on or off independently using the checkboxes under "Manage Connections".

    But there is an extra setting to be aware of...

    check the "data services" setting - you get to it by selecting "Mobile Network Options" under the "Set Up, Services and Options" heading (lower down on the same page as "Manage Connections"). You need to leave the "data services" set to "On" in order for wifi to work accessing the Blackberry Internet Service, "BIS", even if the mobile network radio is turned off.

    If you uncheck the "mobile network" checkbox under "Manage Connections", yes, you lose data access and also phone calls and text messages.

    If you leave this box checked, you get your phonecalls and text messages, but you'll only get BIS access if you ALSO have "data services" set to "On" under the Mobile Network Options.

    If wifi is turned on and the mobile network is turned off, the "data services" needs to be on in order to get BIS to work over wifi.

    Sounds complex but it gives users a lot of choices about how to manage their connections.
    12-16-10 01:53 PM
  6. AcADIeN's Avatar
    if you have UMA, with UMA you can disable Mobile Network and still received call and text via wifi.
    12-16-10 02:11 PM
  7. escobar973's Avatar
    This is the only way it worked for me.. "If wifi is turned on and the mobile network is turned off, the "data services" needs to be on in order to get BIS to work over wifi."...
    12-16-10 02:34 PM
  8. era3z's Avatar
    I also thought I wasn't connected correctly to my WiFi, but when I test my BBM, twitter, and FB, and also appworld, the connection is faster than my BIS + the WiFi symbol is white not grey....

    Let's say it is like what you said homer1475, but why every time I turn on my wifi (and consider it is not connected), I can access the apps with internet connection, but I can't browse at all? and when I turned off the wifi (which is not connected), I still can access the apps with internet connection + I can browse... I don't know about this >.<

    Yes the data service is stayed On when I try to set my Mobile Network to off...

    Don't know how to solve this problem........ >.< help moiiiii T__T
    Last edited by era3z; 12-17-10 at 03:25 AM.
    12-16-10 05:52 PM
  9. branflakes's Avatar
    Check your "Service Status" to see what all the services are connected to when you're on your Wi-Fi. Tap the top of your screen to bring up the network settings, scroll to the bottom where you'll see Service Status. Look at what BIS and other items are connected to.

    If you do have Data Services on and you're properly on the Wi-Fi, you should be able to browse on WI-FI only.
    Last edited by branflakes; 12-16-10 at 06:05 PM. Reason: misspellings
    12-16-10 06:03 PM
  10. era3z's Avatar
    Check your "Service Status" to see what all the services are connected to when you're on your Wi-Fi. Tap the top of your screen to bring up the network settings, scroll to the bottom where you'll see Service Status. Look at what BIS and other items are connected to.

    If you do have Data Services on and you're properly on the Wi-Fi, you should be able to browse on WI-FI only.
    BIS : Connection : wi-fi and mobile network (I see it changes every minute between wi-fi and mobile network) maybe this is the problem? when I turn of the mobile network the connection changes to wi-fi

    Wi-Fi network : Active profile : my wifi..
    Last edited by era3z; 12-17-10 at 03:32 AM.
    12-17-10 03:22 AM
  11. era3z's Avatar
    Fixed........ found the answer in bbos... from madasafish

    -----------------


    I assigned a static DNS and that did not help... at first...


    But when i checked the box marked "Allow inter-access point handover" at the bottom of the WiFi network screen it started to work perfectly.
    At last everything on my Torch is working wonderfully.
    12-17-10 07:30 AM
  12. homer1475's Avatar
    Fixed........ found the answer in bbos... from madasafish

    -----------------


    I assigned a static DNS and that did not help... at first...


    But when i checked the box marked "Allow inter-access point handover" at the bottom of the WiFi network screen it started to work perfectly.
    At last everything on my Torch is working wonderfully.
    I assign a static IP to everything on my network. Your other option you found(allow inter-access point handover) I don't even have on my torch, so I'm assuming your overseas?
    12-17-10 07:49 AM
  13. era3z's Avatar
    I assign a static IP to everything on my network. Your other option you found(allow inter-access point handover) I don't even have on my torch, so I'm assuming your overseas?
    Yes.. I am from Indonesia... and madasafish from BBoS is from UK =)
    12-17-10 08:15 AM
LINK TO POST COPIED TO CLIPBOARD