1. jskinvest's Avatar
    Somebody sent me a contact card. I added it to my address book but now I cannot edit it or delete it. I get the error message: "Contact updated externally, changes will be lost and viewer closed". I have tried a battery pull and researched solutions but nothing works. Please advise. Thank you.
    04-19-10 09:44 PM
  2. jeffh's Avatar
    I ran into that problem almost two years ago. Here's the thread: http://forums.crackberry.com/f61/jav...upgrade-42622/

    Good luck. You're going to need it.
    04-19-10 10:09 PM
  3. jskinvest's Avatar
    I don't want to wipe the whole device clean for just one corrupt contact entry. Is there another way?
    04-19-10 10:13 PM
  4. jeffh's Avatar
    You can get lucky and find the one bad contact. You might try working backward from recent entries, if you know what you've recently added. There's no way to my knowledge to get the contacts sorted chronologically by order of entry.
    04-19-10 10:24 PM
  5. jskinvest's Avatar
    There is only one contact that will not delete or edit. I know which one it is. I cannot remove it. What do I do?
    04-19-10 10:26 PM
  6. jeffh's Avatar
    Did you look at post #28 in my thread? That's how I finally solved the problem in my case.
    04-19-10 10:29 PM
  7. jskinvest's Avatar
    Yes I saw that. I am not on BES though. I cannot sync that contact or edit or delete it. Any other ideas?
    04-19-10 10:33 PM
  8. jeffh's Avatar
    You can always use the Advanced Backup and Restore option in Desktop Manager to clear just the address book database. Then you can restore it from a good backup. All you will lose are the entries made since the last good backup. Whether that's practical will depend on how current your good backup is.
    04-19-10 10:38 PM
  9. jskinvest's Avatar
    I just tried that. I cleared the address book. Every address was deleted except for the corrupt one. It was still there. Any other ideas?
    04-19-10 10:48 PM
  10. jeffh's Avatar
    If you restore a good address book, it should overwrite the corrupted one. That's my last idea.
    04-19-10 10:51 PM
  11. jskinvest's Avatar
    I tried that. I restored the good address book, replaced all the addresses on the device, but that corrupt entry was still there.
    04-19-10 10:54 PM
  12. Jiggavel's Avatar
    i have the same problem i think it never deletes
    04-20-10 09:27 PM
LINK TO POST COPIED TO CLIPBOARD