1. annakelly425's Avatar
    I recieved a ipod 4th generation which cannot get ios7. I tried to download bbm on appstore but it said i needed ios7. I wonder if there is any site that i can download an older version of the app. Any advice would be very much appreciated!
    02-17-15 03:35 PM
  2. diegonei's Avatar
    Really sorry but I don't think they even want BBM on iPods. I am almost 100% sure it cannot be done.
    02-17-15 04:37 PM
  3. Elephant_Canyon's Avatar
    Even if you jailbroke your iPad and sideloaded BBM, it still wouldn't run. It's not an arbitrary issue with the store, the app itself needs iOS 7 or later to work.
    02-18-15 06:57 AM
  4. kye2000's Avatar
    The early versions were able to run on it

    Posted via CB10
    02-18-15 06:59 AM

Similar Threads

  1. New Classic displays message 'Device is network locked'
    By Ay Emmanuel in forum Ask a Question
    Replies: 17
    Last Post: 11-12-16, 10:27 AM
  2. Why hasn't my game finished downloading?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-18-15, 01:30 PM
  3. How many BBM users are there worldwide?
    By Dat Gui in forum BlackBerry Passport
    Replies: 6
    Last Post: 02-17-15, 09:31 PM
  4. BBM Not Secure?
    By sjwpenney in forum General BBM Chat
    Replies: 2
    Last Post: 02-17-15, 01:27 PM
  5. Can I delete tweets in a block instead of one at a time
    By darinmusic in forum Ask a Question
    Replies: 1
    Last Post: 02-17-15, 12:53 PM
LINK TO POST COPIED TO CLIPBOARD