1. moofed's Avatar
    I have a blackberry curve 9300 (3g). It can connect to other peoples wifi's but just not my own!!!!

    I tried changing my router many times but it just doesn't work. It finds, and connects to my network but there is no internet when I try to use it.

    In wifi diagnosis: it says network acquired and -39dbm signal with an ip. but in the VPN section, everything is blanked out and it says VPN profile not found at the bottom.

    Does anyone know how to fix this? I've tried WEP, WPA, WPA2-AES / TKIP.

    One thing i did notice was that when i set my router to open, it does an "internet detection count down" but still doesn't give me internet.

    EDIT: when i found out my ip, it's slightly different than the diagnostics one.
    the last digit is off by 2. so instead of 2, it's 4 on my bb

    and again, it works at my friends house, so I'm pretty sure it's my router's settings. I have the asus rt-n11 ez wireles router.

    any help greatly appreciated.
    Last edited by moofed; 12-18-10 at 09:03 PM.
    12-18-10 08:59 PM
LINK TO POST COPIED TO CLIPBOARD