1. SammyLeopold's Avatar
    Recently, my curve 8300 has been having a problem connecting with Tmobile. Sometimes it wont send or receive calls, texts, emails, etc. but sometimes it will. I called Tmobile support, they have tried kicking me off the network so I reconnect properly, having me try a battery pull, and reinstalling the OS. I have even tried my SIM in another phone and it worked fine. Tmobile now says that I need a new BB. However everything else on my phone works fine. The only issues seem to be this connectivity. Sometimes where the signal indicator is I see it display at different times: EDGE, edge, GSM, SOS, off. So my question is, can the connection functionality of a BB just stop working? Do I need to get a new BB or is there something else I should try? I have been experiencing this problem for approx. 2 days now. Thank you very much.
    03-06-10 04:06 PM
  2. johnling's Avatar
    If you want a phone that will conect you should exchange it as they offered to do.
    03-06-10 04:49 PM
  3. elvin1983's Avatar
    If you want a phone that will conect you should exchange it as they offered to do.
    Agreed, it may not be software related, the radio itself may be defective. Sometimes it happens...

    Posted from my CrackBerry at wapforums.crackberry.com
    03-06-10 04:56 PM
  4. hamanwho's Avatar
    how old is your phone?
    03-06-10 04:58 PM
  5. SammyLeopold's Avatar
    my phone is about 2 years old, they didn't offer to exchange, they told me to purchase a new one. Which is why I was skeptical. Were they just tired of troubleshooting and trying to get me to purchase a new BB, or am I really out of options now? Thanks!
    03-06-10 05:02 PM
  6. MrObvious's Avatar
    I honestly think they are right. The phone went pfft.
    03-07-10 12:55 AM