06-01-10 07:42 PM
105 123 ...
tools
  1. Coosh's Avatar
    So heres the scoup, I just recently switched from a pearl to a 8330 on telus. The pearl my gps just "worked", and worked amazing in buildings and everything. I am on my second 8330, first one gps was not working so I wipe'd it to only realize there was no OS posted yet for it. So I got it exchanged today, same deal with the new one. The GPS will not aquire a signal.. I spoke with some other curve users on rogers, they are running 4.2 and it works like the pearl for them. They have a refresh option in the advanced -> gps menu where I do not. I am wondering if other telus users were able to get it working correctly?
    04-10-08 01:30 PM
  2. javatyger's Avatar
    My guess is TELUS is blocking the use of it for some reason because they are trying to sell their Navigator software subscription along with it.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-10-08 02:06 PM
  3. mkgrahamBB's Avatar
    I can't connect to any satellites. I tried to call Telus and they were not helpful. I'm new to the blackberry, so I don't really know what I am looking for.
    04-10-08 04:27 PM
  4. Timewalk's Avatar
    The problem is with BB Maps, and the new 8330 Curve on Telus..

    I can use google maps with my 8330, and it works fine..
    04-10-08 05:17 PM
  5. Coosh's Avatar
    I tired google maps, on my pearl it would find me within 10-20 meters every time. Using it on the curve it finds me with in on average 1700meters.
    04-10-08 05:41 PM
  6. mkgrahamBB's Avatar
    Yeah me too at best 1700 meters and it shift from one location to another with a huge margin of error.
    04-10-08 07:06 PM
  7. wolff46's Avatar
    mine works perfectly i just got the bell 8330
    04-10-08 07:11 PM
  8. Timewalk's Avatar
    Sorry to go off topic a bit here. But has anyone transferred files to their MicroSD cards on their 8330?
    I took me about 5-10 seconds to transfer 500MB of files, it took me at least a minute to do that before..
    Very, very fast...
    04-10-08 07:33 PM
  9. Schmiesus's Avatar
    Gps isn't working with google maps its using cell towers to find you. I am really pissed off about the gps on this phone. They should be required by law to say it only works with the navigator. Has anyone actually tried the tes version of telus navigator to see if the gps works.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-10-08 10:14 PM
  10. bokyo102's Avatar
    mine works perfectly i just got the bell 8330

    Bell already released the 8330?
    04-10-08 10:42 PM
  11. soarin's Avatar
    I have been using the GPS for the last 2 days.. I am using it with BB Maps (havent tried Google Maps yet...haven't had the need to) and it works fine... there are two tricks I have found...

    First: It does take a few minutes to find enough satellites for a GPS fix. Remember that it takes at least 3 satellites for a good location fix. The more the better... (usually around 7 or 8) and more accurate the location fix will be. Be patient, it will connect. (Or at least it has for me!)

    Second: Be outside and motionless when you start the GPS up!

    GPS just like any other wireless technology is affected by EVERYTHING under the sun (actually, including the sun LOL) things like weather conditions, being inside a building, being in motion when trying to get a fix, orientation of the antenna, u name it... honestly.. everything. Also, its dependent on power supply, speed of the data network, other signals hitting the satellite etc etc. Remember that the GPS in this device is not as strong as a purpose specific unit (such as the GPS devices available for driving, flying, hiking etc) ... its a "nice to have" in this device.

    Now.. I could be totally wrong.. LOL.. perhaps some devices are defective... then again.. sometimes we all just need to make sure our expectations are in check

    Cheers all!
    04-10-08 10:42 PM
  12. Schmiesus's Avatar
    well i downloaded the trial version of telus navigator and it works just fine so i think they have tried to cripple the phone.

    Pisses me off.
    04-10-08 11:11 PM
  13. soarin's Avatar
    Weird... mine is working just fine ... connected and disconnected probably 20 times in the past 48 hours... finds satellites each time and stays connected when i want it too... maybe its quirky... LOL ... but so far so good here...
    04-11-08 12:22 AM
  14. Coosh's Avatar
    I will try navigator but second 8330 and still no signal in a massive empty parking loit with clear blue skies..

    Posted from my CrackBerry at wapforums.crackberry.com
    04-11-08 01:58 AM
  15. Coosh's Avatar
    So telenav works and picks up the gps.. bb maps still no luck... Telenav is a 30day trial then subscription I do think that is kinda low if telus did block it to sell that...

    Posted from my CrackBerry at wapforums.crackberry.com
    04-11-08 03:22 AM
  16. pozi240's Avatar
    Well, I too upgraded to a 8330 yesterday, and yep, no sattelites are found (BB maps loads up fine), and everything else works wonderfully. Will play it again later today, but I have a feeling I will be doing the exchange thing "again" (it took me 3 8130 Pearls to get a "good working" GPS). And the whole "wait several minutes" and "these devices don't have a strong GPS" is total BS. With my Pearl (which is a smaller form factore), the GPS worked as well as my TomTom for accuracy and it aquired 9-14 satellites almost immediately and even inside very large buildings, no issues at all! I'm thinking Telus was so quick to get the 8330 released before anyone else, we have a few "bum" units going out.........it happens. But Telus is NOT locking down thier GPS. This has been confirmed with corporate and they haven't locked it down on any of the other model BB's.
    04-11-08 08:35 AM
  17. Timewalk's Avatar
    Yaa, something is definately up..
    It works fine at my house, i changed location , BB Maps can't even find Satellites and Google Maps isn't accurate at all..

    I have not tried Telus navigator, i really didnt care for it last time i tried it..
    04-11-08 08:42 AM
  18. mkgrahamBB's Avatar
    Went to my dealer today and they said that the telus curve might not be fully activated yet. It was supposed to be launched may 5th so not everything could be ready. I still think I have a defect curve. I left mine outside for 45 mins and I had no lock on any satelites.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-11-08 12:08 PM
  19. Timewalk's Avatar
    Went to my dealer today and they said that the telus curve might not be fully activated yet. It was supposed to be launched may 5th so not everything could be ready. I still think I have a defect curve. I left mine outside for 45 mins and I had no lock on any satelites.

    Posted from my CrackBerry at wapforums.crackberry.com
    Well, its affecting pretty much all of us.. So lets hope the Telus rep is right...
    04-11-08 12:11 PM
  20. Schmiesus's Avatar
    I resent my service books yesterday. (not sure if this is what did it) And i got bb maps to work. took a min to connect but it started pulling 12 sats. Don't know if was the service books or if because i downloaded the trial of the telus navigator
    04-11-08 12:13 PM
  21. wolff46's Avatar
    Bell already released the 8330?
    today, the 11th it was released, except for my store, in which our first 2 were given to me and a friend early
    04-11-08 12:35 PM
  22. Wirelezz's Avatar
    MIne works perfect ! i even tested it today with the heavy rain and ragtop up on the car, GPS navigations 100 percent !! Google maps needs a fix for internal GPS, it only works of towers, this was a 8130 pearl isue as well and google will release a fix for the gps.
    04-11-08 02:03 PM
  23. soarin's Avatar
    Hey everyone...

    Mine is still working fine... I am giving it a major workout... connecting it.. driving from one meeting to another... one set of errands to another... it finds satellites and keeps up in real time... working like a a dream. I disconnect ... do some stuff... re-connect when I want to and never a problem.. always between 7 and 12 satellites... and at work earlier this morning.. it connected while I was in our basement (which has walls of concrete several feet thick)...

    Did I just get lucky?
    04-11-08 04:03 PM
  24. Coosh's Avatar
    So I now have telenav installed it works and have played with it. It works as well I would expect bb maps to work and as well as my pearl did with bb maps, which was amazing. I finally gave up but before I went to bed last night I gave it another go and tried to connect, bb maps for the first time ever got signal with 7 sats I disconnected, then reconnected, it connected ok. This morning on the way to work I tried again and no go. I would lead to believe that telus did not lock them out and more of just a software glitch.
    04-11-08 04:15 PM
  25. pozi240's Avatar
    Ok, so, I think I found a "common link" in the glitch with our new Curves. If you d/l TELUS Navigator (or another 3rd party GPS program) , your GPS will start working. Even after closing Navigator, BB Maps will now find satellites right away! I did call TELUS DNA, and they say its a known issue with the GPS, and gave me a line about the OS (4.3) being so new, some features are not fully working on the network yet. (Hence the reason Verizon and Sprint are delaying their release supposedly). Hmmmmm, well, I wonder if they will actually "fix" this glitch, or maybe give us free access to Navigator (after the free trial expires).......hmmmm, yeah right.
    Last edited by pozi240; 04-11-08 at 05:06 PM.
    04-11-08 04:26 PM
105 123 ...
LINK TO POST COPIED TO CLIPBOARD